Support in other languages: 
Reply
What's DOS?
dpb642
Posts: 1
Registered: ‎10-04-2011
Location: New Hampshire
0

Problem installing XP Pro in AHCI mode on M91p tower.

Hello everyone,

 

I am hoping someone can help me with this very annoying problem. I just received a new M91p desktop and I am trying to install Win XP SP2 in AHCI mode but the install crashes on me (BSOD). I verified the storage drivers under Windows 7 before I attempted to wipe it out and it was listed in Device Manager as the Intel Desktop/Workstation/Server Express SATA AHCI Controller. I copied the iaAHCI.inf, iaAHCI.cat, iaStor.cat, iaStor.inf, iaStor.sys, and TXTSETUP.OEM to floppy and attempted the pre-install F6 method but the install still crashes soon after the drivers load. I must not be using the correct AHCI drivers or something. Does anybody know where I can get the correct Intel AHCI drivers for the new M91p desktops? Any help would be much appreciated.  

Community Moderator
zoltanthegypsy
Posts: 3,351
Registered: ‎01-13-2008
Location: Bainbridge Island, WA, USA
0

Re: Problem installing XP Pro in AHCI mode on M91p tower.

[ Edited ]

Did you copy those files from the Win 7 install?  Perhaps that _should_ work - I don't know.  Does it behave any better if you use the files from the Lenovo page for your machine?

 

http://download.lenovo.com/ibmdl/pub/pc/pccbbs/thinkcentre_drivers/c1rau12us17.exe

http://download.lenovo.com/ibmdl/pub/pc/pccbbs/thinkcentre_drivers/c1rau12us17.txt

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.

 

The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored. ... GeezBlog

English English Community   Deutsche Deutsche Community   Español Comunidad en Español   ru.gif Русскоязычное Сообщество

Ctrl-Alt-Del
solr_07666
Posts: 10
Registered: ‎10-22-2011
Location: USA
0

Re: Problem installing XP Pro in AHCI mode on M91p tower.

I am working on the exact same problem.  I create a Floppy for the drivers pressed F6, and it detected the drivers.  The install CD I was using was a Dell XP PRo SP2 and it said "the drivers you selected are newer than the ones on the CD", but I went with the new one. I got three choices, I picked the Express chipset, and it crashed with a blue screen.

 

If you turn of AHCI and set it to IDE it will allow the install to work.

But then you wont be able to setup RAID.

 

Sol

Paper Tape
JasonSh
Posts: 3
Registered: ‎11-15-2011
Location: United Kingdom
0

Re: Problem installing XP Pro in AHCI mode on M91p tower.

Seems the same as the problem i've posted about for the M71e. 

 

The downloadable drivers (including the iastor files), simply don't fix the issue.  In AHCI boot mode, the pc will just reboot after the windows screen and you just get a 7b error when attempting to F6 boot it using the diskette containing the files.

What's DOS?
dacer
Posts: 1
Registered: ‎02-20-2012
Location: QATAR
0

Re: Problem installing XP Pro in AHCI mode

Hi, my laptop is based on Interl HM65 chipset with SATA AHCI Controller enabled.

I am trying to install Xp with F6 but when I select the Driver SATA RAID driver every time I come accross BSOD  0x0000007E can any body help me what is the reason for Xp install fail.