Support in other languages: 
Reply
Paper Tape
pschreber
Posts: 3
Registered: ‎11-26-2009
Location: Germany
0

S50 (8183-K83): unable to detect entire hard disk size (1000 GB)

Hi everybody,

 

I'm trying to install a Samsung 1000 GB SATA hard disk in my ThinkCentre S51. It's the only hard drive in the machine, and I've successfully installed WinXP SP3 onto it. However, when formatting the disk during XP's setup, only some 130 GB were detected.

 

So I created a 20 GB partition for Windows, hoping it would find the remaining 980 GB afterwards, using the "EnableBigLBA" registry trick (MS knowledge base 303013). But I discovered that, unfortunately, as my XP already comes with SP3, that trick is unnecessary, for BigLBA is enabled already (the tool from 48bitlba.com confirmed that). A BIOS update was no help either. Windows's disk manager still lists the unpartitioned space as 110-something GB.

 

So, any help would be appreciated -- maybe the size limitation lies with the hardware? I found a "maximum hard drive size matrix" at lenovo.com for the Aptiva series, but none for the ThinkCentres...

 

thanks in advance, best,

 

Paul

Paper Tape
pschreber
Posts: 3
Registered: ‎11-26-2009
Location: Germany
0

Re: S50 (8183-K83): unable to detect entire hard disk size (1000 GB)

[ Edited ]

PS: the hard disk is a Samsung HD103UJ, BIOS version is 2AKT51AUS. I just called Lenovo and they said it »might be« (!) that the computer is too old to detect a hard disk larger than 130 GB...

Token Ring
MacX
Posts: 77
Registered: ‎04-28-2009
Location: Bavaria Germany
0

Re: S50 (8183-K83): unable to detect entire hard disk size (1000 GB)

Hi

 

definitely not too old to detect a hard disk larger than 130 GB

 

check this out: There might be a barrier above 500GB, SATA and PATA together might be a problem

http://forums.lenovo.com/t5/E-S-series-ThinkCentre-Desktops/IBM-S50-8184-640-GB-Sata-Drive/m-p/56098

 

I fitted a Hitachi 250 GB IDE disk into a 8183-21G - worked  just fine, no problems with XP

 

Cheers

 

Punch Card
Grinder
Posts: 109
Registered: ‎11-19-2008
Location: NYC USA
0

Re: S50 (8183-K83): unable to detect entire hard disk size (1000 GB)

Hi i have a 931GB(SATA) drive running on my S50-8183 but i used G parted,  from a puppy linux live CD to format the disk,then acronis true image to copy the 40 gig IDE drive pluged in the drive ((1GB) (windoz set up the hardware for me)  It still works no problems, 6 or 8 months now

Paper Tape
pschreber
Posts: 3
Registered: ‎11-26-2009
Location: Germany
0

Re: S50 (8183-K83): unable to detect entire hard disk size (1000 GB)

[ Edited ]

 


Thus spake MacX:

 

SATA and PATA together might be a problem

 


 

Bingo! Thanks a lot... I can't believe it, but I disconnected the DVD drive (PATA), and all of a sudden it worked. XP recognized the complete disk, I could partition and format it. Now everything's fine, except I can't use my DVD drive. When I re-connect it, I get a Blue Screen of Death during XP startup. And I'm afraid this also means I won't be able to connect my old PATA hard drives to copy my stuff onto the new one. I guess I have to get a SATA DVD drive and an IDE-USB adapter, don't I?

 

Punch Card
Grinder
Posts: 109
Registered: ‎11-19-2008
Location: NYC USA
0

Re: S50 (8183-K83): unable to detect entire hard disk size (1000 GB)

again i had no problems copying the ide drive to the sata, the optical disk was running linux live cd at the same time (check bios)

Punch Card
Grinder
Posts: 109
Registered: ‎11-19-2008
Location: NYC USA
0

Re: S50 (8183-K83): unable to detect entire hard disk size (1000 GB)

oops i forgot tap F12 while booting,and tell machine to boot from your hard drive it will proably detect the cd drive