Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
henge
Posts: 5
Registered: ‎12-04-2011
Location: Germany
0

A1 - WiFi with display off?

I have this problem with my new A1:

I switched WiFi standby policy to "never" (so that a connection should be maintained all the time). When the screen turns off now, my router shows that the connection is kept.

BUT, while screen is off, I don't get any notifications (email, chat, etc.)

Also, when I turn the screen on again, there is a short glitch in which the WiFi symbol in the status bar becomes white for a split second (no connection to Google?), but immediately turns green again. At that time, my router log file shows a newly established WiFi connection, yet no logoff prior to that...

I don't have such problems with my Android phone, so it must be A1-specific...

 

Anyone any clues?

802.11n
ricochet_k1
Posts: 159
Registered: ‎11-25-2011
Location: Bay Area
0

Re: A1 - WiFi with display off?

[ Edited ]

I think its possible you are describing two issues here. Standard behavior, your router's log isn't going to show disconnection for a device, even if the device disconnects prior to the DHCP lease time expiration. It will however log a new connection if a device has lost connection for any reason after timing out. If the same device reconnects prior to the lease expiration, it will get the same IP address based on its MAC address. If the lease has expired the router will assign it a new IP. I would suggest that you verify your DHCP lease time settings on your router. On the A1, if your wi-fi disconnection ploicy is set to never and your wi-fi adapter is losing connection, its either losing its lease based on lease time settings on the router or you've possibly found a bug in the OS on the A1.

Thanks,
Ricochet_K1
K1_A301_14_14_120109_US
Paper Tape
henge
Posts: 5
Registered: ‎12-04-2011
Location: Germany
0

Re: A1 - WiFi with display off?

Thanks for your thoughts!

You're probably right concerning the behavior of the router, but still there is a problem that I think has its origin in the Android firmware on the A1. When the tablet established a WiFi connection and I turn off the screen (no matter how long after initializing the connection), the think doesnt make a sound when I send an email to myself. When I do that while screen is on (and WiFi connection present) I get a notificaiton immediately.

 

Curious:

When I set up my WiFi as hidden in the router (do not broadcast SSID), the tablet loses connection for sure when screen turns off. Then it takes a good deal longer to re-establish the connection, when I turn it on again. With visible SSID there is only a short glitch...

What's DOS?
dcossey014
Posts: 2
Registered: ‎01-05-2012
Location: Ruston, LA
0

Re: A1 - WiFi with display off?

[ Edited ]
This is not just a bug with the A1. I have the same problem with my Thinkpad tablet. I think it's a problem with Android. Mine stays connected for about 10 minutes after the screen turns off. I've checked my router settings and my lease times are set to the maximum for WPA2 encryption. I have my router set to hidden SSID and after my tablet drops the connection, it takes about 10 seconds to reconnect. I'm getting kind of tired of this, because it makes using Google Music very frustrating that I have to reconnect my tablet to internet every 10 minutes.

Oh yeah, I forgot to mention... I have all my advanced settings for WiFi set to not turn off if screen turns off
802.11n
sinanju
Posts: 236
Registered: ‎12-09-2011
Location: US
0

Re: A1 - WiFi with display off?

And in General Sync Settings you have both Background data and Auto-sync checked?