Support in other languages: 
Showing results for 
Search instead for 
Do you mean 

Yoga 2 Pro - Auto brightness feature and how to disable in Windows 8.1

Helpful?
Click ►
Started ‎10-31-2013 by
Modified ‎04-20-2014 by
(70,950 Views)

Yoga 2 Pro - Auto brightness feature and how to disable in Windows 8.1

Question

I have a Yoga 2 Pro system and the brightness on my screen is constantly adjusting.  This  is most obvious when making the move from the desktop to Metro. After hitting the windows key, I can see the brightness increasing in stages (about 4 times) after flipping over to Metro.

 

I have disabled Auto-Brightness under the Change My PC Setting -> Power and Sleep menu. I have also disabled Enable Adpative Brightness under Windows Power Mangement but the issue still persists.

 

Is there any other location I might be missing a setting that can be affecting this ? Brightness is set to full and keeps dipping down.

Answer

There are a few factors if your screen appears dim, or the brightness changes automatically and frequently.

 

You can check the three methods below to ensure the auto brightness adjustment feature is not enabled.

 

1) Brightness adjustment via Power and Sleep in Windows 8.1

You may wish to disable the Automatic Brightness setting in Windows 8.1.  This setting is enabled by default; however, some users may not wish to make use of this option.

 

To disable Automatic Brightness:

 

First, begin by swiping the right edge of the screen or touchpad to fly out the Charms bar


Next, tap 'Settings'


Now, in the bottom right corner, tap “Change PC Settings”

 

Y2P brightness 1.png

 

In PC Settings, tap "PC and devices"

 

Y2P brightness 2.png

 

 

Under "PC and devices", tap "Power and Sleep".   The Brightness setting allows you to toggle the automatic brightness feature on and off.  Simply drag the slide controll to the left to turn off.

 

Y2P brightness 3.png

 

2) Check your Intel graphic card properties

If you find that your screen continues to automatically adjust brightness, please try the following:

 

  1. Right click on the desktop and select "intel graphics properties." 
  2. Now, select the "on battery" tab and turn off "Display Power Saving Technology."  

 

This method was provided by user Supermax .

 

3) Check you Power Plan set in Power Option in Windows 8.1

 

Right click start menu in Desktop and choose Power Options.

Depends on the power plan you're using, select the "Change plan settings".

Set all the brightness according to your preference under "On battery" and "Plugged in" mode.

 

This 3rd method was suggested by user goldmaple


Comments
by Lenovo201402 on ‎02-12-2014 09:15 AM

I have the Lynx with the same issue. None of this works for me. The intel power option does not appear to on my system.

by Lenovo201402 ‎02-13-2014 08:06 AM - edited ‎02-13-2014 08:08 AM

I noticed the problem seems to only occur When the tablet is charging and then when the fluctuation seems to happen when its fully charge and the power light flashes to recharge again is almost a direct correlation. Is any one seeing this?

by TiloNovo ‎02-17-2014 04:32 PM - edited ‎02-17-2014 04:34 PM

For me I solved it via classic "Control Panel"

Control Panel\System and Security\Power Options\Edit Plan Settings

Change advanced power settings

> Display > Enable Adaptive Brightness > OFF

 

cheers

 The settings mentioned in this article was not available for me (due to domain policy / GPO)

by goldmaple on ‎02-24-2014 11:18 PM

I've been fighting this issue for a few rounds. By the time I arrived to the main solution suggested by this article, the option to turn off automatic brightness was disabled, perhaps because I'd adjusted the brightness settings via the traditional Windows menus to 100% and to never, ever dim.

 

I thought I'd conquered it, but tonight after a while on battery, it started to dim again. I also went to the classic "Control Panel":

 

Control Panel\System and Security\Power Options\Edit Plan Settings

Change advanced power settings

 

> Display > Display Brightness

>On battery: 100%

>On power: 100%

 

AND

Dimmed Display Brightnes

>On battery: 100%

>On power: 100%

 

AND

Enable Adaptive Brightness 

>On battery: OFF

>On power: OFF

 

 

by ellamac on ‎03-01-2014 08:22 PM

None have worked for me but found a solution.

FOR THOSE WHO HAVE WINDOWS 8.1 AND HAVE THE IDEAPAD FLEX SERIE:

(I'm not sure if this will work for others as well, try it..)

 

1) Follow the above instructions at the top

2) If it's still a problem, simply right click on the desktop

3) Selet the first option, which should be your processor's control center. 

4) Click Power > PowerPlay (could be different, I'm not sure but this option is where you edit what your processor does when on battery)

5) Simply check off Enabled VariBright which should be at the left of the adjustment screen brightness bar.

 

THEN YOU'RE DONE. 

by Supermax on ‎04-12-2014 12:47 AM

This one worked for me.

 

Apparrenly the culprit is the Intel Graphics Card and upon tinkering with the options. I think I've got it.

 

First I disabled the adaptive brightness on the power options, and disabled the brightness sensor on the "services.msc"

 

*Then I right clicked on the desktop.

*Clicked on " Graphics Properties"

*Clicked on Power.

*Then Disabled the "Display Power Saving Technology"

*Then clicked APPLY.

 

Now my display is not automatically dimming anymore. :smileyhappy:

 

brightness.jpg

by spiritfly on ‎09-25-2014 01:45 PM

Nothing of these worked for my Lenovo Yoga Pro 2 and I cannot stand it any longer. This si extremely frustrating and I can't see why Lenovo wouldn't react. Everybody is affected and they do not care. I have tried all the possible solutions suggested here and everywhere. No joy. I'm terribly dissapointed by lenovo and their attitude.

by Silverback on ‎11-01-2014 06:19 AM

Yea, great... it seems like these articles and suggestions come up in the forum, and then there is always someone that says "it didn't work but this solved it for me" which ammounts to setting the screen at full brightness all the time.  

 

LENOVO, HOW ABOUT FIXING THE ISSUE!!!  It definitly has something to do with power, in my case _the only_ thing that fixes it is either plugging in a power cord or closing the screen, reopening it and hitthing the power button to turn it back on (both are REALLY annoying if you're trying to get work done).  

I'm a fairly experienced IT guy, and I used to swear by _IBM_ Thinkpads and related laptops, then when they went to Lenovo a few years ago it seems like the support has gone to hell and the hardware appears nice but is sketchy (this thing should have never shipped with this display problem or the wifi card issues that it shipped with).  

 

Honestly if issues like this don't get resolved Im not likely to order any more, ever.  Not for my self or for my organization, we will stop persueing contracts with you and certifying the hardware for our work (though with the lenovo purchase it was deemed that the hardware wasn't certifyable for certine applications anyway).  Yes, that will cost you a few thousand sales a year, which is  a drop in the bucket for you, but I'm sure I won't be the only one.

by Wpariona ‎11-17-2014 08:40 PM - edited ‎11-17-2014 08:40 PM

None of those options work for me!!! HELP please!

by Ancient on ‎11-24-2014 02:26 PM

Suffer under the same annoying auto brightness with latest Win 8.1. Auto brightness is so worse, it makes the screen for me almost unusable.

 

I turned off a) auto brightness  in Win 8.1 b) in Control center (Energy options for battery and cable) and c) Graphic card settings (only adjustable for akku).

 

 

 

Nothing finally helps.

 

This is the 2nd big issue, my another one is the crappy touchpad driver. Sucks to hell.

by Sang-Jun on ‎11-27-2014 05:31 AM

what about android ?

 

i'm using yoga 2 8-inch android version.

 

I also have same problem

 

when i watching like a... universe scene in the movie

 

display automotive darkess

 

i hope you can fix it quickly