Support in other languages: 
Reply
Paper Tape
schne166
Posts: 4
Registered: ‎12-07-2011
Location: United States
0

B520 Built-in Microphone Problem

We recently got a B520 77452MU All In One.  It includes a built-in webcam & microphone, and since right out of the box the microphone has recorded horribly.  It has very high background noise, kind of like a whirring static-y fan, so high that one might say the talking is actually the "background" noise.  We've tried updating the drivers and adjusting the microphone settings in the sound section of the control panel.  After troubleshooting extensively with the warranty tech support, they said it wasn't a normal problem and had us ship it in to try replacing the microphone (the particular model # we bought was not available to order by the time we received ours - it took a month to ship - so the sales rep couldn't just exchange it). That did not resolve the poor recording quality, even though the repair slip said the webcam/mic unit was replaced and passed the test, so we're thinking this must really be a normal weakness of the system.  Does anyone else have this problem?  Has anyone figured out a solution?

 

We like the features of the computer otherwise, so we're thinking about just buying an external microphone, but it is very annoying to have an "all-in-one computer" mounted to our wall with accessories hanging off it because it isn't really "all-in-one".

Punch Card
glavewu
Posts: 36
Registered: ‎02-09-2012
Location: United States
0

Re: B520 Built-in Microphone Problem

I had the same problem at the beginning when I used skype to play online game with friends... But I think it was because my skype used auto adjustment of the mic which boost the background noise when I didn't speak. After that, it became normal although the quality of the builtin mic is just ok to communicate.

 

Paper Tape
normana
Posts: 2
Registered: ‎04-11-2012
Location: Woodstock, NY
0

Re: B520 Built-in Microphone Problem

I have the same B520 model and have run into a background noise that has affected speech recognition when I use Rosetta Stone. I'm not using the Built-in Microphone of the B520, so it may not be what you've encountered. However, when I speak into the USB-connected headset and then listen to a rejected pronunciation, I often hear my own words dominated by a the kind of staticy sound that you described. It is almost as if the mic is picking up the internal sound of the disk drives, etc.

 

I did call the Lenovo help desk this morning and the hardware person looked at the settings (Windows 7) on my computer and was going to transfer me to Lenovo software. However, I had an appointment and couldn't do the transfer. I was looking for a setting of some sort that would keep the internal noise (at least I think it is internal noise like disk usage) out of the mic input being fed to the  voice recognition software. Interestingly, this didn't seem to be a problem last week.  (I also have a question in to Rosetta Stone to see if they have a suggestion.)

 

I'll add more when/if I find out more. While it isn't the same situation that you encountered, it does seem like it could be related. All I did to find your note was search "B520 noise".

 

(Added note: I have an old non-Lenovo machine that had static-y noise picked up by voice recognition and a USB-headset, so it is also possible that background noise and audio is a generic problem.)

Paper Tape
normana
Posts: 2
Registered: ‎04-11-2012
Location: Woodstock, NY
0

Re: B520 Built-in Microphone Problem

I have more info on my own situation (with a USB connected head set.) Net: the Rosetta Stone suggestions seem to have worked. I've listed the steps they supplied for Windows 7. I made two changes from what I had been recently using, highlighted in red under "Editorial Comments" in steps 9 and 12. That combination seemed to stop the background noise (feedback from a device?) in my talking during voice recognition. 

 

I realize this doesn't directly address the original post about "B520 Built-in Microphone Problem" since i wasn't doing the same thing. The original symptom, though, seemed to be related.

 

The suggested steps with a USB headset for voice recognition with my annotations:

 

 

1. Plug your headset into an available USB-Port.

2. Open the Start menu.

3. Click on the Control Panel.

start menu

4. If you're viewing the Control Panel by Category, click Hardware and Sound and then Sound. If you're viewing by Large or Small icons, click Sound.

open sound menu

5. On the Playback tab, highlight your device by clicking on it. Your device may be listed as C-Media USB Audio Device, USB VoIP Device or Other USB Device. (Editorial comment: my only USB choice was "USB VoIP Device", which was what I was already using.)

6. Click the Set Default button. If there's a green checkmark next to your preferred device, it's already set as the Default Device.

Set Default

7. Click the Properties button.

click properties button

8. Click the Levels tab.

9. Adjust the Speakers to 30.   (Editorial comment: mine had been set to 67.)

10. Click OK.

11. Click the Recording tab.

12. Highlight your device by clicking on it. It should have the same name as the device that you selected in the Playback tab.  (Editorial comment:  my microphone highlighted had a different name, "Lenovo USB 2.0 Audio", though I had nothing else audio but my headset plugged into a USB connection. I  highlighted the "USB VoIP Device" name used in step 5.)

13. Click the Set Default button. If there's a green checkmark next to your preferred device, it's already set as the Default Device.

14. Click OK.

Paper Tape
stewnew
Posts: 4
Registered: ‎04-17-2012
Location: UK
0

Re: B520 Built-in Microphone Problem

Hi

 

Not sure if this is related but I sure would appreciate any help that can be offered. I took delivery of a new B520 today. It was all set up fine and working OK. Then I went to change the annoying screensaver, and when I clicked "apply" the machine suddenly rebooted itself. When it came back up there is an annoying hissing constantly coming from the speakers. It is still there even if I mute the speakers. I have muted the mic too, as suggested on some other forums. The drivers are all up to date.

 

The hissing only stops when the machine is shut down. Other ausio playback appears normal, albeit wih the hissing continuing. 

 

Anyone heard of this problem before?

 

Thanks

 

 

What's DOS?
balajiraja85
Posts: 1
Registered: ‎06-19-2012
Location: USA
0

Re: B520 Built-in Microphone Problem

Hi. I just got a brand new G470 Lenovo. I am facing this static noise issue when both the webcam and the built in mic are operating together. Be it a video chat on skype or even have the cam on and running on the 'YouCam' application and parallelly use the sound recorder to record voice. 

Also, i found that when an external mic is connected, the problem doesnt occur. More to it, when the webcam is turned off, the internal mic also seem to function fine. If Lenovo is worried about its quality, i hope they look at this right away. Its very annoying that this happens on a fresh out of the box product, that too i bought it for my dad as a father's day gift :smileysad:

Paper Tape
draw
Posts: 3
Registered: ‎07-02-2012
Location: Rep. of Panama & US
0

Re: B520 Built-in Microphone Problem

I have the B520 77452SU.  Mic works okay only if my mouth is about two inches from the built in receiver otherwise the listener indicates it sounds like I'm in a barrel.  Built in speakers sound okay.  Would like to use a plugin mic and headphone for my communications but they do not disable the built in mic and speakers.  I downloaded the latest drivers for the B520. 

Paper Tape
draw
Posts: 3
Registered: ‎07-02-2012
Location: Rep. of Panama & US
0

Re: B520 Built-in Microphone Problem

Should have made more time available in the US after purchase but packed it for plane trip to Panama.  Customer service provided a third party contract service for Lenovo but was no help. Finally got the solution from a friend.  I had been going to Control Panel and trying to change settings which didn't solve the problem.  The solution was going to Skype, tools, options, audio settings and then changing Mic and Speaker options to others available until they worked.  Selected save and the problem was solved. 

Paper Tape
draw
Posts: 3
Registered: ‎07-02-2012
Location: Rep. of Panama & US
0

Re: B520 Built-in Microphone Problem

Additional information for solution to B520 Built-in Microphone Problem:

Information posted for Skype solution was correct but discovered that You tube audio and other audio selected from other sites still came through built-in speakers.  To disable speakers and use headphone:

1. Go to Control Panel

2. Click on Sounds

3. Right click on an empty space within the Sound box

4. Check is "show disable devices" have a check mark.  If not check on that.

5. You will find the devices which are disabled, right click on the device and enable it.

(Change the devices until you find the proper one you want to activate or disable)

 

Information from Microsoft help site.  For additional information:

http://windows.microsoft.com/en-US/windows7/Sound-cards-frequently-asked-questions

http://windows.microsoft.com/en-US/windows7/Tips-for-fixing-common-sound-problems