Support in other languages: 
Reply
Blue Screen Again
replica
Posts: 4
Registered: ‎11-29-2011
Location: Australia
Accepted Solution

Lenovo S10e WLAN WIFI driver issue solved

I recently re-installed XP on an S10e but could not get the WLAN to work. I installed every driver on the lenovo website for the broadcom S series drivers but no success. And then tried again

 

2 weeks later I then re-formatted and installed Windows Vista but again same issues.

 

Solution

Go to the device manager and select the Details tab

My VEN number was 8086 and DeV number 4327

 

I then went to http://www.pcidatabase.com

entered the details and found that device was an Intel (R) WiFi Link 5100 AGN (according to the chip id)

(use the browser find function with the device id number-saves a lot of time going through the list)

 

followed the link to http://downloadcenter.intel.com/Default.aspx?lang=eng

 

and found the matching device id

 

Wireless Technology >> Intel Centrino WIFI Products >>Intel WIFI Link 5300 and Intel WIFI Link 5100

 

installed the driver for my operating system and now everything is working 100%

 

It seems that the device id in the BIOS is incorrect or that it really is an Intel and not broadcom chip.

 

I hope this helps the many people that are having the same issue as I had and ends the endless traul on getting the WIFI working again.

 

Good luck and let me know if it work for you

Blue Screen Again
replica
Posts: 4
Registered: ‎11-29-2011
Location: Australia
0

Re: Lenovo S10e WLAN WIFI driver issue solved

Also all other drivers were installed automatically with the VISTA install no need for driver downloads (except bluetooth which installed under automatic updates - not that I use it anyway)
KalvinKlein
Posts: 2,325
Registered: ‎01-21-2009
Location: Germany Hannover
0

Re: Lenovo S10e WLAN WIFI driver issue solved

Hi and welcome,

 

first ...congrats excellent explanation  ... :smileyhappy:

 

second i have a question did you bought your S10e as used  or new ?

If you bought the machine as used netbook, could be possible that earlier user did change the card ..

 

third ..on the other hand, but that is valid for newer machines.

i know that different wireless cards for Ideapad S205 are factoryinstalled

comes with atheros cards , other countrys will get S205 with broadcom cards..

 

regards KalvinKlein

 

 

______________________________________
Thinkpad 2x X200s L9600/9400 AFFS 8GB 3G SSD Win7 64bit
Thinkpad X301 8GB 3G SSD Win7 64Bit Ft. Speakerbezel Metal Mod
Blue Screen Again
replica
Posts: 4
Registered: ‎11-29-2011
Location: Australia
0

Re: Lenovo S10e WLAN WIFI driver issue solved

HI,
This machine was bought new about 1-2 years ago with factory installed OS, everything was working fine until malware messed up the OS and OKR (aka F11) wouldn't work.

It may have been a chip mix up on assembly but that won't explain why it worked with original driver.

Any ideas how to check? The back plate only gave access to the HDD and a RAM slot

KalvinKlein
Posts: 2,325
Registered: ‎01-21-2009
Location: Germany Hannover
0

Re: Lenovo S10e WLAN WIFI driver issue solved

[ Edited ]

Hi , the wireless card is placed under palmrest ...

four screws and you can check wlan card .. download HMM (Hardware Maintanance. Manual)  HMM on page 73 you can see what to do..  be sure to remove battery and psu before you go... only lift the palmrest , its no need to unplug the cable..

on the left side you should see the wlan card  

Palmrest 1.JPG

 

 

 

wlan.jpg

sincerely KK

______________________________________
Thinkpad 2x X200s L9600/9400 AFFS 8GB 3G SSD Win7 64bit
Thinkpad X301 8GB 3G SSD Win7 64Bit Ft. Speakerbezel Metal Mod
Blue Screen Again
replica
Posts: 4
Registered: ‎11-29-2011
Location: Australia
0

Re: Lenovo S10e WLAN WIFI driver issue solved

I took a look and it was an Intel WIFI Link 1500 card.

I brought this brand new from a retailer in Australia when they had a special on these.

I checked the MAC address sticker on the Base and it doesn't match the MAC address on the card sticker.

 

 Well i guess if the drivers for others aren't working it's because the wrong WIFI card is in there.

 Thanks to everyone posting on the forum to help identify the issue.:smileyhappy:

 

I took photos but can't figure out how to upload them