Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
cjinn
Posts: 2
Registered: ‎05-23-2010
Location: Thailand
0

S10-3 Wireless - not working with Windows 7

[ Edited ]

Hi, I bought the S10-3 two days ago and decided to load windows 7 (ultimate). The load was smooth but after I had finished the wireless was not working nut the wireless light on the front of the PC was on. The first strange thing I noticed was Fn5 did not work so the only on/off control I had was on the side switch. I eventually fixed this problem by downloading the driver from the internet , the wireless is the Atheros AR9285. Everything was well and proceeded to download anti-virus and other software.

 

Then disaster, during the time of downloading windows had also been doing some updates and when the system restarted there is NO WIRELESS.

 

It appears on boot that the "wireless" light indicator is ON and when windows fires up it goes off, I checked in the boot and it is enabled, I checked the driver again but it is OK but windows says it is not switched ON but I have checked the physical switch and it is ON.

 

Any ideas appreciated.

 

edit : correct machine model in postname 

Token Ring
tulisan
Posts: 125
Registered: ‎02-23-2010
Location: manila
0

Re: S10-3 Wireless - not working with Windows 7

try enabling it in the BIOS

KalvinKlein
Posts: 2,340
Registered: ‎01-21-2009
Location: Germany Hannover
0

Re: S10-3 Wireless - not working with Windows 7

Hi and welcome, if all possible is switched on.. did you install the lenovo energymanagement ?

where you can switch (softwarebased) seperately wireless devices... if wifi still isnt work... :smileysad:

you have to bite in a sour apple and install windows 7 from a scratch again ... then first update all via windows updates , then ... install the lenovo energymanagement... , then, look in devicemanager if there is some questionmark ...  in normal case there is no need other driver to install...:smileyhappy:

and all should be working... simply install a antivirus-program.. and all your need other personal stuff...

 

sincerely KalvinKlein

______________________________________
Thinkies 2x X200s/X301 8GB 256GB SSD @ Win 7 64
Ideas Centre A520 ,Yoga 2 256GB SSD,Yoga 2 tablet @ Win 8.1
Paper Tape
cjinn
Posts: 2
Registered: ‎05-23-2010
Location: Thailand
0

Re: S10-3 Wireless - not working with Windows 7

Thanks for the suggestions, I will follow and let you know ... much appreciated.
Blue Screen Again
charmeleon68
Posts: 7
Registered: ‎05-23-2010
Location: Philippines
0

Re: S10-3 Wireless - not working with Windows 7

Have you installed ALL the drivers? I mean everything found on the drivers folder on the drive D? I had an s10-3 too and also, I installed Windows 7 Ultimate. But everything is working fine for me. I have seen no problems so far. So I guess you're just missing something. :smileyhappy: Goodluck!

Blue Screen Again
buttsimpson
Posts: 1
Registered: ‎12-28-2011
Location: New Zealand
0

Re: S10-3 Wireless - not working with Windows 7

Hi Guys,

 

Using  a stock S10-3 purchased this year. I have 32 bit Windows 7 professional, the wireless worked perfectly fine for a short while, but one day just refused to connect to any thing. I tried un/re-installing the drivers recommended by the Lenovo support site, but I got nowhere. Eventually, I solved the issue by connecting to the internet with the ethernet port, and allowing Windows Update to find the driver for me. Instead of the suggested Broadcom driver, Windows installed "Atheros AR9285 Wireless Network Adapter" which worked perfectly.

 

So yeah, TLDR..

* Wireless drivers from Lenovo site - bad

* Wireless drivers from WIndows Update - good