Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
KalvinKlein
Posts: 2,339
Registered: ‎01-21-2009
Location: Germany Hannover
0

S10 92 BIOS Online

[ Edited ]

New Bios for S10 14CN92WW the 92 is ready for download here:

 

http://consumersupport.lenovo.com/en/DriversDownloads/drivers_show_1283.html#

 

 

Summary of changes
==================

1. Resolve the problem with One Key Recovery button which makes the system automatically power on when the LCD cover is closed, especially if pressure is applied to the cover nearby the battery.

2. Add Password-on-boot functionality to BIOS CMOS settings.

3. Resolve the problem with the units carrying a  6-cell battery, where the computer's battery indicator displays wrong values for both the status (upon removing the AC adapter) and the volume charged.  

4. Resolve the problem with the short-cut key for wireless connections configuration (FN+F5).The system is not able to save the changes entered through the short-cut key.

5. Fix S9/S10/M10 auto shut-down in low temperature issue.

6. Fix Linpus S4 auto entry S3 after wake up issue.

7. Fix S9/S10/M10 Fan turning on/off frequently issue.

8. Fix the problem with LCD backlight remaining on while LCD cover closed.

9. New option in the BIOS setup utility to mute/unmute the beep when pluggin/out the AC adapter.

10. Combine the BIOS for non-3G and 3G system together.

Message Edited by KalvinKlein on 06-22-2009 03:58 PM
______________________________________
Thinkies 2x X200s/X301 8GB 256GB SSD @ Win 7 64
Ideas Centre A520 ,Yoga 2 256GB SSD,Yoga 2 tablet @ Win 8.1
Punch Card
theoak
Posts: 14
Registered: ‎02-08-2009
Location: USA
0

BIOS version 92 for S10 now available

Just to let everyone know, I checked the download section for my S10 (4231 2CU) and there is a new BIOS version to download. It is version 92. I was previously not able to try version 67 (144 error), but this one installed (for me) without a hitch. It adds Quick Start and the ability to turn off the bleeping plug removal noise. I know these are not new to everyone, but for me they are new. I have been using BIOS version 38 (the original).

 

This BIOS returned my video RAM to 64 MB instead of the 128 MB it had. I will try the BIOS default settings trick to see if it goes back to 128 MB.

 

My fan runs all the time now. I'm not crazy about that development.But CPU temps run around 34 with no programs running, which is cooler than my usual 38 in BIOS version 38.

 

Speedfan reports elevated ACPI (Temp 1) temps. With no programs running, Temp 1 hovers around 60 degrees. In my old Bios version 38, this temperature was always around 40 degrees. I am not sure if this is why the fan runs constantly. When watching youtubes this temp went up to 75, and Speedfan shows a flame beside it :smileysurprised:.

 

Does anyone know anything about this ACPI temp thing and whether it is dangerous or not?

Punch Card
theoak
Posts: 14
Registered: ‎02-08-2009
Location: USA
0

Re: BIOS version 92 for S10 now available

Just to follow up on the video RAM issue, going into the BIOS settings and selecting the option to load default settings DOES return video RAM to 128 MB. (Of course that is only true if you have added extra RAM.)
Paper Tape
stunpix
Posts: 5
Registered: ‎06-01-2009
Location: Odessa, Ukraine
0

Re: S10 92 BIOS Online

[ Edited ]

Still have the same problem as with 90 bios. Fan starts rotating at bootup, then stops after about 2 seconds and doesn't rotates till reboot.

With bios earlier than 90 fan doesn't rotates at all... at any time Are someone here who knows how to do full CMOS reset?

Not "load setup defaults", but really CMOS reset... I really tired with this problem...

@Admin maybe technical support can help me? Fan is working... I feel hot wind and I hear it from laptop after power on... then fan stops.

 

Moderator Note; edited post to fix format problem

Message Edited by andyP on 06-22-2009 10:24 PM
Administrator
Mark_Lenovo
Posts: 8,026
Registered: ‎11-19-2007
Location: RTP, North Carolina
0

Re: S10 92 BIOS Online

Stunpix,

 

If your fan is not running other than just at startup, no matter what your system is doing, then I would suggest you contact service.  

 

You can try loading BIOS defaults and be sure to save and exit.  You can also try turning off, removing battery and AC and pressing and holding power button several times.   I don't believe either of these will change your situation.

 

TheOak,

 

Thanks for sharing your tip on reserved video memory settings.  How much total memory do you have in your system?

There is extensive discussion on fans / temp / and monitoring program results (speedfan and others) on this board.   I will note that starting on version 58 of the BIOS, the temp data is being drawn from a different sensor.  

 

Mark

____________________________________________

ThinkPads: S30, T43, X60t, X1, W700ds, IdeaPad Y710, IdeaCentre: A300, IdeaPad K1
Mark Hopkins
Program Manager, Lenovo Social Media (Services)
twitter @lenovoforums
English English Community   Deutsche Deutsche Community   Español Comunidad en Español   ru.gif Русскоязычное Сообщество
Punch Card
theoak
Posts: 14
Registered: ‎02-08-2009
Location: USA
0

Re: S10 92 BIOS Online

[ Edited ]

Mark_Lenovo,

 

I have 2 GB of RAM installed.

 

If you mean that really long (912 posts) thread, I have read every single post. Slash's instructions (concerning the Intel Core DTS interpretation being set to relative, and both offsets set to 90) at post # 123 have been applied to Speedfan.  I did not see any reference to temp data sensor changing.

 

Are you saying that the Temp 1 is now the CPU temp? If so, then this bios runs much hotter and the fan is wearing itself out for nothing. Or are there other adjustments to Speedfan?

 

In any case, if I have to choose between running hot and the fan being on always or losing Quick Start, and the bleep silenser, then I think I will return to bios 38. For me, the fan hardly runs in that version.

 

EDIT: Think I found the thread you referenced. It is in the Fan Control for the S10(e) - user-developed solution, in post # 54. There user Carsten states that BIOSes prior to 58 used a different EC register reading to control the fan.

Message Edited by theoak on 06-23-2009 04:33 PM
Punch Card
XTS2500
Posts: 16
Registered: ‎06-11-2009
Location: Atlanta, GA.
0

Re: S10 92 BIOS Online

No problems updating to 92 from 58 on my S10, type 4231. WinXP Pro SP3, 2GB RAM. No change in VRAM or fan operation here, now the backlight goes off when I close the lid- cannot be happier. I love this little machine, it turns heads at work. Thinking of buying a second one, RadioShack near me has them for 299.99, 80GB HDD, 1GB RAM w/XP Home.

the views expressed herein are those of the author and do not in anyway represent those of the poster's employer, or it's affiliates, vendors or served agencies.
802.11n
yus9
Posts: 132
Registered: ‎03-17-2009
Location: San Jose & Taipei
0

Re: S10 92 BIOS Online

Had a great running S10 model 4231 with BIOS 59.

2GB, 320hd, dual boot XP & Chinese XP.

Added a Lenovo 6 cell battery and had an occassional startup/battery issue.

 

Was reluctant to update because everything else was fine including the fan and camera. 

 

Finally decided to flash up to BIOS 92.

Absolutely no problems and it seems the battery/startup issue is now fixed.

 

BTW, can't seem to see any video ram setting in the BIOS.

How can I find or change it from 64 to 128? 

KalvinKlein
Posts: 2,339
Registered: ‎01-21-2009
Location: Germany Hannover
0

Re: S10 92 BIOS Online

Hi yus9, thats not visible in BIOS, only thing to dofor that is load setup defaults F9 in BIOS...

 

approve in XP

right click at desktop-- screen preference-- advanced --graphicscard --shows you the graphics memory 

 

should before F9 64 MB after F9 128 MB...

 

sincerely KalvinKlein

 

 

______________________________________
Thinkies 2x X200s/X301 8GB 256GB SSD @ Win 7 64
Ideas Centre A520 ,Yoga 2 256GB SSD,Yoga 2 tablet @ Win 8.1
802.11n
yus9
Posts: 132
Registered: ‎03-17-2009
Location: San Jose & Taipei
0

Re: S10 92 BIOS Online

Thanks KalvinKlien!

 

Went to my BIOS.

Used F9 to reset. 

 

Maximum Graphics Memory now = 128 MB.

No longer 64 MB.

    ___________________________

Seems odd that it is a function of the bios,

but there is no display or control provided.