Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Punch Card
jakfish
Posts: 12
Registered: ‎02-15-2012
Location: Greece
0

Solution to Window 7's Inability to Run Chkdsk at Boot

[ Edited ]

Using a S10-3t and Windows 7 Home Premium, I was unable to finish a disk check scheduled after a restart.  Googling sent me toward MS hotfixes (which do not work) and to other advice about failed hardware, viruses, etc (which do not work as well).

 

What happened in my case was at boot, the disk scan was started and then cancelled.  At least with my machine, a bug in the keyboard/touchpad/touchscreen allowed the scan to believe a key to be touched which resulted in scan termination.  The workaround is this:

 

In the Win7 registry, go to:

 

 HKLM\System\CurrentControlSet\Control\Session Manager
REG_DWORD:AutoChkTimeOutData

 

Change the value of AutoChkTimeOutData from 3 (or it may be 10) to 0 (zero),  This stops the prompt at boot that allows the user to change his/her mind about the schedule scan.  Instead, it goes right to scanning and all is well.

 

Hope this helps somebody save the time that I lost :smileyhappy:

 

Jake

802.11n
fiesta
Posts: 134
Registered: ‎12-18-2011
Location: Athens
0

Re: Solution to Window 7's Inability to Run Chkdsk at Boot

I believe the S10's preloaded software was the Starter version of Windows.

 

Have you changed the initial Operating System?

Punch Card
jakfish
Posts: 12
Registered: ‎02-15-2012
Location: Greece
0

Re: Solution to Window 7's Inability to Run Chkdsk at Boot

[ Edited ]

Actually, the stock OS for my S10-3t was Win7 Home Premium.

 

Jake

802.11n
fiesta
Posts: 134
Registered: ‎12-18-2011
Location: Athens
0

Re: Solution to Window 7's Inability to Run Chkdsk at Boot

Nice. Well thanks for the initial feedback, it certainly may come in handy! :smileyhappy: