Support in other languages: 
Reply
Paper Tape
Morfcake
Posts: 1
Registered: ‎05-21-2012
Location: Hungary, Budapest

Lenovo Y570, nvidia GT555M not working

Hello, I got hold of my laptop very recently, and when I tried the little switch for the GPU nothing happened.

 

So I went to nvidias website and got the latest driver, (296.10) which after I downloaded and installed it told me this: 'You are not currently using a display attached to an nvidia gpu' when I tried to open it from the bottom right corner where it had a little icon. 

 

After this I checked on the control panel at the PC Properties what is up, and there it says this about my gpu 'Windows has stopped this device because it has reported problems. (Code 43)'

 

I've tried, updating the bios, but the exe that I downloaded told me 'the rom file isn't newer than that of the bios'.


I also tried downloading the driver for the GPU from the lenovo website, but I can't. It starts to download and then slowly the speed drops to very close to zero kilobytes and after a while it states that the download was interrupted. I tried about 4-5 times.

I'm pretty sure the rest of my drivers are up to date, I've checked it with the driver detector on intel's website, and updated whatever it suggested. 

 

Last thing I tried today was a one key recovery. Afterwards I checked which driver it has on for the GPU, its not the latest one, that nvidia website suggests but some older version (nvidia graphics driver 268.44 and nvidia 3D vision controller driver 266.34).

I also uninstalled my antivirus for a while, but nothing helps, the GPU switch doesn't work with these drivers, and at the PC properties it still says 'Windows has stopped this device because it has reported problems. (Code 43)'

 

I have been looking for a solution online for 3 days now but I can't find anything that helps me.
I'm starting to think that the GPU is simply faulty, but if someone can help me out I'll be very grateful.  

What's DOS?
Trakat
Posts: 1
Registered: ‎05-31-2012
Location: Prague, Czech republic
0

Re: Lenovo Y570, nvidia GT555M not working

I have exacty the same problem with Z570. Did anybody resolve it? Is my vga faulty?

 

Thank you.

RMattoo
Posts: 1,241
Topics: 3
Kudos: 94
Solutions: 91
Registered: ‎11-02-2011
Location: India
0

Re: Lenovo Y570, nvidia GT555M not working

Hi

Welcome to Lenovo Community

 

Please  update the Bios  and then update the Nivdia drivers

 

http://consumersupport.lenovo.com/us/en/DriversDownloads/drivers_list.aspx?CategoryID=867235

 


Hope This Helps
Cheers!!!