Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
JacksonParaluch
Posts: 3
Registered: ‎08-15-2011
Location: Canada
0
Accepted Solution

Minecraft Lagging on Y570

I have a Y570 with rapid drive, i7-2630QM Processor, NVIDIA GeForce GT 555M 1GB, 8 GB PC3-8500 DDR3 SDRAM 1333MHz.

It runs games like Starcraft 2, Portal 2, League of Legends and Team Fortress 2 smoothly. But for some reason minecraft lags terribly. When I'm playing minecraft the fps ranges from 4 to 20. I have all the video settings for minecraft at the lowest setting. 

On my previous computer, ( I don't remember what it was) I was able to run minecraft very smoothly with little lag, but the computer couldn't handle starcraft 2 or League of Legends. This is why I upgraded to my Y570.

I hope someone has a solution to this problem.  

Blue Screen Again
bilge
Posts: 36
Registered: ‎08-14-2011
Location: US
0

Re: Minecraft Lagging on Y570

Check to make sure the the nvidia optimus is switching from integrated graphics to dedicated
Paper Tape
JacksonParaluch
Posts: 3
Registered: ‎08-15-2011
Location: Canada
0

Re: Minecraft Lagging on Y570

How do i do this?

 

Community Moderator
yigit
Posts: 13,395
Registered: ‎12-07-2009
Location: Česká republika
0

Re: Minecraft Lagging on Y570

[ Edited ]

there's a switch button probably right side of your computer that helps you to activate nvidia graphic card.

 

also, take a look at the thread below:

http://forum.lenovo.com/t5/IdeaPad-Y-U-B-V-and-Z-series/Y570-Why-do-games-run-better-off-my-battery-... 



http://www.ki-themes.com
Fanfold Paper
MrEngenious
Posts: 6
Registered: ‎07-27-2011
Location: Brooklyn
0

Re: Minecraft Lagging on Y570

[ Edited ]

Actually I know what the problem is.
It's not detecting it as a program/game that would require the video card because it's a Java based application. Two ways of fixing this is to either:
1) Set it in the nvidia control panel to always use the video card when running java (not recommended).
2) Always start minecraft by right-clicking on minecraft.exe and selecting the nvidia video card (since it has the Intel graphics as default).

Also make sure you have 64-bit java installed as well, since I had crashing issues due to 32-bit java being used for it. I would also recommend using the optifine mod; it gives you more control over the settings, enables hd textures, and it improves performance regardless of how powerful your machine is.

Paper Tape
JacksonParaluch
Posts: 3
Registered: ‎08-15-2011
Location: Canada
0

Re: Minecraft Lagging on Y570

Thank you VERY much :smileyhappy:       I switched to 64 bit java and selected the nvidia video card and now minecraft runs smoother than ever!

Thanks