Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
sigmondzavion
Posts: 3
Registered: ‎07-26-2011
Location: Orland Park, IL
0
Accepted Solution

V570 + Win 7 64 pro = NO WIRELESS

 

I have installed a fresh copy of Win 7 Pro (64 bit) on my brand new V570.  All drivers installed fine - except the WIFI driver (Centrino 6150).  I have tried for days now with no success.  I have even paid for Lenovo premium support.  They tried for 5 hours and had no success.  They are sending me a driver CD.

 

The computer came with Win 7 Home Premium (64 bit).  I went thru the OEM install process and all went good with the factory setup.  The WIFI works great, when I have the factory drive installed.   I then installed my SSD (Intel 320).  I found out that the recovery discs that I created with the factory drive will not restore the OS to the new drive.  The drive has to be the EXACT specs as the factory drive ... %$@^%^%$!!.   At this point, I was very frustrated.  So, I  went out and purchased Win 7 pro (64 bit) and installed it along with all the drivers found on the Lenovo site.

 

I currently can install the factory drive and all hardware functions correctly - including the WIFI.

 

After seeing the techs frantically uninstall / install drivers via remote connection, I do not have much confidence in the "Driver CD" that is currently being sent to me.  The techs were doing every obvious thing that I was doing.

 

Please help, anyone. 

Punch Card
Obrut
Posts: 30
Registered: ‎07-19-2011
Location: Bulgaria
0

Re: V570 + Win 7 64 pro = NO WIRELESS

Please refer to my post here: http://forums.lenovo.com/t5/IdeaPad-Y-U-B-V-and-Z-series/many-Z570-problems/td-p/481043/page/3

 

It's for Z570 but I assume that your problem is very similar...

Community Moderator
yigit
Posts: 13,402
Registered: ‎12-07-2009
Location: Česká republika
0

Re: V570 + Win 7 64 pro = NO WIRELESS

Paper Tape
sigmondzavion
Posts: 3
Registered: ‎07-26-2011
Location: Orland Park, IL
0

Re: V570 + Win 7 64 pro = NO WIRELESS

 

Obrut:  Thanks for the info.  I am eager to try this when I get home.  I am also having the issue with powering down - as you described.

 

Paper Tape
sigmondzavion
Posts: 3
Registered: ‎07-26-2011
Location: Orland Park, IL
0

Re: V570 + Win 7 64 pro = NO WIRELESS

@Obrut:  You are a genius!  Your solutions worked perfectly.  I did a fresh install of Win 7 (with MBR partition) and everything is working great.

 

Thank you, for taking the time to post the solutions.

 

@Lenovo:  You need to get your act together, regarding this situation.  The first V570 I bought 2 weeks ago - I had to return because the BIOS locked up.  I've done many OS installs and never ran across anything like that.   I have been a long-time ThinkPad user and was almost ready to move to some other manufacturer.   I am surprised that your Premium Support techs couldn't figure this one out.  I am still waiting for the driver CD that PSS sent via snail-mail.   And when I get it ... well, I don't suspect that it will be of much use.

 

Anyways, things are good now.  The machine really cranks with the Intel 320 SSD.

Punch Card
cypha
Posts: 31
Registered: ‎04-27-2010
Location: USA
0

Re: V570 + Win 7 64 pro = NO WIRELESS

Hey, can you explain how you got this wireless card working? I still get the "NO MATCHED WIRELESS" popup, even with the latest drivers

I've also mentioned this here

 

I would GREATLY appreciate your help!

Punch Card
richardjones
Posts: 19
Registered: ‎09-02-2011
Location: UK
0

Re: V570 + Win 7 64 pro = NO WIRELESS

As you have found sigmondzavion, Lenovo "Engineering" know very little and care even less!!