Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Serial Port
bjasinski86
Posts: 21
Registered: ‎11-17-2008
Location: Poland
0
Accepted Solution

Y530 + Win 7 - no bluetooth device found

Hi,

 

My Y530 originally came with Vista, but I upgraded to 7 (as could get it free from MSDN AA).

 

Bluetooth WORKED FINE with Vista, but now there is no way I can turn it on. I've downloaded and installed all Win 7 drivers and software from Lenovo website (except BT driver, as it says there is "no bluetooth device detected" and I shoul turn it on). Fn + F5 shows WiFi card only, also no BT device in control panel. What can I do?

 

PS. I'm starting to miss my old T41 where everything worked fine, just the way I needed. Y530 is full of annoying (not to say "stupid") features, with Lenovo Power Management as first of them :/

//Bartek
//Y530 owner
Community Moderator
yigit
Posts: 13,391
Registered: ‎12-07-2009
Location: Česká republika
0

Re: Y530 + Win 7 - no bluetooth device found

activate wireless ( by pressing fn + f5 ) before installing bluetooth driver.

by the way which version of windows 7 are you using? ( 32 bit or 64 bit )



due to my absence, i may not reply your posts and/or personal messages

http://www.ki-themes.com
Serial Port
bjasinski86
Posts: 21
Registered: ‎11-17-2008
Location: Poland
0

Re: Y530 + Win 7 - no bluetooth device found

I'm using 32bit version of Win 7.

 

Meanwhile I managed to solve the problem. When I had launched my laptop for the first time after bringing it from a store I noticed that wireless lamp was pink - which meant that BT was active. So I went to BIOS and brought back default settings, which turned on the BT. Then I started the system and it installed the driver automatically. To be sure everything is compatible with Power Management, I additionally installed Lenovo software for the BT. After that Fn+F5 shows the device and everything seems to be working OK...

//Bartek
//Y530 owner
Fanfold Paper
irfnsnck
Posts: 5
Registered: ‎12-03-2010
Location: Turkiye
0

Re: Y530 + Win 7 - no bluetooth device found

Unfortunatelly I can not solve the same problem. I cant find anything in BIOS settings about bluetooth. Can anybody tell more detailed please.

Community Moderator
yigit
Posts: 13,391
Registered: ‎12-07-2009
Location: Česká republika
0

Re: Y530 + Win 7 - no bluetooth device found

@ irfnsnck

have you ever used bluetooth before?

when you press fn + f5, the windows will come up, you also need to activate bluetooth.

if you don't see bluetooth option, probably you don't have bluetooth hardware.

 



due to my absence, i may not reply your posts and/or personal messages

http://www.ki-themes.com
Fanfold Paper
irfnsnck
Posts: 5
Registered: ‎12-03-2010
Location: Turkiye
0

Re: Y530 + Win 7 - no bluetooth device found

yes I have. Before windows 7 I can use it by vista. After w 7 the problem exists. I cant see the bluetooth device beside the other devices in device manager.

Community Moderator
yigit
Posts: 13,391
Registered: ‎12-07-2009
Location: Česká republika
0

Re: Y530 + Win 7 - no bluetooth device found

upgraded vista to windows 7?

try to re-install bluetooth drivers.



due to my absence, i may not reply your posts and/or personal messages

http://www.ki-themes.com
Fanfold Paper
irfnsnck
Posts: 5
Registered: ‎12-03-2010
Location: Turkiye
0

Re: Y530 + Win 7 - no bluetooth device found

I did it again and again, unfortunatelly there is no change. I am afraid I cant solve this problem.

Community Moderator
yigit
Posts: 13,391
Registered: ‎12-07-2009
Location: Česká republika
0

Re: Y530 + Win 7 - no bluetooth device found

[ Edited ]

i'm not sure it'll help but try to check bios for wireless option is activated.

by the way, did you perform clean windows installation or upgrade?

cause upgrading windows may cause some issues if you forget to un-install drivers first.

 

edit: try the drivers from the below.

http://consumersupport.lenovo.com/uk/en/DriversDownloads/drivers_list.aspx?CategoryID=13



due to my absence, i may not reply your posts and/or personal messages

http://www.ki-themes.com
Fanfold Paper
irfnsnck
Posts: 5
Registered: ‎12-03-2010
Location: Turkiye
0

Re: Y530 + Win 7 - no bluetooth device found

But the problem is my not being able to find bluetooth section in BIOS menu. I'm sorry to employ you with this issue, but it will be very pleased if you tell me how I can do it step by step.