Support in other languages: 
Reply
Punch Card
MR2Dave
Posts: 5
Registered: ‎03-04-2008
Location: USA
0

Y550P won't POST with OCZ Vertex 3 SSD, X201 just locks up constantly.

I bought 2 120GB Vertex 3 SSDs to upgrade my notebooks. The Y550 wouldn't even post with the SSD installed at first. The logo screen doesn't even display, what looks like a cursor flashes on the screen for a second, then freezes. That's it.

I updated to the latest BIOS (5.07), and checked the SSD firmware, which was already up to date. No change.

In the end, I pulled the drive, got into BIOS, and switched the SATA controller into compatible mode. Now it'll boot, but obviously, it should work in AHCI mode.

The X201 is worse. It locks up constantly, I can't even get an OS installed. Doesn't matter which mode the SATA controller is in. I've tried all of the usual troubleshooting steps, like making sure the firmware/BIOS is up to date. I also tried setting the drive to SATA2 mode (instead of it trying to negotiate for SATA 3), with no effect.

I've popped these drives into my desktop, and it didn't have any problems with either of them. Is Lenovo working on this at all, or am I going to have to start buying my laptops from Asus?

tanujhanda
Posts: 955
Topics: 3
Kudos: 80
Solutions: 65
Registered: ‎01-05-2010
Location: INDIA
0

Re: Y550P won't POST with OCZ Vertex 3 SSD, X201 just locks up constantly.

Hello MR2Dave,

 

This issue could be as brand compatibility with laptop.

 

If you have another brand SSD then you may check as it should work.

 

Lenovo has Solid State Drive firmware update utility  which check your system configuration and detect all Solid State Drives  installed in your ThinkPad.

 

This utility is compatible with Intel, Samsung, Micron however, you must try to run this.

 

Best Regards,

Tanuj

 


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Punch Card
MR2Dave
Posts: 5
Registered: ‎03-04-2008
Location: USA
0

Re: Y550P won't POST with OCZ Vertex 3 SSD, X201 just locks up constantly.

By "brand compatibility", do you mean Lenovo? It's a SATA drive with TRIM support, these are industry standard protocols, they're not brand specific at all. These drives work just fine in other computers with the same chipset/controller.

 

Since I "must", I ran the utility. Of course, it does nothing, because it doesn't have a firmware update for my drive. The drive is up to date anyhow, which I've already mentioned.

 

So, can we expect a BIOS update to fix the bug, or is a hardware design flaw causing this?

Punch Card
MR2Dave
Posts: 5
Registered: ‎03-04-2008
Location: USA
0

Re: Y550P won't POST with OCZ Vertex 3 SSD, X201 just locks up constantly.

OCZ released a firmware update, version 2.22, which I updated to. The drives work just fine in Asus, Acer, and HP computers. Lenovo, on the other hand... The Y550 still won't POST with the controller an AHCI mode, and the X201 still locks up.

 

I'm still waiting for an answer from Lenovo. Support like this is going to ruin (what's left of) the brand's reputation pretty quickly.