Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
RossS1990
Posts: 5
Registered: ‎03-22-2012
Location: Watervliet, Mi
0
Accepted Solution

Y570 FPS Issues, Help would be amazing!

Hey guys I bought a Y570 a few weeks ago. I saw 6GB RAM, i7 Quad-Core, and nVidia GT 555m and thought it would work well with playing Star Wars The Old Republic. I installed the game fine and it recommended the settings be on "Medium" graphics. It runs between 70 and 100 FPS 90% of the time but has HUGE drops in FPS(Below 10 at times.) The only way I can play the game without FPS drop is to use "Very Low" settings for graphics.. Which really sucks because the game looks 100 times better on "High" or "Medium" settings.

I've went into the performance settings and set everything to run at high performance when plugged in. Then I went into the graphics options and set SWTOR to run on the GT 555m with high performance graphics settings. I have to be honest though I'm not sure exactly if I've set everything up properly.

 

The one thing that I've had a little concern about are the temperatures. I have a cooling pad and a box fan blowing right on it and the cores are between 58-65 C. I believe the GPU is setting around 60C while playing.

The odd thing is that before I bought the laptop I was running the game on a desktop, AMD Athon II x3(3 cores), 8GB RAM and a Radeon HD 5670 and could run it on "Low" settings with no lag spikes at all(Laptop has to be ran on "Very Low" to achieve the same consistent FPS.)

Other details that I'm not sure could effect performance: I'm running the laptop through my TV with an HDMI cable.

If you guys could help me with this I can't describe how much I'd appreciate it. I would love to play the game on "Medium" or "High."

Token Ring
Fletchman1313
Posts: 113
Registered: ‎03-04-2011
Location: Hawaii
0

Re: Y570 FPS Issues, Help would be amazing!

Did you press the GPU button on the front of the laptop?  Is it lit up?

802.11n
velenoso666
Posts: 411
Registered: ‎01-24-2012
Location: Australia
0

Re: Y570 FPS Issues, Help would be amazing!


RossS1990 wrote:

If you guys could help me with this I can't describe how much I'd appreciate it. I would love to play the game on "Medium" or "High."



Have you tried using the 285.79 drivers? Because only very few people can get their Y570 to run well on anything else.

HDMI
kostadinbal
Posts: 155
Registered: ‎03-03-2012
Location: Bulgaria
0

Re: Y570 FPS Issues, Help would be amazing!

It is probably a driver problem, try the 285 or 295 versions. And make sure its a clean uninstall->restart->install new->restart

Token Ring
zitnikp
Posts: 162
Registered: ‎01-06-2012
Location: Slovenia
0

Re: Y570 FPS Issues, Help would be amazing!

Try the exact drivers as Velenoso666 told you, following the procedure of Kostadinbal just make sure that when you install the new drivers, you select Custom install->Clean install

Paper Tape
RossS1990
Posts: 5
Registered: ‎03-22-2012
Location: Watervliet, Mi
0

Re: Y570 FPS Issues, Help would be amazing!

Yep the GPU button is lit up..

I'll try the clean install one my question before I do that though: There are 4 different nVidia related programs.

3D Vision Controller 295.73
Graphics Driver 295.73

PhysX System Software

NVIDIA Update 1.7.11

Do I uninstall all four?

HDMI
kostadinbal
Posts: 155
Registered: ‎03-03-2012
Location: Bulgaria
0

Re: Y570 FPS Issues, Help would be amazing!

Um as I remember I installed only the graphics driver 295.73. Just download the 295.73 from nvidia website , uninstall the old one from your control panel and install this one as I described before
Token Ring
zitnikp
Posts: 162
Registered: ‎01-06-2012
Location: Slovenia
0

Re: Y570 FPS Issues, Help would be amazing!

Uninstall all 4 because the graphic and physx driver differ and so might the other 2 aswell. Just to make sure it's a clean install not a normal downgrade.

Token Ring
BrownEye02
Posts: 40
Registered: ‎03-19-2012
Location: Colorado
0

Re: Y570 FPS Issues, Help would be amazing!

Yes do a full uninstall. Remove all four programs and it sometimes even helps to check the box to delete user settings. The only issue with that is you will have to reset everything up.

Paper Tape
RossS1990
Posts: 5
Registered: ‎03-22-2012
Location: Watervliet, Mi
0

Re: Y570 FPS Issues, Help would be amazing!

Installing the older drivers has improved the lag issue by 95%! There are still a few little lag spikes here and there but nothing serious or game breaking.. Thanks a lot!