Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
cab2arch
Posts: 3
Registered: ‎12-29-2010
Location: Wisconsin, USA
0

no mouse cursor anywhere to be found

I own a Z60m. Type 2531 to be exact.

I trying to run the recovery on my computer to start over again.  However here is what's going on right now:

 

Situation 1:  When I'm running Thinkvantage and it's up on my screen ready to go, there is no mouse cursor.  Also it doesn't appear that I can use "tab" to go through the different options on the screen.

 

Situation 2: When I'm running the BIOS setup utility, my keyboard does work for sure then.  I don't have any errors in BIOS to my knowledge.

 

Situation 3: When Windows XP PRO is up and running on my computer, the mouse cursor is on the screen and in it's default middle of the screen position.  But I can't move it with anything... the trackpoint, the touch pad or even a usb plugged in mouse can't move the mouse anywhere.

 

Does anyone have any idea what might be causing something like this to occur?  Could it be a driver or is it hardware related?  I've already tried unplugging and the plugging back in the keyboard and touchpad plugs back into the motherboard.  But I still have the same problems.

 

Please help anyone...

Guru
Mornsgrans
Posts: 2,474
Registered: ‎03-19-2009
Location: Idar-Oberstein, Germany
0

Betreff: no mouse cursor anywhere to be found

Did the laptop get contact with liquids in the past?

Please check in BIOS under Congig - Mouse/Keyboard, whether trackpoint and touchpad are setto "automatic".

--------------------------------
My home-forum: http://www.thinkpad-forum.de
Wiki: Deutsches ThinkPad-Wiki English ThinkWiki
My ThinkPad-Collection
Paper Tape
cab2arch
Posts: 3
Registered: ‎12-29-2010
Location: Wisconsin, USA
0

Betreff: no mouse cursor anywhere to be found

Thanks for sharing your thoughts on my problem.  Yes both trackpoint and touchpad are set to "automatic".  As far as liquid in the past, not to my knowledge has liquid contacted anything.  There is no evidence in the inside of the computer of liquid residue.

The keyboard works just fine.  The problem is just with the mouse.  It would make sense to me that a setting or driver could be messed up.

I do have another Z60M in my house.  Maybe I'll try switching out the keyboard and touchpad and see if it makes the problem computer work.

Guru
Mornsgrans
Posts: 2,474
Registered: ‎03-19-2009
Location: Idar-Oberstein, Germany
0

Betreff: no mouse cursor anywhere to be found

Dis you update the Ultranav - driver the last days to this version?

 

Are the mouse-/Ultranav-devices still mentioned in the device manager?

Do you have any problems with USB-devices (f.ex. "This device can run in higher speed, after connecting to an USB 2.0 - port..." - message)?

--------------------------------
My home-forum: http://www.thinkpad-forum.de
Wiki: Deutsches ThinkPad-Wiki English ThinkWiki
My ThinkPad-Collection
Paper Tape
cab2arch
Posts: 3
Registered: ‎12-29-2010
Location: Wisconsin, USA
0

Betreff: no mouse cursor anywhere to be found

After you spoke about the new Ultranav driver, I tried updating it last night.  I was successful in updating the driver, but I still can't use the mouse for the trackpoint or touchpad.

 

To answer your question about USB devices, I have had no problems of any kind.  In fact the only mouse I can use on that computer is my USB plug and play mouse.

 

Not sure if this is related or not, but I can't get any sound to come out of the two speakers of this laptop.  Again, just like the trackpoint and touchpad, everything looks like it should work in the device manager.  There are no yellow exclamation marks anywhere.

 

I keep going back to the BIOS page when I start up the computer and everything is set to "automatic".  It appears that all my settings are right in this section.

 

But for some reason, the speakers and touchpad and trackpoint aren't being acknowledged by the motherboard as being connected.  Yes I've verified they are plugged in also.  Besides, I can type just fine on the computer and it is the same cable that connects the trackpoint and the keyboard to the motherboard.  There has to be something else going on. 

 

By the way, I've already prepared for the worst case scenario and I've taken any files of value and made copies of them on a different computer.   Do you think a BIOS update could fix this?  I see one on the Lenovo website.  Or any other ideas?

Guru
Mornsgrans
Posts: 2,474
Registered: ‎03-19-2009
Location: Idar-Oberstein, Germany
0

Betreff: no mouse cursor anywhere to be found

I recommend to test the trackpoint/touchpad- and audio behavior under Linux - f.ex. Knoppix or Ubuntu Live-CD.

If the problem remains, it might be a hardware failure.

--------------------------------
My home-forum: http://www.thinkpad-forum.de
Wiki: Deutsches ThinkPad-Wiki English ThinkWiki
My ThinkPad-Collection