Support in other languages: 
Reply
Fanfold Paper
solariski
Posts: 19
Registered: ‎03-09-2011
Location: United Kingdom
0
Accepted Solution

""Unknown PCI Device " ????

[ Edited ]

Hello everyone, just had a Z61T bought for me as a replacement for a busted ACER, and I have to be honest and say I'm seriously pleased with it :smileyhappy:

BUT, I have a problem, a niggle as it were. Everytime I boot up and get va little message in the task bar telling me that "new hardware" has been found, as above, initially the wizard describes it as IDE ATA/ ATAPI controller, then disappears when I cancell it and it returns as " Unknown PCI Device". I can't find any drivers, none are installed, can't roll back can't even uninstall whatever it might be. Device Manager is no help at all- so any and all ideas greatly appreciated and welcome !!

 

I do love this machine tho :smileyhappy:

 

EDIT :  Sorry forgot to say I'm running XP Pro SP3 2GHZ model( T72000) and 2GB RAM

buddinggeek
Posts: 2,846
Topics: 105
Kudos: 139
Blog Posts: 0
Solutions: 118
Registered: ‎02-22-2008
Location: Telangana , India +GMT 5.30
0

Re: ""Unknown PCI Device " ????

Install system update,it should fetch the required drivers

http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-66956





Cheers and regards,
• » νιנαソѕαяα∂нι ѕαмανє∂αм ™ « •
Think : T410,X220T,Thinkpad Yoga
Idea :3000H,Z500,U410,Yoga 11, Yoga tab 10,Horizon

●๋•کáŕádhí'ک díáŕý ツ


I am a volunteer here. I don't work for Lenovo
Fanfold Paper
solariski
Posts: 19
Registered: ‎03-09-2011
Location: United Kingdom
0

Re: ""Unknown PCI Device " ????

[ Edited ]

I agree it should but it doesn't, I have attempted that 2x now and still no progress :smileysad:

further info:-

PCI bus 0, device31, function 2  ?????

PCI device properties under device manger  only reveals under "details" -

PCI\VEN_8086&DEV_27C5&SUBSYS_200D17AA&REV_02\3&B1BFB68&0&FA

No drivers, no rollback available , nothing!

 

It shows up as a windows  storage device when I run AIDA32 ??

 

Any ideas to what it is exactly ? At least it'd give me a chance of tracking down a driver and getting rid of this irritating message and window

ajkula66
Posts: 7,602
Kudos: 750
Solutions: 792
Registered: ‎11-23-2007
Location: USA

Re: ""Unknown PCI Device " ????

Install the Intel chipset driver to begin with.


http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-62939


Your missing device is likely to be a card reader.


http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-67470


Good luck.

Cheers,

George




In daily use: T43pSF, R60F, T61, X301

Collecting dust: T60, T61p, R500F

Enjoying retirement: A31p, T42p,

Non-ThinkPads: Panasonic CF-31 & CF-52, HP 8760W

I build FrankenPads....scary FrankenPads...

S = SATA-mod (on T43/p units only)
F = FrankenPad
L = LED-mod utilizing an UXGA AFFS LED screen


Please DO NOT PM me with requests for individual support, but post your questions and concerns in the appropriate section of the forum where other users can benefit from them as well. Thank you.
.
Fanfold Paper
solariski
Posts: 19
Registered: ‎03-09-2011
Location: United Kingdom
0

Re: ""Unknown PCI Device " ????

I'll try that ,many thanks , I'll get back and lte you know :smileyhappy:

Fanfold Paper
solariski
Posts: 19
Registered: ‎03-09-2011
Location: United Kingdom
0

Re: ""Unknown PCI Device " ????

hey hey hey ! guess who's got a sn

miley face ??

First off thanks for all the input /suggestions, it wasn't any of the above but certainly in the ball-park, it was in fact an update to the Intel Storage Manager driver that was required but hey I wouldn't have known to look at it if it wasn't for your suggestions .

 

So, BIG THANK YOU !!

Karlo