Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
What's DOS?
u848237
Posts: 4
Registered: ‎12-19-2010
Location: UK
0

Re: [Solved]: Wrong Detection Of Native Internal Display Resolution On Boot

Many thanks for posting this - I've just tried this and, like yours, my machine works absolutely fine when started with the LCD nearly closed :smileyhappy:

Ctrl-Alt-Del
mappi
Posts: 5
Registered: ‎08-07-2010
Location: Austria
0

Re: [Solved]: Wrong Detection Of Native Internal Display Resolution On Boot

[ Edited ]

Hello,

 

a week ago I disassembled the notebook to disscover iIt really was a broken LCD cable.

 

I've been mailing a  number of notebookdisplay-shops in germany but none was able to deliver the broken  cable.

 

Lenovo will only sell a combination of the cable+lcd and charges 330€ :smileyvery-happy: (despite the financial insanity, think of the environmental aspect: wasting a fine working LCD for the reason of ONE BROKEN WIRE, nice job Lenovo, really "Green Computing")

 

So I decided to solder the cable myself, with success as it seems. (Since  I am writing from the C200 at the moment :smileywink: )

 

The whole procedure is quite simple and I think everybody who is able to handle a screw driver + a soldering iron  (and has the strong desire/need for a working laptop without wasting any more money on our chinese notebook friends) should be capable of doing it.

 

1. You only need to remove the the display frame (6 screws under the small rubber things) an another 2 screws for releasing the backside of the display lid)

 

2. Remove the panel with powerbutton hotkeys (its only clipped no screws at all)

 

3. loose the last two screws to remove the keyboard

 

4. Now you can unplug the cable from the mainboard (one plug for the lcd, one for the backlit) and remove the other end of the cable from the backside of the lcd an inverter

 

5. You need to carefully remove the metal tape which is wrapped around the cabel an then look for the defective wire...

 

Good luck!

 

Martin

 

 

 

 

 

Paper Tape
theMarmot
Posts: 1
Registered: ‎12-11-2008
Location: UK
0

Re: [Solved]: Wrong Detection Of Native Internal Display Resolution On Boot

Thanks Martin,

 

I can't tell you how happy i am to have a working screen again! A simple thing i know but very annoying when you can't see things full screen.

 

Anyway, it was as you described: one tiny wire had snapped. I soldered a new piece in and hey presto - result!

 

Respect to that man.

 

Cheers,

 

Jamie.

 

 

Ctrl-Alt-Del
mappi
Posts: 5
Registered: ‎08-07-2010
Location: Austria
0

Re: [Solved]: Wrong Detection Of Native Internal Display Resolution On Boot

THX ans nice thing it worked for you, too!

 

 

What's DOS?
u848237
Posts: 4
Registered: ‎12-19-2010
Location: UK
0

Re: [Solved]: Wrong Detection Of Native Internal Display Resolution On Boot

For the benefit of the search, the cable in question is marked:

 

HDL20/30_LDVS_CABLE

DC02000BU00 REV:1.0

FOXCONN 061123

 

Searching by DC02000BU00, these are now available on eBay for about USD 16, shipped from Hong Kong of course.

 

Since mine is now really broken and the wires them are truely tiny, I've ordered one of these 'compatible' replacements.  I hope it works!

What's DOS?
u848237
Posts: 4
Registered: ‎12-19-2010
Location: UK
0

Re: [Solved]: Wrong Detection Of Native Internal Display Resolution On Boot

Since developing the original fault, my laptop screen had also gone 'streaky' at times, which I'd assumed to be more wires breaking.

 

Anyway, the new cable arrived and fitted just fine, and has resolved the original problem so screen is properly detected every time.

 

However the screen itself I think is on it's last legs as the 'streaky-ness' comes and goes.  But at least it's usable.

 

So anyway, thanks to the mappi for posting the info about the cable problem :smileyhappy:

R23
What's DOS?
R23
Posts: 2
Registered: ‎02-25-2012
Location: United Kingdom
0

Re: [Solved]: Wrong Detection Of Native Internal Display Resolution On Boot

I'm so glad I found this thread because trying to describe the problem to other people they thought I was mad! I have a 3000 C200 and it seems this is a common fault with this model.

 

I have exalt the same problem with an offset desktop screen, about 4cm is missing from the left side and 1 cm missing from the top. When I boot the Lenovo bios screen is blurry and also offset. Clearly the wrong resolution is being detected internally regardless of what Windows display settings and Intel GMA settings are saying.

 

In the beginning the screen wouldn't even turn on past the windows loading screen, then sometimes it would but be offset, then sometimes it would be fine.... this lead me to suspect that it wasn't a software but a hardware issue and that seems to be the case.

 

So I take it the way to fix this is open up the screen housing and find that little wire that people are saying has come loose? Can it be reattached with a soldering iron or can you replace the whole component? Also does anyone have a link to the C200's service manual so I can see a take apart guide?

 

Thanks

R23
What's DOS?
R23
Posts: 2
Registered: ‎02-25-2012
Location: United Kingdom
0

Re: [Solved]: Wrong Detection Of Native Internal Display Resolution On Boot

EDIT, I just read the whole thread through and I see more clearly what I have to do now, I will see how badly damaged the wire is then see whether to fix it or get the replacement part. In all fairness this laptop has worked perfectly for nearly 6 years but its still quite an inconvenience to fix. I have laptops from the 1980's and their monochrome screens still work fine!