Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Fanfold Paper
marek999
Posts: 3
Registered: ‎08-04-2010
Location: Zagreb, CRO
0

G555 Bios problem

[ Edited ]

Hi, today I bought Lenovo g555

after installing windows XP, I have installed all the drivers from lenovo site, and everything was ok, but then i realised that there is new bios for my laptop. when i flashed the bios my ati card was not recognized any more. i tried to reinstall the driver but nothing happens. My original bios was ( 2cec19ww (v1.06 ), and the new one is 2ccn21ww(v1.10).

I dont know what to do now, should i somehow clear the cmos and how? or can i find old bios firmware and where ?

Please help

IPnaSh
Posts: 2,403
Kudos: 369
Solutions: 126
Registered: ‎06-05-2010
Location: Rosario, Santa Fe, Argentina
0

Re: Bios problem

Try to enter BIOS and load default settings. If this doesn't solve this, maybe you need to call customer service.

IPnaSh
First Spanish Community Guru - Colaborador ad honorem

Lenovo
Fanfold Paper
marek999
Posts: 3
Registered: ‎08-04-2010
Location: Zagreb, CRO
0

Re: Bios problem

I have already tried that.
IPnaSh
Posts: 2,403
Kudos: 369
Solutions: 126
Registered: ‎06-05-2010
Location: Rosario, Santa Fe, Argentina
0

Re: Bios problem

Maybe you should back to previous version. You need to contact customer suppor because Lenovo shows only the latest BIOS on download page.

IPnaSh
First Spanish Community Guru - Colaborador ad honorem

Lenovo
Fanfold Paper
marek999
Posts: 3
Registered: ‎08-04-2010
Location: Zagreb, CRO
0

Re: Bios problem

My computer works again :smileyvery-happy:

Since my bios was not bricked, I decided to install a win7x64 and to flash bios with x64 file. and guess what ? it works.  :smileytongue:

IPnaSh
Posts: 2,403
Kudos: 369
Solutions: 126
Registered: ‎06-05-2010
Location: Rosario, Santa Fe, Argentina
0

Re: Bios problem

Cool! :smileyvery-happy:

IPnaSh
First Spanish Community Guru - Colaborador ad honorem

Lenovo
Blue Screen Again
yozz
Posts: 2
Registered: ‎08-27-2010
Location: Slovakia
0

Re: Bios problem

Congratulations. This is not a solution for XP user, though. I have the same problem. I was looking for the original BIOS on the net, but can't get it anywhere. I've also contacted the Customer support with no sucess. The only solution seems to be to ask for it here or another forum, if somebody has it backed up. Can someone help ?

Community Moderator
yigit
Posts: 13,329
Registered: ‎12-07-2009
Location: Antalya
0

Re: Bios problem

updated Information:
the latest bios version supports ati m93 xt graphics card.

 

http://consumersupport.lenovo.com/us/en/DriversDownloads/drivers_show_3030.html



http://www.ki-themes.com
Posts: 1,502
Topics: 38
Kudos: 117
Solutions: 49
Registered: ‎04-20-2010
Location: Jeffersonville, Indiana
0

Re: Bios problem

[ Edited ]

I just don't understand why people update the BIOS when they do not have an issue. I have NEVER updated any of my PC's BIOS. If it ain't broke don't fix it.

IT Specialist and Consultant
Lenovo Tablet Evangelist
Current Machines: IdeaCentre A300, ThinkPad Tablet, ThinkPad L410, and IdeaPad U410 Touch

Deutsche Deutsche Community   Español Comunidad en Español

Lenovo - the latest in DOtabs, DOpads, DOcentre's, DOstations and DOservers!
Blue Screen Again
yozz
Posts: 2
Registered: ‎08-27-2010
Location: Slovakia
0

Re: Bios problem

They do it to get support for new functions. Like USB booting.