Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
JonnykDoe
Posts: 2
Registered: ‎06-30-2012
Location: Israel
0

G570 wifi connectivity problem

Hey everybody.

Need some help.

Approx. 6 months ago I bought a G570 leptop.

Everything works great except one annoying issue:

My wireless adapter (Broadcom) has a mind of its own.

Sometimes, when I open a lid it connects automaticaly to my wifi network, as it suppose to do.

Sometimes, it refuses to connect automatically and I have to connect it manually.

Sometimes, it waits for 20-30 seconds and then connects automatically. 

It drives me crazy.

I want my leptop to be connected automatically, every time I turn it on.

I have another 2 leptops: Lenovo n200 and fujitsu. Never had the same problem with them.

 

Please help.

 

P.S.

I reinstalled the wireless network drivers (up to date).

Wireless autoconnetion is turned on.

The laptop usually turnd on from a sleep mode.

 

 

Thanks.

topmahof
Posts: 3,163
Topics: 35
Kudos: 351
Solutions: 235
Registered: ‎01-21-2010
Location: Etters, PA
0

Re: G570 wifi connectivity problem

Hi JonnykDoe,

 

Try the things in this thread .  Let us know if anything helped.  Especially the device manager  one about  "allow windows to turn off this device to save power".

 

Dave

_______________________________________________________
T430u, x301, x200T, x61T, 2-x61s, x60T, x32, x41T, x40, U160, ThinkPad Tablet 1838-22R, Z500 touch, Yoga 10
Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!
If someone helped you today, pay it forward. Help Someone Else!
English English Community   Deutsche Deutsche Community   Español Comunidad en Español   ru.gif Русскоязычное Сообщество
RMattoo
Posts: 1,241
Topics: 3
Kudos: 94
Solutions: 91
Registered: ‎11-02-2011
Location: India
0

Re: G570 wifi connectivity problem

Hi Welcome To Lenovo Community You may also try updating the Bios version of the system to latest http://consumersupport.lenovo.com/us/en/DriversDownloads/drivers_show_5922.html Hope This Helps Cheers!!!