Support in other languages: 
Reply
rss
Paper Tape
rss
Posts: 1
Registered: ‎12-06-2009
Location: UK
0

Internet keeps disconnecting

Hi all. I have an N500, and ever since I bought it almost a year ago, the Internet keeps disconnecting sporadically. There's a red X that shows up on the WIFI link icon, and then I get a message saying 'limited connectivity.' I doubt there's something wrong with my router, because I have another laptop, and it never happens on that one. 

 

I sent it in for repair - twice. The first time Lenovo said there was nothing wrong and returned it. I sent it in again and they claimed they changed the WIFI link. There's not a problem if I use an ethernet cable. And I also updated drivers. 

 

I'm at wit's end and ticked since I suspect this might have been a problem inherent when I bought it new. 

 

Anyone have any ideas?

Thanks.

Ctrl-Alt-Del
smiller
Posts: 6
Registered: ‎07-02-2009
Location: Florida
0

Re: Internet keeps disconnecting

[ Edited ]

I purchased a G530 in late June and have had issues with the internet connection.  When I use the laptop while plugged into the electrical outlet, the internet works fine, although I am constantly bombarded with pop up "Wireless Connection Error" messages.  When I use the laptop on the battery, getting online and staying online is a nightmare.  I've gone in and changed certain settings to less secure ones and that helps, but it is noticeably slower and seems to be constantly "refreshing" or "reloading" every couple of minutes.  I feel like I have to try and hurry to get something before it stops to reload the page.  I've sent my laptop back to the Lenovo Repair Depot twice.  The first time they replaced the hard drive and "updated" the BIOS.  I've had a constant display resolution problem since day one, but they didn't address that... unless updating the BIOS was supposed to fix that issue.  Since the display issue was not resolved and the issues with the wireless internet connection, it was sent back a second time.  This time they "updated" the BIOS - again - and updated the drivers for the display and the wireless network.  I got the laptop back yesterday and it was exactly the same as when I sent it to them... oh, except that all my personalized settings, internet explorer favorites, etc. were all gone.  I think they have their head burried in the sand when it comes to the Lenovo G530 laptops running Windows XP Pro.

What's DOS?
irella
Posts: 1
Registered: ‎02-13-2010
Location: sf
0

Re: Internet keeps disconnecting

i have the exact same problem. has this been resolved yet. I also have a g530 model. i noticed the problem happend when i updated the intel graphics card to fix the brightness keys that weren't working earlier. Lenovo, can you get this together? ever since i updated windows 7, this computer has been causing me so many problems. and my veriface doesn't work any more. HELP!!!!!!!!!!!!