Support in other languages: 
Reply
Serial Port
benyben
Posts: 29
Registered: ‎05-18-2010
Location: Los Angeles, CA
0

the LCD saga continues - want to cry now

[ Edited ]

Hi

Brief summary of the past:

1. Screen started displaying horizontal lines.But still worked after touching here and there. I therefor assumed that the screen is fine, and the cable is the problem.

2. Bought a new cable.

3. This didn't fix it.
so I assumed it was the top part of the screen, where the cable connects to the lcd.
So i bough a new screen.

4. this didn't fix it as well.
so now i have a new screen, and still ALL I SEE IS WHITE LIGHT coming out of it.

what now?

should I now assume it's this little part that the cable ALSO connects to?
i am talking about the part that sits under the screen, and there are 2 cables connected to it from each side: one from the lcd panel itself, and one from the video card (as the video cable has this intersection, where 1 becomes 2).

 

http://lh6.ggpht.com/_Z4j4C2LFXKE/TJf0sKcKL9I/AAAAAAAAK_g/sc_59vcg_JI/s800/LCD.jpg

 

http://lh5.ggpht.com/_Z4j4C2LFXKE/TJf0roM75sI/AAAAAAAAK_c/hPb9dR5aCiY/s400/LCD%20%281%29.jpg

 

Note from Moderator:  Image(s) >50k converted to link(s).

 

 

Lenovo 3000 N100 0768-BLG
T5500
Geforce 7300 Go
2 Gig Ram
Retired Guru
Duck3
Posts: 2,081
Registered: ‎07-13-2009
Location: USA
0

Re: the LCD saga continues - want to cry now

Check the cable connections.

See THIS also. (White screen problem)

 

Part you are talking about is the Inverter.

Serial Port
benyben
Posts: 29
Registered: ‎05-18-2010
Location: Los Angeles, CA
0

Re: the LCD saga continues - want to cry now

Hi
I have some news.
So here is what I thought of: I downloaded a LIVE CD of Linux Puppy (knowing it can fully run from the CD and boot from it).
I than managed to get the external monitor working (once puppy ran), BUT, here is what I get:
please see video:

 

YouTuve Video

 

Please analyze - does this shade new light on the issue?

THANKS

Lenovo 3000 N100 0768-BLG
T5500
Geforce 7300 Go
2 Gig Ram
Retired Guru
Duck3
Posts: 2,081
Registered: ‎07-13-2009
Location: USA
0

Re: the LCD saga continues - want to cry now

Maybe, maybe not.
Could be a Puppy config problem, with monitor or laptop graphics. Not sure from here!
Check the external monitor settings, like Auto Adjust, etc.

Did you recheck the lcd cables to your new panel?
Especially the flat ribbon going into top back of panel.
Was the new panel "bare"? (No cables)
Serial Port
benyben
Posts: 29
Registered: ‎05-18-2010
Location: Los Angeles, CA
0

Re: the LCD saga continues - want to cry now

it's weird, because I have tried to reload puppy, and it won't show a picture this time (tried it 3 times). And I know it loaded, because I can hear the CD working and the HDD light flashing.

 

Why would it show up once, and now it won't?

 

Yes, the LCD did cam bear. That is, no video cable (if that's what you mean).

 

I am really lost.

Lenovo 3000 N100 0768-BLG
T5500
Geforce 7300 Go
2 Gig Ram
Retired Guru
Duck3
Posts: 2,081
Registered: ‎07-13-2009
Location: USA
0

Re: the LCD saga continues - want to cry now

[ Edited ]

Yes, weird. It may be the graphics hardware on the motherboard. Inverter is possible also, I guess.

I have no further ideas at this time, sorry.
If I think of any, I will post or PM you.

Blue Screen Again
jazz_deluxe
Posts: 9
Registered: ‎06-26-2010
Location: France
0

Re: the LCD saga continues - want to cry now

looks like an inverter problem . Some guy i know had the same problem and he said it was the inverter ...  i hope so , because if it's the motherboard you'll be hard pressed i think to get a new one for a good price ...

Serial Port
benyben
Posts: 29
Registered: ‎05-18-2010
Location: Los Angeles, CA
0

Re: the LCD saga continues - want to cry now

I think I am going to let it die. Because I don't think it's the inverter. I think it's the GPU or the MBoard. Why do I think this? Well, I am not knowledgeable in computers, but when I managed to get an external display running (this only happened one), there were a lot of distortion. This made me feel that the problem is the GPU.....

now that I think of it, I don't see why this would be a better assumption than assuming it's an inverter.
Lenovo 3000 N100 0768-BLG
T5500
Geforce 7300 Go
2 Gig Ram
Retired Guru
Duck3
Posts: 2,081
Registered: ‎07-13-2009
Location: USA
0

Re: the LCD saga continues - want to cry now

[ Edited ]

With a bad inverter, the backlight would not light up.
That's my understanding, at least.

So, if everything else is correct, cables, panel is right model,
etc., you may be right. GPU or other motherboard problem.

Serial Port
benyben
Posts: 29
Registered: ‎05-18-2010
Location: Los Angeles, CA
0

Re: the LCD saga continues - want to cry now

Yes. I am also assuming this (tell me if correctly so): when a laptop is connected to an external monitor, the inverter becomes irrelevant (that is, the inverter is not needed - not used - to produce the picture).

If this assumption is right, than it means that even if the laptop's display is malfunctioning, I would still get an image from the external display.

 

Is this a right assumption?

 

(i am only going over these issues so I will know i am not giving up on my main - and best - computer of the house)

 

 

Lenovo 3000 N100 0768-BLG
T5500
Geforce 7300 Go
2 Gig Ram