Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Blue Screen Again
Posts: 2
Registered: ‎03-16-2012
Location: USA

Intel Wireless Adapter keeps dropping!

[ Edited ]


I recently bought a IdeaPad V570 with the following adapters installed:


Intel Centrino WiMAX 6150

Intel Centrino Wireless N 6150


I use a netgear Wireless N 300 as my wireless router.  The problem is whenever I run on battery, my adapter keeps dropping the connection every few minutes.  I had to troubleshoot and reenable the adapter everytime, and it usually lasts for anywhere from a few seconds to a couple of minutes, and it dropped again. 


This problem doesn't seem to occur as often when I use the power cord.  I tried to look for a driver update online but I couldn't seem to find the right available, as there were only 3 choices and none of them matched neither of the adapter. 


Could anyone please help?  Thanks.



Posts: 3,297
Topics: 25
Kudos: 387
Solutions: 250
Registered: ‎01-21-2010
Location: Etters, PA

Re: Intel Wireless Adapter keeps dropping!

Hi vlau7772 and welcome to the community,


Try the easy stuff first.  Go into control panel, power options, open your power plan and choose advanced.

Check the settings on the wireless adapter, make sure that maximum performance is chosen for both ac adapter and battery.


If it works fine on ac but not on battery, chances are that it's a power setting.



T430u, x301, x200T, x61T, x61, x32, x41T, x40, U160, ThinkPad Tablet 1838-22R, Z500 touch, Yoga Tab 2 Windows 8.1, Yoga Tablet 3 Pro
Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!
If someone helped you today, pay it forward. Help Someone Else!
English English Community   Deutsche Deutsche Community   Español Comunidad en Español   ru.gif Русскоязычное Сообщество
Blue Screen Again
Posts: 2
Registered: ‎03-16-2012
Location: USA

Re: Intel Wireless Adapter keeps dropping!

Nope, it's still not working.  It keeps having to reset my network adapter.