Support in other languages: 
Reply
Fanfold Paper
dragosmc
Posts: 21
Registered: ‎02-03-2012
Location: manchester
0
Accepted Solution

[Solved] V570 UEFI problem

[ Edited ]

Hi guys,

 

I am trying to install Linux on my v570 but I can't make it to boot from anything else instead of Windows. I even tried to wipe out Windows and leave Linux alone on the HDD and then I got the message "no operating systems detected" (or something similar).

 

Is there any workaround for this issue ? Now I'm at the university and I need Linux for daily activites and homework.

 

PS: Hope there is a fix for this because I really like this laptop and don't want to sell it just for that...

 

Thanks,

Dragos.

802.11n
abvasili
Posts: 182
Registered: ‎11-10-2011
Location: Albania
0

Re: V570 UEFI problem

Hi dragosmc,

 

I think this link may be of help. Patiently read the posts. You can use Linux for sure in a UEFI bios. :smileyhappy:

 

http://forums.lenovo.com/t5/Linux-Discussion/SOLVED-No-boot-on-T420-with-debian/td-p/669757

 

Write back if there is anything that you do not understand! 

 

Regards

 

abvasili 

 

P.S.. I do not know what are your preferences, but take a look at linuxmint.com. You will like it! :smileyhappy:

I'm just a volunteer. I like to help others where I can. Do my ideas work? I hope so. o_O
Who helped you today? Do not forget to thank him.
My hardware: TP x120e 0596-2ru. Windows 7, sp1, 64Bit, English, installed in UEFI mode.
Fanfold Paper
dragosmc
Posts: 21
Registered: ‎02-03-2012
Location: manchester
0

Re: V570 UEFI problem

Actually I don't have such an option in the BIOS to switch it to "Legacy mode".

Punch Card
kschumake83
Posts: 27
Registered: ‎12-31-2011
Location: Orefield, Pennsylvania
0

Re: V570 UEFI problem

easiest way around it is to download rescatux, its a live cd that restores grub or in our case installs grub (not grub2 which is incompatible with our uefi) once you download rescatux burn it to cd then install the linux distro of your choice. once the distro is installed reboot with the rescatux cd in and boot off of the live cd, select repair grub and when that finishes you will have a working bootloader. or you can just install linux mint 11 or 12 that already have the correct bootloader, but not debian or xfce. i believe suse will boot without any bootloader work but you cant see any other distros with that bootloader if you dual boot, at least not without some command line bs.

Fanfold Paper
dragosmc
Posts: 21
Registered: ‎02-03-2012
Location: manchester
0

Re: V570 UEFI problem

OK, thanks. Now you gave me some work... :smileyvery-happy:

Fanfold Paper
dragosmc
Posts: 21
Registered: ‎02-03-2012
Location: manchester
0

Re: V570 UEFI problem

Oh, i forgot to ask: where should i install the GRUB ? in /dev/sda1 which is the GPT partition or in Linux's own /boot partition ?

Punch Card
kschumake83
Posts: 27
Registered: ‎12-31-2011
Location: Orefield, Pennsylvania
0

Re: V570 UEFI problem

Just default setting it that's what I did, whatever it was on is what I put it on.
Punch Card
kschumake83
Posts: 27
Registered: ‎12-31-2011
Location: Orefield, Pennsylvania
0

Re: V570 UEFI problem

Sorry didn't read your whole post put it on sda1 that's where I have it
Fanfold Paper
dragosmc
Posts: 21
Registered: ‎02-03-2012
Location: manchester
0

Re: V570 UEFI problem

[ Edited ]

Ok, here is the grub_install log. It seams that something went wrong (there is no boot menu after restart) and besides that, "Update GRUB Configuration" doesn't work (throws the error message).

 

log: http://paste.debian.net/155523/

 

PS: Here is the Bootinformation log

 

log: http://paste.debian.net/155524/

802.11n
abvasili
Posts: 182
Registered: ‎11-10-2011
Location: Albania
0

Re: V570 UEFI problem

Can you format your HDD to mbr partition table instead of GPT? Grub can't be installed on GPT partition table.

 

abvasili

I'm just a volunteer. I like to help others where I can. Do my ideas work? I hope so. o_O
Who helped you today? Do not forget to thank him.
My hardware: TP x120e 0596-2ru. Windows 7, sp1, 64Bit, English, installed in UEFI mode.