Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
anselmop
Posts: 5
Registered: ‎07-22-2008
Location: Brazil
0
Accepted Solution

Sound does not work on Ubuntu

Hi, folks. I have just installed Ubuntu 8.04 on my N200 7369-AAP and I can't hear any sound. The volume controller on Gnome shows normally, as if the sound card was working. Have any of you come across the same problem? I would be grateful for any help.
Punch Card
wonnage
Posts: 10
Registered: ‎07-19-2008
Location: Berkeley
0

Re: Sound does not work on Ubuntu

Can you open the sound settings up? This is the screen where you can choose the sound system (ALSA, OSS, etc.). Try forcing it to ALSA instead of Pulseaudio, that helped for mine.
Punch Card
JeniSkunk
Posts: 35
Registered: ‎05-17-2008
Location: Australia
0

Re: Sound does not work on Ubuntu

I think the problem is caused by a lack of hardware drivers in the distribution of Debian on which Ubuntu and other current distributions of Linux are based.

I have tried the KDE desktop based LiveCDs of Kubuntu 8.04.1; and SimplyMEPIS 7.0, and both have no sound at all on my 3000 n200 0769-A64. Kubuntu uses KDE 4.0, and SimplyMEPIS uses KDE 3.5. Neither have PulseAudio as an available audio output option.

 

In Ubuntu 8.04.1, the only audio output choices I have are:

HDA Intel (ALSA Mixer)

Realtek ALC861-VD (OSS Mixer) 

Playback: ALSA PCM on front: 0 (ALC861VD Analog) via DMA (PulseAudio Mixer)

  

Irrespective of which audio output device I select, I get no sound at all from my notebook under these distributions of Linux. 

I cannot see how to change which sound system is being applied to which audio output device in Ubuntu. 

Before testing in each case I made sure that the volume sliders were set to maximum, and that the devices were not muted. 

 

I've not tried a current LiveCD of Linux that is not based on Debian. 

 

Jenifur Charne

Lenovo 3000 N200 0769A64 owner.
Serial Port
cb750rob
Posts: 30
Registered: ‎03-03-2008
Location: Wales
0

This fix worked for me

[ Edited ]

Hi folks, I have a 3000 n200 0769brg and the following worked for me on both mint and Ubuntu so prob ok on debian based distro. Also I think you need multiverse&universe or your distros repository equivalents enabled

 

I take no credit for finding the solution offered here, but instead, offer eternal thanks to "jamdess" and "Apprenti_chercheur" for their excellent knowledge of Linux..
 
The first step is to download the latest ALSA driver and associated files from:- http://www.alsa-project.org/
At the time of writing  the following versions were available, I suggest you download all of them:-


alsa-driver-1.0.17
alsa-lib-1.0.17
alsa-utils-1.0.17
alsa-tools-1.0.17
alsa-firmware-1.0.17
alsa-plugins-1.0.17
alsa-oss-1.0.17
pyalsa-1.0.17

 


Open a terminal window hit return after each line of codealso I had to hit "y" for yes to allow some changes


Create a folder called "alsa" in your home directory with the command;-

Code:
mkdir ~/alsa
Move the downloaded files to this directory.
Execute the following commands from within a terminal.

Code:
sudo apt-get install build-essential ncurses-dev gettext

sudo apt-get install linux-headers-`uname -r`

cd ~/alsa
tar -xvf alsa-driver-1.0.17.tar.bz2
tar -xvf alsa-lib-1.0.17.tar.bz2
tar -xvf alsa-utils-1.0.17.tar.bz2
tar -xvf alsa-oss-1.0.17.tar.bz2

cd alsa-driver-1.0.17
./configure --with-cards=hda-intel
make
sudo make install

cd ../alsa-lib-1.0.17
./configure
sudo make install

cd ../alsa-utils-1.0.17
./configure
sudo make install

cd ../alsa-oss-1.0.17
./configure
sudo make install

 

Edit your alsa-base file
Code:
sudo gedit /etc/modprobe.d/alsa-base
Add the following line to the file

Code:
options snd-hda-intel position_fix=1 model=lenovo
Save the file and reboot the computer and hopefully you should now have sound.

 

Hope this helps

 

Regards

Rob

 

 

Message Edited by cb750rob on 07-29-2008 08:50 PM
Serial Port
cb750rob
Posts: 30
Registered: ‎03-03-2008
Location: Wales
0

Re: This fix worked for me

Sorry forgot to add:

 

open terminal:

 

code:

alsamixer (hit return)

 

you can now adjust the volumes once all previous instructions followed

 

Cheers!

Paper Tape
mycroft72
Posts: 1
Registered: ‎08-05-2008
Location: Swansea, United Kingdom
0

Re: This fix worked for me

Hi, I've got Ubuntu 8.04 with Gnome running on a 3000 N200 0769-K2G, and I just went with the following from Rob's post, and didn't need to re-compile alsa, the Intel chipset support was already there.

 

> Edit your alsa-base file
> Code:
> sudo gedit /etc/modprobe.d/alsa-base
> Add the following line to the file
>
> Code:
> options snd-hda-intel position_fix=1 model=lenovo

 

Thanks Rob.

 

Sim

Paper Tape
Onin
Posts: 1
Registered: ‎08-20-2008
Location: Czech Republic
0

Re: This fix worked for me

It worked for me as well. Lenovo 3000 N200, type 0769-BNG. Ubuntu 8.04 Hardy Heron. Thanks a lot!
What's DOS?
satheesh
Posts: 1
Registered: ‎09-20-2008
Location: India
0

Re: This fix worked for me

 Hello, I used the codes Specified by ROb and after 1 month I got the sound issue fixed on my Lenovo 3000 N200 laptop

 

THANK YOU VERY MUCH FOR YOUR HELP   ROB

 

 

Serial Port
cb750rob
Posts: 30
Registered: ‎03-03-2008
Location: Wales
0

Re: This fix worked for me

Glad it helped :smileywink:
Fanfold Paper
HandyAlan
Posts: 5
Registered: ‎11-06-2008
Location: Ann Arbor, MI
0

Re: This fix worked for me

Try 8.10 it does a variety of good things, namely sound and Cisco wi fi without intervetion.