Support in other languages: 
Reply
Paper Tape
red_revenger
Posts: 10
Registered: ‎10-12-2009
Location: kathmandu
0

Ubuntu 11.10 failed to boot after (un)successful install on Thinkpad X61

Hello,
I installed Ubuntu from a USB drive and now it won't boot. I get the screen from which I can enter BIOS and manually boot from the USB stick but it won't automatically boot from the HDD. if I don't do that, what happens is that once the BIOS screen disappears all I get is a black screen with a blinking cursor in the top left corner. nothing else happens anymore. pressing down any key has no effect.

Shortly before finishing the installation, I get this message: "An attempt to configure apt to install additional packages from the CD failed". it doesn't say that the installation as a whole failed thought...
Your help is appreciated!

802.11n
abvasili
Posts: 182
Registered: ‎11-10-2011
Location: Albania

Re: Ubuntu 11.10 failed to boot after (un)successful install on Thinkpad X61

Hi red_revenger,

 

Can you try formatting the usb in fat32 with the windows (or Linux) tool and after that dump again the ISO image to your usb with unetbootin.

 

If the problem persist, make a test with another distro, or another version of ubuntu.

 

If after all steps above you can't still start the system, the problem might be elsewhere. Post back the outcome. 

 

abvasili

I'm just a volunteer. I like to help others where I can. Do my ideas work? I hope so. o_O
Who helped you today? Do not forget to thank him.
My hardware: TP x120e 0596-2ru. Windows 7, sp1, 64Bit, English, installed in UEFI mode.
Paper Tape
Stephen_Beynon
Posts: 1
Registered: ‎05-04-2012
Location: UK
0

Betreff: Ubuntu 11.10 failed to boot after (un)successful install on Thinkpad X61

The reason for this is the ACPI support in the X61 is poor.  I have managed to get ubuntu to boot by disabling the acpi.

 

To do this you will need to get up the ubuntu boot menu.  This is done by hitting escape just as the bios finishes before ubuntu starts to boot.  I tend to hit escape repeatedly to catch the moment.

 

When the menu comes up hit 'e' to edit the default boot configuration

use the arrow keys to take you down to the line which starts "linux" and insert acpi=off just after the word ro

hit F10 to boot

 

When you have booted and logged in you will need to make this change persistant.  To do this open up a terminal window and type

sudo pico /etc/default/grub

 

Change the line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"

hit ctrl-X to exit pico and save the file then type

sudo update-grub

to update the boot menu with the new settings