Support in other languages: 
Reply
Punch Card
Mainframe_Snob
Posts: 50
Registered: ‎12-25-2009
Location: EU
0

W520, Debian 64-bit (Testing) + VT enabled

[ Edited ]

Hello all,

 

 

on booting the abovmentioned configuration, at boot time, everything stops with multiple "udev..." messages.

 

If I disable VT, boot process completes.

 

I have tried a different Linux flavour (Gentoo 64-bit) and the same thing happens with VT enabled.

 

Anyone any ideas??

 

 

Regards,

 

 

 

Aubrey

 

 

 

PS Debian Kernel is 3.2.

Community Moderator
zoltanthegypsy
Posts: 3,292
Registered: ‎01-13-2008
Location: Bainbridge Island, WA, USA
0

Re: W520, Debian 64-bit (Testing) + VT enabled

Hi Mainframe_Snob,

 

Is there anything useful in the thread below?  I haven't chased down all the links, but it looks similar.

 

64-bit Linux, W520 & nVidia

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.

 

The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored. ... GeezBlog

Punch Card
Mainframe_Snob
Posts: 50
Registered: ‎12-25-2009
Location: EU
0

Re: W520, Debian 64-bit (Testing) + VT enabled

Appreciate the prompt reply.

 

Afraid none of the solutions are applicable in my case.

 

*MUST* be able to run 64-bit.

 

 

 

Regards,

 

 

 

Aubrey

802.11n
Volker1
Posts: 334
Registered: ‎03-02-2010
Location: Dublin
0

Re: W520, Debian 64-bit (Testing) + VT enabled

[ Edited ]

I'm running Fedora 16 64-bit on my W520 with VT-d enabled. The difference is that I disabled the NVidia card in the bios and use the Intel graphics. Better battery life, too. 

 

This bug with the NVidia driver/chip has been out for a while now. It would be nice if somebody at NVidia would fix it, or give us the source so we can fix it ourselves...

 

Edit: seems like its fixed in NVidia driver 295.09 beta (beta is a state of mind!)

Punch Card
Mainframe_Snob
Posts: 50
Registered: ‎12-25-2009
Location: EU
0

Re: W520, Debian 64-bit (Testing) + VT enabled

I am afraid with the Nvidia Beta driver 295.09 this problem has not gone away..

Punch Card
Mainframe_Snob
Posts: 50
Registered: ‎12-25-2009
Location: EU
0

Re: W520, Debian 64-bit (Testing) + VT enabled

Hello all,

 

I see that BIOS 1.36 has been released for the abovementioned Thinkpad.

 

I have duly installed same but STILL CANNOT boot my Debian 64-bit Linux with VT-D enabled.

 

Thousands of "DRAM..error" and / or UDEV messages are issued at the start of the boot sequence.

 

I do not want to run this machine with ACPI=off and only run with one CPU or try any hacks to try and circumvent this nor am I interested in running on the integrated Intel GPU (which also does not work, see above error message description).

 

I am currently running with the Nvidia 295.09 driver.

 

 

A DEFINITIVE STATEMENT from Lenovo on whether this is a BIOS problem or not would be helpful.

 

 

Punch Card
Mainframe_Snob
Posts: 50
Registered: ‎12-25-2009
Location: EU
0

Re: W520, Debian 64-bit (Testing) + VT enabled

** No interest or competence here ?? **

 

 

Still waiting for a reply.

 

 

 

Aubrey

 

 

 

PS Not impressed at all.

Mark_Lenovo
Posts: 7,835
Topics: 410
Kudos: 1,308
Solutions: 283
Registered: ‎11-19-2007
Location: RTP, North Carolina
0

Re: W520, Debian 64-bit (Testing) + VT enabled

Mainframe_Snob,

 

Please understand that the Linux boards in this forum are going to have to run as peer to peer support.  Lenovo supports the Windows preloads, so while it is possible we have some quirk that needs to be addressed in BIOS it is difficult to open this as a formal problem for engineering to chase to a definitive solution.

 

If this ALSO occurs under windows, then it may be easier to obtain greater focus on the issue.

 

That said, if you will post some additional details on this including the error list.  (Is there a way you can capture the list?) 

We can try check into this a bit further.

 

I appreciate your understanding.  

 

Thanks

 

Mark

____________________________________________

ThinkPads: S30, T43, X60t, X1, W700ds, IdeaPad Y710, IdeaCentre: A300, IdeaPad K1
Mark Hopkins
Program Manager, Lenovo Social Media (Services)
www.twitter.com/lenovoforums
www.facebook.com/lenovo

English English Community      Deutsche Deutsche Community      Español Comunidad en Español

Punch Card
Mainframe_Snob
Posts: 50
Registered: ‎12-25-2009
Location: EU
0

Re: W520, Debian 64-bit (Testing) + VT enabled

Hello Mark,

 

as these messages  (see previous posts) happen at the very start of the boot sequence, it is impossible for the kernel to start writing its logs, hence the difficulty in providing "hard" evidence.

 

Supposedly there was a Linux kernel (IOMMU) bug in the early 3.x kernels that should have been addressed in the latest (3.3) kernel, alas, this is not the case - still the same problem. See this post - http://www.phoronix.com/scan.php?page=news_item&px=MTAzNzk

 

The problem also occurs when I use the Intel integrated graphics card only (i.e. disable the Nvidia card).

 

I have tried this (enable VT-d) with Liquorix kernels 3.0-3.2 and a vanilla 3.3 kernel, all with the same result.

 

Here is one of many google hits returned if one enters the following keywords "w520  bios vt-d dmar boot"

 

http://web.archiveorange.com/archive/v/u1yF7FblX57xwavu9sBj

Punch Card
Mainframe_Snob
Posts: 50
Registered: ‎12-25-2009
Location: EU
0

Re: W520, Debian 64-bit (Testing) + VT enabled

@Mark,

 

 

below URL for W520 DMESG boot with VT-d disabled.

 

[URL=http://www.zshare.net/download/99166017a138c52e/]W520-Boot-VT-d_disabled.txt - 0.04MB[/URL]