Support in other languages: 
Reply
SCSI Port
maortl
Posts: 73
Registered: ‎09-06-2011
Location: Israel
0

ubuntu 11.10 on w520

i really like linux but the experience on ubuntu under the w520 is plain awful!

the computer get reaaaaaally heated up! and also extreme battery lose!

also if i leave the computer plugged in to the charger it seems that the brick gets reaaallly heated up! even tho the computer is already charged to 100%....

 

i never experience these issues in windows... 

 

anyone got some solutions maybe? maybe a differente distro??

Token Ring
Chatbox
Posts: 487
Registered: ‎11-04-2010
Location: Sydney
0

Re: ubuntu 11.10 on w520

[ Edited ]

I just went through the whole Ubuntu 11.10, 64bit, nvidia, compiz, on W520 saga.

 

It's a real mess.

 

Here are the issues I ran into from the get go:

1. Prior to starting the Ubuntu 11.10 64bit installation from the CD, I've set display to Discrete mode in the BIOS.

2. Installation went smooth (great...or so I thought).

3. System boots up, no issue.

4. Ran the Update Manager, updated 300+ packages, 275MB or so.  No problem here.

5. Reboot....first thing you'll run into is that the new nvidia driver will no start up successfully 100% of the time...X may, or may not start up successfully.  If it doesn't, then you're stuck at a blank screen...Sometimes, you can get to the text terminal by Ctrl-Alt F1...if needed.  To fix this, you either have to add "acpi=off" (bad choice) or "pci=noacpi" (better choice) to the boot parameter (mentioned in nVidia driver's Readme - Common Problems section).  Then X will be able to start successfully.

6.  Next issue, running Compiz in Unity (not Unity 2D), you'll notice that moving windows around is laggy.  This is fixed in Compiz 0.9.7...but it's not listed in the update manager yet.

7.  Next issue, brightness control using Fn+Home and Fn+End.  You'll either not be able to see the brightness indicator (OSD) correctly.  the OSD indicator doesn't show the correct brightness level on screen.  You can still adjust the brightness...it just doesn't show up correctly in the indicator.  To fix this, you'll use the nox2apic parameter instead of the ones from Point 5 (above).  Also added the EnableBrightnessControl=1 option to the xorg.conf file.

8. Now, graphics is work, brightness control works...what else could be wrong, right?  Here's what's wrong, brightness steppings.  In Windows (and in BIOS, DSDT), you have 16 levels of brightness (0-15 inclusive).  Now, in Linux, you only get about 7.  Not a big deal...

9. Here's what else is wrong.  When the laptop is running on battery, CPU speed will not throttle correctly...and only have a max of 1GHz (cat /proc/cpuinfo | grep -i mhz).  If you go back to the pci=noacpi parameter, the scaling seems to be correct....

 

All in all, Ubuntu's GUI has a lot of work to do when it comes to performance and polish (Unity and compiz...OMG...don't use it).  NVIDIA driver requires some looking into to get it to work "well" with the correct kernel parameter, so that the end result will not interfere with ACPI, nor SpeedStep.

 

In the end, I decided that the W520's "Windows 7" sticker does really mean what it says.  For Windows 7.

 

For now, I would say "Stay the fxxx away from Unity".  I've yet to find a way to get the nvidia driver, ACPI (and hotkey), cpu scaling (with and without battery)...too all work together.

 

And then there's also the issue of battery life (lack of true stable Optimus support).

 

If stability, battery life & (graphics) performance is what's needed...then Windows seems to be the only option for now.

 

I also tested out the Hackintosh way of things.  Again, not a great experience.   Graphics is stable.  What's not stable is USB 2 and USB 3 during sleep and wakeup cycles (would kernel panic),  audio (VoodooHDA 2.7.3) is not stable either.

buddinggeek
Posts: 2,844
Topics: 105
Kudos: 139
Blog Posts: 0
Solutions: 118
Registered: ‎02-22-2008
Location: Telangana , India +GMT 5.30
0

Re: ubuntu 11.10 on w520

[ Edited ]

Have you tried to use the opensource Nouveu drivers? I know unity sucks as what it is right now...IU faced the same issue when i installed ubuntu 11.10 .... I used cinnamon to replace unity...everything runs ok now 

 

 






Cheers and regards,
• » νιנαソѕαяα∂нι ѕαмανє∂αм ™ « •
Think : T410,X220T,Thinkpad Yoga
Idea :3000H,Z500,U410,Yoga 11, Yoga tab 10,Horizon

●๋•کáŕádhí'ک díáŕý ツ


I am a volunteer here. I don't work for Lenovo
SCSI Port
maortl
Posts: 73
Registered: ‎09-06-2011
Location: Israel
0

Re: ubuntu 11.10 on w520

yeah but the problem i am talkin about is that the computer gets really heated when i plug it in and work on it
on battery it seems fine but there is an extreme battery usage
Token Ring
Chatbox
Posts: 487
Registered: ‎11-04-2010
Location: Sydney
0

Re: ubuntu 11.10 on w520

[ Edited ]

Power management for laptops in the land of Linux is not known to be spectacular.  Having said that, I've read that Mint, or Fedora (can't remember which) has done some dedicated work on PM.  I might check them out shortly.

 

I took a look at the Nouveu site.  The "current status" section alone has already deterred me from using it:

"2D support is in very good shape"  --> It should be ROCK solid...come on...2D.

"Suspend and resume is working for many chips" --> lacks driver maturity.

"Some 3D acceleration exists"...If that's the case, I might as well just use the Intel Integrated Display.

"Nvidia Optimus support is not implemented yet"...No other platform has Optimus working properly except Windows (and some can argue that the implementation of Optimus in Windows on the W520 is a bit wacked).

 

Some people install Linux on the W520 have lower expectations.  I don't.  I mean, having a Quadro chip just so one can run a 2D desktop environment?

Token Ring
Chatbox
Posts: 487
Registered: ‎11-04-2010
Location: Sydney
0

Re: ubuntu 11.10 on w520