Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
jamco
Posts: 3
Registered: ‎05-02-2011
Location: Japan
0
Accepted Solution

L420 Audio problems

Hi,

 

I'm having a few problems with my new L420. Specifically, I'm having trouble with the onboard audio. Generally, the output seems to work fine (e.g. watching videos, general windows sounds), but I've had issues with a few applications (e.g. Skype) where the speakers are recognized but do not work at all. A bigger problem though is the onboard microphone, which hasn't ever worked since day one.

 

I've tried changing the sound settings in the Windows 7 control panel and although the microphone is listed under recording devices, it does not receive any sound. The "setup microphone" wizard, sound recorder and Skype all have the same issue in detecting input from the microphone, sometimes accepting that the microphone exists, other times not, but never receiving any sound.

 - I have muted and unmuted it in sound properties, using the Lenovo Communications utility and using the keyboard hotkeys.

 - I have uninstalled and reinstalled the latest Realtek audio driver (from the Lenovo website).

 - I have checked in the BIOS that the microphone is enabled (under "Security" > "I/O devices").

 

In addition, from time to time the speakers (under Sound > playback devices) cannot be configured, saying "Failed to play tone" when tested. This problem is not always the case and is not easily replicated, but when it does occur it affects other Windows applications.

 

Hope there's someone out there that can help me out with this! Many thanks in advance!

 

 

 

 

System information:

Lenovo L420

Windows 7 Home Premium

Core i5-2410M, 4Gb Ram

Integrated fingerprint reader, webcam, speakers and microphone (apparently)

Retired Employee
Serge1410
Posts: 2,438
Registered: ‎04-10-2011
Location: Malaysia
0

Re: L420 Audio problems

hey jamco,

could you try this ..

1. uninstall current audio drivers
2. let win7 install generic audio drivers
3. test the audio and mic with the generic drivers, via windows sound and with sound recorder.

if it works, then reinstall skype and do that skype test call.

check and see if it works. if it does not; i suggest getting in contact with skype tech support





WW Social Media
Important Note: If you need help, post your question in the forum, and include your system type, model number and OS. Do not post your serial number.

Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!



Follow @LenovoForums on Twitter!
Have you checked out the Community Knowledgebase yet?!
How to send a private message? --> Check out this article.
Paper Tape
jamco
Posts: 3
Registered: ‎05-02-2011
Location: Japan
0

Re: L420 Audio problems

Thanks, that did the trick!

 

Now the mic works with Windows sound recorder (and by extension, Skype and other applications).

 

As a side note, I have noticed that if I try to configure the microphone (sounds > recording devices), it loses functionality and I have to reinstall the drivers again. But this is no real problem - I just won't bother configuring through Windows! I wonder if there is any chance that by attempting to configure the mic I am somehow switching from inbuilt mic to the mic jack for some reason?

 

Anyway, that's no longer a concern for me. Thanks for your help!

Fanfold Paper
bert520
Posts: 5
Registered: ‎05-23-2011
Location: Nederland
0

Re: L420 Audio problems

Hello Serge,

On my L520 I had the same issue, solved by the same solution.
Thanks.
What's DOS?
rahchgo
Posts: 1
Registered: ‎05-27-2011
Location: Chicago
0

Re: L420 Audio problems

I had the same problem on my new L520.    Here's a little more information.    The factory installed driver was  Realtek High Definition Audio Driver  Version 6.0.1.6287.   iTunes and Windows media player worked fine with this driver and the internal speakers, however, Skype would not play on the internal speakers, but workd fine when I plugged in my iPhone headset to the audio jack.  The built in microphone would not work with Skype or the installed Windows microphone setup software.   If fixed the problem as suggested above.  In my case, I went to the audio driver device properties window and clicked on the Rollback button.   That installed Microsoft High Definition Audio Driver  version 6.1.7601.17514  dated 11/19/2010.   So far, this driver is working fine with all my audio applications, including Skype, using the internal microphone and speakers and my iPhone headset.  

Punch Card
Bardamu
Posts: 27
Registered: ‎05-28-2011
Location: Denmark
0

Re: L420 Audio problems

[ Edited ]

I have the same problem, and even though the fix above is a good workaround, I'm still sadly missing all the sound options, which the Realtek drivers have.

 

If there is a way to get the Realtek drivers to work, please let me know. :smileyhappy:

 

Edit: I simply downloaded the new Realtek drivers from the Realtek site, and that did the trick! Now I have all of the sound options and none of the issues. :smileyhappy:

What's DOS?
sadeanandkiran
Posts: 1
Registered: ‎03-20-2012
Location: Bangalore
0

Re: L420 Audio problems

Hi Bardam,

 

Could you please provide with the link, that you have downloaded from ?

 

Thank you!

Guru
PeterTWJ
Posts: 1,102
Registered: ‎05-29-2010
Location: Singapore
0

Re: L420 Audio problems

Hi sadeanandkiran

 

Here it is
http://www.realtek.com/downloads/downloadsCheck.aspx?Langid=1&PNid=24&PFid=24&Level=4&Conn=3&DownTyp...

 

Have a nice day! :smileytongue::smileyhappy::smileyvery-happy:

Peter
W520 (4284-A99)

Does someone’s post help you? Give them kudos as a reward, as they will do better to improve | Mark it as solved if the solution works for you, so it could be reference for others in the future 

=====================================

Sound Enthusiast and Enhancement (Post comments, share mixes, etc.) 

http://forums.lenovo.com/t5/General-Discussion/Dolby-Home-Theater-v4-for-most-Lenovo-Laptops/td-p/62...