Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Fanfold Paper
m1tYo
Posts: 13
Registered: ‎01-10-2012
Location: Bulgaria
0

L420 - video problems with Intel HD 3000

I have recently bought a Thinkpad L420 with integrated graphics - Intel HD 3000. At first it was all OK, but after a while the issue has been revealed - hd videos starting from 480p seem to be a problem which is unacceptable for a graphic unit like this. 1080p is not even mentioned. And the interesting fact is that it is a problem for all players, except windows media player, even though in the beginning I was able to watch everything on every player I want. Of course, I checked the GPU loading while playing a video and it was 12% average, so I tried reinstalling the drivers and I did it from three different places - the Lenovo support, Intel's support and windows update and every time there was no result. BUT, the last time on windows update the miracle happened - videos were playing nice and smooth, 1080p was a delightful view and I was like in heaven... but was only for 24 hours. On the next day I was watching a movie and everything was just fine, after that a played another video file and the problem started all over again. Now I can't fix it. Please someone tell me what to do!

Retired Employee
Serge1410
Posts: 2,438
Registered: ‎04-10-2011
Location: Malaysia
0

Re: L420 - video problems with Intel HD 3000

hey m1tYo,

uninstall the current graphic driver for your unit and let windows install its generic drivers and test video playback.

is it smooth?

after that, head over to >>http://support.lenovo.com , download the driver and before installing set your unit to diagnostic mode via msconfig.





WW Social Media
Important Note: If you need help, post your question in the forum, and include your system type, model number and OS. Do not post your serial number.

Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!



Follow @LenovoForums on Twitter!
Have you checked out the Community Knowledgebase yet?!
How to send a private message? --> Check out this article.
Fanfold Paper
m1tYo
Posts: 13
Registered: ‎01-10-2012
Location: Bulgaria
0

Re: L420 - video problems with Intel HD 3000

[ Edited ]

Thanks for the advice. I tried it, but infortunately - no success .. I'm considering installing a fresh new copy of windows.

Fanfold Paper
m1tYo
Posts: 13
Registered: ‎01-10-2012
Location: Bulgaria
0

Re: L420 - video problems with Intel HD 3000

I've reistalled the windows. The issue remains. I don't know what to do, except to send it for diagnostics.