Support in other languages: 
Reply
Fanfold Paper
Alpo
Posts: 17
Registered: ‎06-02-2011
Location: Finland
0

Re: L520 - random sleep and constant fan

I was just going to try that version for W520, but I guess there's no need anymore. Random sleep problem is not so severe with this laptop. Probably the latest bios and other updates have done something for this issue, also for your machine Bardamu. Since those updates, random sleep has occured here maybe just once or twice.

 

After several  months, there's still no "official" reply from Lenovo staff for this problem... This sucks. 

 

What's DOS?
Orlando1234
Posts: 2
Registered: ‎09-03-2011
Location: Miami
0

Re: L520 - random sleep and constant fan

Has anyone found a fix for this?:womansad:

Paper Tape
Tyrone
Posts: 6
Registered: ‎05-03-2011
Location: Deutschland
0

Re: L520 - random sleep and constant fan

Unfortunately the same problem here.

The L520 I'm having here is the first we introduced in our company, and it is by great lengths superior to the L512's we had been giving out in the last year. But the constant fan buzz is just awful. This laptop has an idling second generation i5 and intel graphics - it should actually be possible to cool that machine passively. If the fan was only slower, it would help a lot.

The energy-settings seem to be fine, at least the powercfg -energy command didn't show any curious problems.

Lenovo, can't you please look into this? How is it possible nobody realized this while testing the laptop?

So yeah, we really need to get a BIOS-fix, again, to not to be annoyed by our Thinkpads (remember the L512-speedstep issue where one of the CPU cores was constantly overclocked?). 

Please Lenovo, look into this. This issue is nerve-wrecking.

Fanfold Paper
Alpo
Posts: 17
Registered: ‎06-02-2011
Location: Finland
0

Re: L520 - random sleep and constant fan

About the sleep issue. I found for example these event at event viewer when random sleep occurs:

 

1. Kernel-power

 

The system is entering sleep.

Sleep Reason: Application API

 

2.  Kernel-general

 

The system time has changed to ‎2011‎-‎09‎-‎22T14:15:20.500000000Z from ‎2011‎-‎09‎-‎22T14:14:34.462154100Z.



3. NETwns64

 

The \Device\NDMP4 service entered the Intel(R) WiFi Link 1000 BGN state. 

 

4. Power troubleshooter

 

The system has resumed from sleep.

Sleep Time: ‎2011‎-‎09‎-‎22T14:14:30.017899900Z
Wake Time: ‎2011‎-‎09‎-‎22T14:15:23.043145400Z

Wake Source: Unknown 

 

 

I did some changes to bios and windows settings, let's see if those help. If we had a bios option to disable sleep states, I guess this problem could be solved. Unfortunately we don't have those options.. So any fix coming? 

Punch Card
Bardamu
Posts: 27
Registered: ‎05-28-2011
Location: Denmark
0

Re: L520 - random sleep and constant fan

Still no bios fix or Lenovo acknowledgement of the constant fan, but the creator of TPFancontrol responded in another forum:


troubadix wrote:
it's an incompatibility problem of lenovo software (powermanager, hotkeymanager) and TPFanControl, as the access to EmbededController is not coordinated, as I wrote in .ini

// advice for programmers: TPFanControl must acquire mutex named
// "Access_Thinkpad_EC" to get access to embedded controller

.... lenovo is neglecting this piece of advice :roll:

 

If Lenovo is unwilling to fix the fan behavior directly, perhaps they could implement this advice, so we could at least use TPFancontrol to silence our fans.

 

I tried uninstalling the mentioned Lenovo progams, powermanager and hotkeymanager, but that didn't do anything except derive me of functionality.

Punch Card
troubadix
Posts: 22
Registered: ‎05-04-2008
Location: Marburg, Germany
0

Re: L520 - random sleep and constant fan

[ Edited ]

you have to uninstall  Thinkpad Power Manager Driver, look at faqs at http://tpfancontrol.com

Punch Card
Bardamu
Posts: 27
Registered: ‎05-28-2011
Location: Denmark
0

Re: L520 - random sleep and constant fan

Thanks troubadix!

 

I tried uninstalling that driver before, but I guess it didn't work, because I wasn't doing if from a boot to safe mode.

 

I've just now booted to safe mode and uninstalled the driver, so I'm hoping this will work.

Fanfold Paper
Alpo
Posts: 17
Registered: ‎06-02-2011
Location: Finland
0

Re: L520 - random sleep and constant fan

Thanks for this info! I'll give it a try someday.

Paper Tape
Martin_Smith
Posts: 9
Registered: ‎12-07-2011
Location: UK
0

Re: L520 - random sleep and constant fan

I thought I had found the perfect laptop for me given the constant fan noise and the apparent random sleep problem, I am not going to pursue the purchase anymore. I wish Lenovo would address this issued but given that they appear so unresponsive, I will not splash out the money until this matters are resolved.
Fanfold Paper
Alpo
Posts: 17
Registered: ‎06-02-2011
Location: Finland
0

Re: L520 - random sleep and constant fan

I disabled all Lenovo power systems using Autoruns (thanks to troubadix!). By doing that random sleep problem seems to be gone. At the same time I lost on-screen volume display and some other on-screen notifications too. I can't test the laptop thorougly because my gf has it in Germany. Does anybody know which of those disabled power systems affect on-screen display? Secondly, if I enable that one, does it make sleep problem come back?