Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Ctrl-Alt-Del
facemark
Posts: 17
Registered: ‎06-12-2011
Location: USA
0

R61 sound problem: audio crackles at high volume

Since installing Windows 7, audio coming from my thinkpad's speakers crackles when the volume is above level 35 or so. This is a problem because, well, a) volume shouldn't be crackling ever, and b) these speakers are inherently relatively quiet and therefore the volume pretty much always needs to be turned up high. At first I thought it was a codec problem with VLC, as the problem was first noticed while watching .avi movies. Then I noticed the same happening on internet streaming radio. And finally it happens with local mp3s.

 

I've looked through the support site and don't actually see Audio drivers for Windows 7. Only XP, 2000, and Vista.

 

Facts about my setup:

  • Default Device in my Sound control panel is "SoundMAX Integrated Digital HD Audio"
  • Driver Provider: Analog Devices
  • Driver Date: 5/18/2009
  • Driver Version: 6.10.1.7255

 

I searched the support site for that driver, found it here, and see that it's only supported by the Thinkpad X300. So now I don't know what to do.

 

Any suggestions? I'd like to get my speakers back!

Guru
ColonelONeill
Posts: 7,122
Registered: ‎12-26-2009
Location: Toronto
0

Re: R61 sound problem: audio crackles at high volume

Can you try this driver?
http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-73568
W520: i7-2720QM, Q2000M at 1080/670/1340, 21GB RAM, 500GB HDD, FHD screen
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Ctrl-Alt-Del
facemark
Posts: 17
Registered: ‎06-12-2011
Location: USA
0

Re: R61 sound problem: audio crackles at high volume

Installed that driver but there's still the same problem. Any type of audio crackles and skips when the volume is higher than around 60%. YouTube streaming, locally stored music, videos in VLC and DivX player, etc.

Guru
ColonelONeill
Posts: 7,122
Registered: ‎12-26-2009
Location: Toronto
0

Re: R61 sound problem: audio crackles at high volume

Hit Start > Sound > double-click the SoundMax entry > Enhancements > Check Disable all enhancements.

Does this help?
W520: i7-2720QM, Q2000M at 1080/670/1340, 21GB RAM, 500GB HDD, FHD screen
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Ctrl-Alt-Del
facemark
Posts: 17
Registered: ‎06-12-2011
Location: USA
0

Re: R61 sound problem: audio crackles at high volume

Nope, no different. Hrmmm
Guru
ColonelONeill
Posts: 7,122
Registered: ‎12-26-2009
Location: Toronto
0

Re: R61 sound problem: audio crackles at high volume

Weird. Maybe try reseating the speakers?
W520: i7-2720QM, Q2000M at 1080/670/1340, 21GB RAM, 500GB HDD, FHD screen
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Ctrl-Alt-Del
facemark
Posts: 17
Registered: ‎06-12-2011
Location: USA
0

Re: R61 sound problem: audio crackles at high volume

I'm sorry, could you explain? I don't know what is meant by reseat the speakers. I googled it but still I'm not sure. If it involves taking apart the laptop, well, I'm not afraid of doing that. Just want to make sure I understand what you mean. Thanks!
Guru
ColonelONeill
Posts: 7,122
Registered: ‎12-26-2009
Location: Toronto
0

Re: R61 sound problem: audio crackles at high volume

Not sure if it'd do anything though... Did it happen exactly after installing Windows 7?

Maybe try an Ubuntu boot environment before taking it apart?
W520: i7-2720QM, Q2000M at 1080/670/1340, 21GB RAM, 500GB HDD, FHD screen
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Ctrl-Alt-Del
facemark
Posts: 17
Registered: ‎06-12-2011
Location: USA
0

Re: R61 sound problem: audio crackles at high volume

Yep, exactly after installing Windows 7. No problems under XP.

I've never tried Ubuntu...
Guru
ColonelONeill
Posts: 7,122
Registered: ‎12-26-2009
Location: Toronto
0

Re: R61 sound problem: audio crackles at high volume

Does it now drive the speakers louder at the same volume level?
W520: i7-2720QM, Q2000M at 1080/670/1340, 21GB RAM, 500GB HDD, FHD screen
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase