Support in other languages: 
Reply
Serial Port
allancady
Posts: 21
Registered: ‎03-20-2008
Location: USA
0

Bluetooth vanished from SL500

SL-500 with Windows 7 Ultimate

 

I've used bluetooth for months, mostly with Nokia PC Suite to connect to an old cell phone. All of the sudden, all signs of bluetooth capability have vanished from the SL500. Nothing shows up in Devices and Printers, nothing in Device Manager, no bluetooth radio in the Fn-F5 menu, and it doesn't detect my phone.

 

Bluetooth is turned on on the phone. On the SL-500, it's enabled in the BIOS, and the hardware radio switch on the edge of the computer is turned on.

 

I tried uninstalling, then reinstalling the ThinkPad bluetooth drivers (7zbv19ww), but when I try to re-install, I get a popup with the message, "No Bluetooth device was detected. Please make sure that your Bluetooth device is plugged in properly in order to continue installation.", with a single button labeled, "Cancel Installation". Click that, and the installation aborts.

 

The only clue I can see in Device Manager is, under "Other devices", there are four items that show the yellow trouble icon:

Base System Device, with Location: PCI bus 13, device 0, function 3

Base System Device, with Location: PCI bus 13, device 0, function 2

Unknown device, with Location: Unknown

Unknown device, with Location: on Microsoft ACPI-Compliant Embedded Controller

 

All of the above devices indicate "The drivers for this device are not installed. (Code 28)"

 

Suggestions, anyone?  Thanks.

 

Allan

tanujhanda
Posts: 955
Topics: 3
Kudos: 80
Solutions: 65
Registered: ‎01-05-2010
Location: INDIA
0

Re: Bluetooth vanished from SL500

Hello allancady

 

Kindly install Card reader driver for Base system device

 

Install Power manager and Power management driver for unknown devices.

 

After this restart the system and press Fn+F5 key and enable Bluetooth device.

 

Hope your issue gets resolved after this

 

Best Regards,

Tanuj

 

 


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Serial Port
allancady
Posts: 21
Registered: ‎03-20-2008
Location: USA
0

Re: Bluetooth vanished from SL500

Thanks for the good suggestions. Installing those three drivers eliminated two of the four warnings in Device Manager; there are still two "unknown device".

 

Still no sign of Bluetooth functionality. And still, when I try to re-install the ThinkPad bluetooth support package, I get the error, "No Bluetooth device was detected".

 

 

tanujhanda
Posts: 955
Topics: 3
Kudos: 80
Solutions: 65
Registered: ‎01-05-2010
Location: INDIA
0

Re: Bluetooth vanished from SL500

Hello allancady,

 

Kindly update the BIOS and check if the Bluetooth detects.

 

BIOS update utility for Windows

 

BIOS Update Bootable CD

 

Install ThinkVantange System update and then download the updates and install

 

Best Regards,

Tanuj


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!