Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Punch Card
CBR954RR
Posts: 24
Registered: ‎07-05-2009
Location: USA
0

Ricoh Card Reader issues

I have a Thinkpad SL500 with latest 1.30 BIOS running a T9800 (2.93 GHz) CPU and 8GB Ram with Windows 7 Pro (64 bit version) and since day one have had issues with the Ricoh card reader.  I have installed the Ricoh card reader drivers from Lenovo for my machine which is version 3.46.02 and I can't seem to find any that are newer as these are from back on March 26, 2010.

 

Problem in a nutshell is - I use SD cards frequently and when I insert one for the first time, it works as it is supposed to, the icon shows up and I can access all content on the card.

 

Now is where the problem arises - when I eject the card and then try to insert another or even the same card, I get nothing and when I look in the Device Manager, I have a drive listed under Disk Drive section with a yellow symbol and when I check the properties this is what it says...

 

Windows cannot load the device driver for this hardware because a previous instance of the device driver is still in memory. (Code 38)

 

The only way to gain access to the reader again is to reboot the machine and of course, the process happens all over again after the first SD card that is read.

 

Has anyone else had this problem and found a solution?  If so, can you please post how you solved the problem?

 

Thanks to any and all that can shed some light on the problem.

 

- Dan

harishnailwal
Posts: 53
Topics: 0
Kudos: 1
Solutions: 2
Registered: ‎02-01-2012
Location: India
0

Re: Ricoh Card Reader issues

I would suggest you to kindly uninstall the card reader driver from the Device Manager then restart the notebook. Please refer the below mentioned web link to download the updated Card reader driver.

http://support.lenovo.com/en_US/downloads/detail.page?LegacyDocID=MIGR-73836

 

Install the card driver, after this please use the card and check if it works fine.

 

For further use, I suggest you to safely remove the hardware from the System tray and then remove the card from the card reader.


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Punch Card
CBR954RR
Posts: 24
Registered: ‎07-05-2009
Location: USA
0

Re: Ricoh Card Reader issues

harishnailwal,

 

Thanks for chiming in and giving me some suggestions on what to try.  I don't think it will help as I am already using the drivers that are at the link you provided.

 

As for ejecting the SD cards, I always go to the icon in the system tray and safely remove before actually ejecting the card so I don't have high hopes that this is the cure to my problem.

 

Nontheless, I will give it a try and post back the results.

 

Thanks again for your suggestions.

 

- Dan

Guru
ColonelONeill
Posts: 6,794
Registered: ‎12-26-2009
Location: Toronto
0

Re: Ricoh Card Reader issues

Try ejecting the card from the system tray first. Sometimes if I hot-eject a card, the system will refuse to see further cards until I disable/enable the card reader in Device Manager.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Punch Card
CBR954RR
Posts: 24
Registered: ‎07-05-2009
Location: USA
0

Re: Ricoh Card Reader issues

ColonelONeill, Thanks for your ideas. I always eject using the system tray before removing the card. As for disabling/re-enabling in device manager, that does not work for me. I still get the message in the device manager stating that the driver is still in use. The only way to get back to square one is to reboot. Thanks for your thoughts. – Dan
Guru
ColonelONeill
Posts: 6,794
Registered: ‎12-26-2009
Location: Toronto
0

Re: Ricoh Card Reader issues

You might want to try hunting for a newer, non-Lenovo driver based on the hardware ID.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Punch Card
CBR954RR
Posts: 24
Registered: ‎07-05-2009
Location: USA
0

Re: Ricoh Card Reader issues

ColonelONeill,

 

I tried your suggestion of searching for newer drivers based on the hardware ID in the past but have not come up with any drivers that are newer than the ones currently installed.  They are dated March 2010 by Lenovo but the actual date on the drivers is showing 9-3-2009 with a version number of 6.10.01.05 (6.10.1.5).

 

The following are the hardware IDs:

 

Under IDE ATA/ATAPI controllers there are the following:


Ricoh Memory Stick Controller


DRIVER: REDC Driver 6.10.01.05 Dated 9-3-2009 rimspx64.sys c 2001-2009
DRIVER: Sony Corporation 1.0.0.09120 snymsico.dll c 2001

PCI\VEN_1180&DEV_0592&SUBSYS_210C17AA&REV_12
PCI\VEN_1180&DEV_0592&SUBSYS_210C17AA
PCI\VEN_1180&DEV_0592&CC_088000
PCI\VEN_1180&DEV_0592&CC_0880

 

Ricoh SD/MMC Host Controller

 

DRIVER: REDC Driver 6.10.01.05 Dated 9-3-2009 rimmpx64.sys c 2001-2009

 

PCI\VEN_1180&DEV_0843&SUBSYS_210B17AA&REV_12
PCI\VEN_1180&DEV_0843&SUBSYS_210B17AA
PCI\VEN_1180&DEV_0843&CC_088000
PCI\VEN_1180&DEV_0843&CC_0880

 

Ricoh xD-Picture Card Controller

 

DRIVER: REDC Driver 6.10.01.05 Dated 9-3-2009 rixdpx64.sys c 2001-2009
DRIVER: Ricoh Company Ltd. 1.0.1.1 rixdicon.dll

 

PCI\VEN_1180&DEV_0852&SUBSYS_210D17AA&REV_12
PCI\VEN_1180&DEV_0852&SUBSYS_210D17AA
PCI\VEN_1180&DEV_0852&CC_088000
PCI\VEN_1180&DEV_0852&CC_0880

 

Under SD host adapters, the following is listed;

 

SDA Standard Compliant SD Host Controller

 

DRIVER: Microsoft Driver 6.1.7601.17514 dated 6/21/2006 sdbus.sys

 

PCI\VEN_1180&DEV_0822&SUBSYS_210A17AA&REV_22
PCI\VEN_1180&DEV_0822&SUBSYS_210A17AA
PCI\VEN_1180&DEV_0822&CC_080500
PCI\VEN_1180&DEV_0822&CC_0805

 

I find it somewhat interesting that the Ricoh Memory Stick Controller, Ricoh SD/MMC Host Controller, and Ricoh xD-Picture Card Controller listed under IDE ATA/ATAPI controllers all have Ricoh or REDC drivers and the SDA Standard Compliant SD Host Controller under SD host adapaters has a Microsoft driver and not a Ricoh or REDC.

 

Thanks again for throwing out suggestions.  Much appreciated.

 

- Dan 

Guru
ColonelONeill
Posts: 6,794
Registered: ‎12-26-2009
Location: Toronto
0

Re: Ricoh Card Reader issues

http://drivers.softpedia.com/progDownload/Asus-Notebooks-RICOH-R5C8xx-Card-Reader-Driver-35701-Downl...

This one says 3.57.01, which is newer, but for a different manufacturer. The driver should be the same though. Might work.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Punch Card
CBR954RR
Posts: 24
Registered: ‎07-05-2009
Location: USA
0

Re: Ricoh Card Reader issues

ColonelONeill,

 

Thanks for the link with the drivers.  I downloaded them and had a look at the individual files and they appear to be older versions of the files I have.  Their version is 6.0.1.13 and the ones I am currently using are 6.10.01.05.  They have date stamps of 2008 whereas the files I have are date stamped 2009, so I can only assume they are an older version than what I have.

 

I appreciate you taking the time to search for drivers.  Much appreciated.

 

Thanks.

 

- Dan

Guru
ColonelONeill
Posts: 6,794
Registered: ‎12-26-2009
Location: Toronto
0

Re: Ricoh Card Reader issues

What if you uninstall the driver out of Device Manager, checking "Delete software...", and keep doing so until Windows doesn't have any drivers to install for it, then pull the recommended driver off of Windows Update rather than the Lenovo site?
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase