Support in other languages: 
Reply
What's DOS?
henrucci
Posts: 2
Registered: ‎12-29-2010
Location: Venezuela
0

SL400 White Screen & Some Rails

Hi, i got this issue months ago with a Lenovo Thinkpad SL400 when i was changed one of the hinges (The left one) & with my rookie experience i was connected the little short flex that comes from the LCD to the inverter the other way around (upside down).

 

When i was turned on the laptop a little smell like burned circuit came out. The Flex of the LCD (The big-long one not the little that goes to the inverter) was burned 2 pins.

 

 I was bought now a brand new flex but the problem persist. Opinions? Should i replace the inverter? I wish to be secure before buy i knew one.

 

 I forgot to mention: The laptop boot well and the external video exit works fine, i'm using the notebook like this with a external monitor since i got this problem. Any help will be welcome.

 

Thxs

Bit Torrent
Vince69
Posts: 1,213
Registered: ‎12-24-2010
Location: Perth, Australia
0

Re: SL400 White Screen & Some Rails

Hello mate,

 

Could be the inverter or could the LCD who's burn. Whith your rookie experience my advice is finding a technician able to test all that and have a diagnostic about what part is dead.

__________________________________________________________________________________

Knowledge is of two kinds. We know a subject ourselves, or we know where we can find information on it.


ThinkPad T510 4313-CTO Windows 8 x64 - Intel Core i7-620M - NVIDIA NVS 3100M - 8GB RAM - 240GB SSD- Intel Centrino Ultimate-N 6300 - Gobi 2000.
ThinkPad Helix 3697-CTO Windows 8.1 x64 - Intel Core i7-3667U - Intel HD Graphics 4000 - 8GB RAM- 256GB SSD - Intel Centrino Advanced-N 6205 - Ericsson C5621gw