Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Blue Screen Again
Number_6
Posts: 1
Registered: ‎08-25-2011
Location: Canada
0

SL510 Blue Screen of Death in Win 7

Using a brand new Lenovo SL510 laptop running Win 7 Pro SP1 (Model 2847, System Type x64-based PC
Processor Intel(R) Core(TM)2 Duo CPU T6670  @ 2.20GHz, 2201 Mhz, 2 Core(s), 2 Logical Processor(s)
BIOS Version/Date LENOVO 6JET88WW (1.46 ), 04/01/2011, SMBIOS Version 2.5), I experienced serious problems with Blue Screens of Death involving the built-in Intel wireless card. 

 

I was attempting to connect through an ad hoc network to another, older Thinkpad T42 (running WinXP), whose dialup modem I need at the moment for Internet access (wireless access in my current location is flakier than a Crisco pie crust).  The SL510 can see the ad hoc network, and connects to it, but most of the time cannot access the Internet through the modem.  I'm confident that the modem on the T42 has been properly shared through ICS, since three cell phones and a MacBook are quite capable of reaching the Internet through it.  Only the SL510 fails to connect.  Most of the time.  I've managed a working connection twice, but whenever the SL510 goes into power saving mode, the connection to the ad hoc network drops and never returns.

 

I've tried both the Lenovo Access Connections utility and Windows Network and Sharing Centre to connect to the ad hoc network.  With Access Connections, I see the ad hoc network in the display shown under the "Connect to the Internet" tab, click its icon and press "Connect", then enter the network key (set up under WEP-64).  The Location field then shows the ad hoc network display with a green region progressing across the background.  Two windows then open (behind Access Connections...I have to dig them out): one titled "Set Network Location" asking me to choose Home, Work or Public network configurations, the other titled "Access Connections" asking "Would you like to keep this connection as one of your locations" and showing the ad hoc network name in the box labelled "Location Name:").  In each case I've selected "Home" as the network configuration (generating another window confirming "The network location is now Home") and "Save" for the "keep this connection". 

 

At any point from here, I will see the blue screen of death, but it's not immediate. 

 

If the BSoD doesn't hit early, I will have time to try to connect to the Internet.  First, though, I try to change the power configuration so the wireless card will not be turned off.  By switching to "Advanced" mode in Access Connections, I select the "Wireless Settings" tab and through the "Settings" button of the "4. Advanced Settings" field, select the "Maximum Performance" Power save mode.  When I click OK to exit the Edit Profile dialog box, a popup titled "Access Connections" appears complaining "DHCP IP configuration is not supported for ad hoc connection.  Use static IP configuration".  Access Connections even obliges me somewhat by selecting the "Additional Settings" tab and checking the "Override TCP/IP and DNS defaults" box, with the only actionable box being "Settings" for that choice.  I open those settings, and under the assumption that I'm supposed to provide my own IP address, I enter 198.168.0.2 with a Subnet mask of 255.255.255.0. 

 

That makes my original ad hoc network connection vanish from Access Connection's "Connect to the Internet" display, but it still has my ad hoc network location next to a "Connect" button, so I try that.   Once again I'm asked to select a location for my network, but this time the network name is suffixed with a "2".  In previous efforts I've found this continues with "3", "4", etc.  In some cases, I can click "Home" network all I want but Windows ignores me.  In other cases I get confirmation that I've selected a "Home" network.

 

However this works out, I try IE9 to see if I can reach the Internet.  In two cases this has worked (for hours...once it works it works fine), but most of the time this fails and I get the "Diagnose Connection Problems" screen.  When I ask for that diagnosis, Windows Network Diagnostics tells me the problem is I haven't configured my ad hoc network for automatic configuration and offers to fix that for me.  I select "Apply this Fix".  Network Diagnostics sometimes says it's fixed the problem, but usually finishes complaining it could only "Detect" manual connection to my ad hoc network and that there's a problem with my wireless adapter or access point. 

 

At this point I often get a frozen system or BSoD.  When I don't, I've tried repeating these steps, but nothing reliably gets me a connection.  A lockup or BSoD is all that ever awaits.

 

This is rather disconcerting considering that a MacBook and three cell phones can accomplish blindfolded what a brand new Lenovo ThinkPad equipped with Microsoft's latest and supposedly best OS crashes on, but "surprised" is not one of the adjectives I'd apply here.  I would apply "grateful" if this description registers with someone who has suggestions that might get me through this.

 

Thanks for your help.