Support in other languages: 
Reply
Blue Screen Again
pxvdg
Posts: 3
Registered: ‎12-27-2011
Location: Brussels
0
Accepted Solution

SL510 battery not charging

[ Edited ]

Hi

 

I've been looking all over the web and this forum for an answer but I found nothing.

 

I have two batteries and none of them is charging when plugged in. One is stuck at 12% and the other is at 0%  and the battery light  flickers orange. I went to Battery Maintenance and both batteries are fine.

 

I have my sl510 for 16 months and the second battery for 3 months now.

 

Any idea what the problem is?

 

SL510 28477LG

Serie: xxxxxxx

Bios: 6JET86WW (1.44)

 

All help is welcome!!

 

thanks.

 

Moderator Note; s/n edited for member's own protection

lead_org
Posts: 20,770
Topics: 128
Kudos: 1,236
Solutions: 1,327
Registered: ‎12-19-2008
Location: Australia, Melbourne
0

Re: SL510 battery not charging

are these battery discharging when you unplug the AC adapter?
Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
Blue Screen Again
pxvdg
Posts: 3
Registered: ‎12-27-2011
Location: Brussels
0

Re: SL510 battery not charging

Yes they are. 

 

I reinstalled the bios and it worked for a while but then it stopped charging again. I really have no idea of what the problem can be. 

 

 

Paper Tape
blablah
Posts: 4
Registered: ‎01-23-2012
Location: USA
0

Re: SL510 battery not charging

Paper Tape
Kona_Dee_Lux
Posts: 1
Registered: ‎01-29-2012
Location: College
0

Re: SL510 battery not charging

yea same with my battery. I got my laptop free from my high school for being top shop and the battery is at 19% charge with the battery indicator light flickering orange.  This started happening on Jan. 25, 2012.  Battery pack is cold after a 1.5 hr plug in, and the battery terminals if I had the terminals correct read 0V on my volt meter. The Power brick read 20V and its normal. I think the batter pack might be defective.

Blue Screen Again
pxvdg
Posts: 3
Registered: ‎12-27-2011
Location: Brussels
0

Re: SL510 battery not charging

Thank you so much for the link! It really helps.

 

The thing is, from time to time my battery stops charging again but that's not an issue. I just reinstall the Microsoft ACPI Compliant Control Method Battery, restart my computer, then uninstall is again and there, fixed :smileyhappy: 

 

These are the steps who will fix the problem. (source)

 

  1. Disconnect AC
  2. Shutdown
  3. Remove battery
  4. Connect AC
  5. Startup
  6. Under the Batteries category, right-click all of the Microsoft ACPI Compliant Control Method Battery listings, and select Uninstall (it’s ok if you only have 1).
  7. Shutdown
  8. Disconnect AC
  9. Insert battery
  10. Connect AC
  11. Startup

 

With love.

What's DOS?
cincimike
Posts: 1
Registered: ‎10-20-2012
Location: Cincinnati, OH
0

Re: SL510 battery not charging

This was a lifesaver - thank you so much! It worked exactly as advertised......

What's DOS?
NH26
Posts: 1
Registered: ‎04-10-2013
Location: Tasmania
0

Re: SL510 battery not charging

Hi, I have just encountered the same problem with my SL510. I wanted to try the steps you suggested but I can not find Step 6: Under the Batteries category, right-click all of the Microsoft ACPI Compliant Control Method Battery listings, and select Uninstall (it’s ok if you only have 1).

 

Where do I find the batteries catergory?

 

Thanks

Paper Tape
r37890
Posts: 3
Registered: ‎05-18-2010
Location: Dallas, TX
0

Re: SL510 battery not charging

It's in Device Manager. Under Win7, just type device in the search bar, then make the appropriate selection.

 

In WinXP you'll need to right click on the My Computer icon and select Manage. Device Manager is in the System Tools section of Computer Management.