Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Punch Card
YellowJersey
Posts: 21
Registered: ‎04-06-2012
Location: Canada
0
Accepted Solution

Brand new T520 gives me blank screen

So I just got my brand new T520 today. It booted up fine the first time, but after downloading and installing a bunch of Windows 7 updates, it rebooted and is now just giving me a blank screen. I can move the mouse around, but can't seem ot get to my desktop. Here's a photo I took of the screen.

 

 Help?

 

http://img.photobucket.com/albums/v515/CdnShockwave/Zombie.jpg 

Token Ring
Soduku
Posts: 130
Registered: ‎04-24-2012
Location: Birmingham, UK
0

Re: Brand new T520 gives me blank screen

Hi buddy,

 

I would try the F11 factory restore. I know it's a pain, but I'd rather do that than send my machine off and wait a long time for it to be fixed.

 

It seems like an update wasn't installed correctly. But maybe you can ask Lenovo for a replacement?

ThinkPad T420s (4174-HG6) i5-2540M 8GB RAM, 320GB HDD
ThinkPad T430s (2356-GDG) i5-3320M, 8GB RAM, 500GB HDD x 2
Fanfold Paper
supersalad
Posts: 19
Registered: ‎05-30-2012
Location: California
0

Re: Brand new T520 gives me blank screen

[ Edited ]

Reminds me not to install anything on my in-transit T520 for a few days until I can make sure that all hardware are working well. Sucks to be having problems on newly received units. Mine just came with stucked pixel and I had to return it back and wait for a replacement.

 

Good luck!