Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Fanfold Paper
Lyndon
Posts: 10
Registered: ‎09-21-2008
Location: Melbourne, Australia
0

LED Screen looks washed out on T500 w/ Windows 7

[ Edited ]

When I first bought my T500 with XP the LED backlit screen was washed out and too bright. No problem, I installed third party DNA video drivers which fixed the problem. Picture quality was better too. But with Windows seven I don't have the option (yet) of using third party drivers as there are none that I know of. The ATI / Lenovo video drivers are rubbish for the ATI Mobility Radeon 3650.

Has anyone had the same experience? Does anyone have a fix for this?

 

Guru
ColonelONeill
Posts: 6,700
Registered: ‎12-26-2009
Location: Toronto
0

Re: LED Screen looks washed out on T500 w/ Windows 7

Is it only washed out on battery power and on the integrated graphics?
Does the Windows 7 color calibration wizard not produce satisfactory results?
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Fanfold Paper
Lyndon
Posts: 10
Registered: ‎09-21-2008
Location: Melbourne, Australia
0

Re: LED Screen looks washed out on T500 w/ Windows 7

I only use the discrete graphics and rarely ever use battery power.

The Windows 7 color calibration wizard doesn't really help much.

 

 

--------------------------------------------------

P.S. I added to your research survey

Guru
ColonelONeill
Posts: 6,700
Registered: ‎12-26-2009
Location: Toronto
0

Re: LED Screen looks washed out on T500 w/ Windows 7

I'm not sure... The T400's LED WXGA+ screen is fairly good in day to day usage, and it becomes very good for regular non-photo usage after calibrating.

Could you take a picture? It's possible that the screen itself has issues.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Posts: 1,502
Topics: 38
Kudos: 117
Solutions: 49
Registered: ‎04-20-2010
Location: Jeffersonville, Indiana
0

Re: LED Screen looks washed out on T500 w/ Windows 7

If you set it to only use the Dedicated GPU in the bios then you can install the latest Win7 Drivers from ATI. I did.
IT Specialist and Consultant
Lenovo Tablet Evangelist
Current Machines: IdeaCentre A300, ThinkPad Tablet, ThinkPad L410, and IdeaPad U410 Touch

Deutsche Deutsche Community   Español Comunidad en Español

Lenovo - the latest in DOtabs, DOpads, DOcentre's, DOstations and DOservers!