Support in other languages: 
Reply
Guru
ColonelONeill
Posts: 6,529
Registered: ‎12-26-2009
Location: Toronto
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7 - FIXED AT LAST?

[ Edited ]

Run the driver setup so it extracts it's contents to C:\DRIVERS\...

1. Open Device Manager, right-click the Intel graphics card, Update Driver Software.
2. Choose "Browse my computer ...".
3. Choose "Let me pick ...".
4. Click "Have Disk".
5. Point it to:
32-bit: "C:\DRIVERS\WIN\VIDEO\Packages\Drivers\Display\W7_INF"
64-bit: "C:\DRIVERS\WIN\VIDEO\Packages\Drivers\Display\W76A_INF"
6. Select the sole entry in the list and hit Next.

7. Continue from there.

 

Might work, might not.

W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Ctrl-Alt-Del
Edbert
Posts: 67
Registered: ‎03-12-2009
Location: Ecuador
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7 - FIXED AT LAST?

Tried it, programs still crash. Thanks for the suggestion.

Punch Card
betalemer
Posts: 12
Registered: ‎10-23-2010
Location: Toronto
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7 - FIXED AT LAST?

[ Edited ]
I experience problem on Firefox 4 Beta 7, IE 9, and Live Messenger 2012 when Intel driver is being used on Win 7 64bit. No problem on ATI. Fortunately, my outlook 2010, chrome 9 and firefox 3.6 works fine. Wait and see whether anyone experience the same problem and whether there is workaround.
Ctrl-Alt-Del
Edbert
Posts: 67
Registered: ‎03-12-2009
Location: Ecuador
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7 - FIXED AT LAST?

[ Edited ]

I experience the same problems as you do on the same programs, seems something is wrong with the Intel driver on Windows 7 64-bit. It seems as if people with the 32-bit version have no problems at all.

HDMI
firaX
Posts: 138
Registered: ‎12-18-2008
Location: Munich, Germany
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7 - FIXED AT LAST?

The CLI Error that occurs when CCC is started with the new driver occurs even when you do a fresh Windows 7 64bit install. So it is clearly a driver issue not an upgrade issue. Im back to the 2009 driver for now...

Thinkpad T400 (Windows 7 Ultimate x64)
Guru
ColonelONeill
Posts: 6,529
Registered: ‎12-26-2009
Location: Toronto
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7 - FIXED AT LAST?

Yeah it looks like a 64-bit only issue; I'm running the new version fine on 32-bit.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Ctrl-Alt-Del
Edbert
Posts: 67
Registered: ‎03-12-2009
Location: Ecuador
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7 - FIXED AT LAST?

Hope Lenovo notices the issue and does something about it!

Paper Tape
blaznonion
Posts: 6
Registered: ‎09-03-2010
Location: Morrisville, NY
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7 - FIXED AT LAST?

[ Edited ]

This driver works well on my T400 Win7 x64.  I pulled the old 10.8's out that I force installed earlier in the month.  I didn't encounter any issues during the installation and I can run 3D applications using the Intel chipset just fine.  I did however get a decrease in my Windows experience index.  My graphical index decreased from 4.8 to 4.7. 

 

Retired Employee
JameZ
Posts: 3,110
Registered: ‎07-11-2010
Location: Malaysia
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7 - FIXED AT LAST?

@All,

 

Those who are having issues despite upgrading to the latest GPU driver please revert the following so we are able to have some stats on the new driver results.

 

Model:

OS:

Lenovo preload OS?

3rd party CCC (non-Lenovo) ?

Settings in BIOS? (Discrete only / intergrated only / both)

Power Manager version

Power Management version

RAM installed (Lenovo preload tested?)

 

//JameZ

Check out the Community Knowledge Base for hints and tips.


Did someone help you today? Press the star on the left to thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!




W520 | 4176-38U | i7 - 2720QM | Quardo 1000M | 8GB RAM | 60GB OCZ Agility 3

Punch Card
betalemer
Posts: 12
Registered: ‎10-23-2010
Location: Toronto
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7 - FIXED AT LAST?

Here are my machie setup

Model :T500 with P9900

Product : 2081CTO (according to ThinkVantage Toolbox)

OS : Win 7 x64

Lenovo preload OS?  Yes

3rd party CCC (non-Lenovo)?  Has installed before but I have uninstall it already

Settings in BIOS?  both

Power Manager Version: 3.30

BIOS : 3.15

RAM installed : 8GB

Programs that has problem using Intel driver - Firefox 4 beta 7, live messenger 2012, and IE 9 Preview 7.