Support in other languages: 
Reply
Paper Tape
luckygoodheart
Posts: 3
Registered: ‎01-11-2010
Location: Canada
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

The Intel graphics driver causes stuttering when playing Recorded TV from Windows Media Center. There is definitely something wrong with hardware acceleration on Intel. Switching to ATI - the problem disappears.

 

One problem solved, another introduced. Seems to be the way these days.

 

 

Retired Employee
JameZ
Posts: 3,110
Registered: ‎07-11-2010
Location: Malaysia

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

@All,

Appreciate everyone's feedback on this. Have cascaded your findings to engineering.

//JameZ

Check out the Community Knowledge Base for hints and tips.


Did someone help you today? Press the star on the left to thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!




W520 | 4176-38U | i7 - 2720QM | Quardo 1000M | 8GB RAM | 60GB OCZ Agility 3

Ctrl-Alt-Del
c1p0
Posts: 14
Registered: ‎10-22-2009
Location: Bucharest, Romania
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

I am currently having an issue with switchable graphics. It appears that after installing the latest drivers: 8.752.4-101022a-
107489C
 , when on the dedicated graphics card (ATI), it doesn't detect my external monitor after coming back from sleep mode. This is happening both when my T500 is docked or when I just try to connect the external monitor directly to its VGA port. 

 

It would appear that the issue is fixed by switching to the Intel graphics card and then back to ATI. After doing so, the external monitor is detected and it works until the next time you put it to sleep and wake it up.

 

Does anybody else have the same problem? Anybody know how to fix it?

 

BTW, I have a T500 with T9600, Win 7 64 bit Professional.

 

Thanks!

What's DOS?
alex-kir
Posts: 1
Registered: ‎11-23-2010
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

c1p0 I have the same config and the same issue too!

Ctrl-Alt-Del
c1p0
Posts: 14
Registered: ‎10-22-2009
Location: Bucharest, Romania
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

I'm sure the new drivers came with the issue. Used to work fine with the previous version.

Guru
ColonelONeill
Posts: 6,556
Registered: ‎12-26-2009
Location: Toronto
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

Can confirm with 32-bit Windows 7.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Guru
ColonelONeill
Posts: 6,556
Registered: ‎12-26-2009
Location: Toronto
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

I am now also afflicted with the GPU-accelerated browsers failing on the Intel card. The only potential event that my have caused this was that I tested the "sleep with external monitor on ATI" bug.

However, if you load said GPU-accelerated browser while on discrete and switch to integrated, the browser seems to remain functional.

Affects both Minefield and IE9.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Fanfold Paper
madcrow
Posts: 1
Registered: ‎12-06-2010
Location: Hungary
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

Hi Everyone,

 

I have noticed two things that may be worth mentioning.

1.:

SMplayer has been misbehaving since I installed the new driver (8.752.4-101022a-107489C-Lenovo).

When I try to switch between fullscreen and windowed mode, It usually crashes when using the GL video output driver no matter which graphics controller is active.

It was working fine with the old driver from Lenovo (8.641.1.1-090824a-089811C) .

2.:

In Power Manager my display brightness is set to 50% in battery-powered mode and to 100% in AC mode.

When I enter battery mode, the brightness always decreases as it should. However whenever I return from battery mode to AC the brightness "forgets" to change back to maximum. If I enter Power Manager in this state, I find the AC brightness slider set to the middle position, so I have to readjust it every time :smileyfrustrated:

This issue existed both before and after the installation of the new driver, regardless of the graphics adapter in use.

 

Has anyone experienced these problems?

 

 

T500 2082-52G

BIOS: 3.15

 

WIN7 Pro x64

Switchable graphics driver: 8.752.4-101022a-107489C-Lenovo

Power Management driver: 1.60

Power Manager: 3.30

 

 

 

Guru
ColonelONeill
Posts: 6,556
Registered: ‎12-26-2009
Location: Toronto
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

I haven't been having issues with video overlay output using VLC, MPC, WMP, or WMC with the Intel card.

However issue 2 sounds like a Power Manager issue rather than a switchable driver issue.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Mark_Lenovo
Posts: 7,846
Topics: 410
Kudos: 1,309
Solutions: 283
Registered: ‎11-19-2007
Location: RTP, North Carolina
0

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

[ Edited ]

All,

 

I moved all the discussions about the new symptoms here from the old thread.   Please continue to work with Jamez here, so that we can get engineering working on the new symptoms.

 

We should note the different symptoms and ensure we capture the cosensus opinion of the comment elements - hardware accelerated browsers affected, Outlook 2007, etc.   It will also help to focus on the more mainstream applications - we will get more attention and focus in addressing an issue that will be understood to affect a broad number of customers and businesses rather than a few niche games or unique applications.  

 

Thanks for your help - sorry if I jumbled the order of the comments during the move.  It's a challenge because some use linear view and some use threaded view when browsing and responding in the forum.

 

Best regards,

 

Mark

____________________________________________

ThinkPads: S30, T43, X60t, X1, W700ds, IdeaPad Y710, IdeaCentre: A300, IdeaPad K1
Mark Hopkins
Program Manager, Lenovo Social Media (Services)
www.twitter.com/lenovoforums
www.facebook.com/lenovo

English English Community      Deutsche Deutsche Community      Español Comunidad en Español