Support in other languages: 
Reply
Retired Employee
JameZ
Posts: 3,110
Registered: ‎07-11-2010
Location: Malaysia
0

Re: R400/T400/T500/W500: Switchable graphics - NEW issues with 8.752.4 video drivers - crashes on In

@lenardg,

Unfortunately I do not have access to the SP1 as I am not in the development team :smileysad:

//JameZ

Check out the Community Knowledge Base for hints and tips.


Did someone help you today? Press the star on the left to thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!




W520 | 4176-38U | i7 - 2720QM | Quardo 1000M | 8GB RAM | 60GB OCZ Agility 3

Ctrl-Alt-Del
Edbert
Posts: 67
Registered: ‎03-12-2009
Location: Ecuador
0

Re: R400/T400/T500/W500: Switchable graphics - NEW issues with 8.752.4 video drivers - crashes on In

@JameZ,

 

When Win 7 SP1/ IE9 are released, will we get any notification if it is safe to install with the 8.752.4 drivers?

Punch Card
LoneWolf
Posts: 38
Registered: ‎03-18-2008
Location: The Mitten State, USA
0

Re: R400/T400/T500/W500: Switchable graphics - NEW issues with 8.752.4 video drivers - crashes on In

[ Edited ]

First of all JameZ, as someone who has watched this thread closely (but mainly posts on other ThinkPad forums), I wanted to thank you for your time and effort in helping all of us.  I know it isn't an easy thing, being a go-between for us, engineering, and others.

 

That said, other posts here have had expert points.  The failure of Lenovo engineering is one of the several reasons that when I replace my T400 someday, I'll be likely to look at Dell's Latitude line.  The current switchable graphics driver for T400/T500 users is only the second one since the release of Windows 7.  If the power problem didn't come to light, I doubt that we would have gotten a second driver, meaning no accelerated Flash support, and very little in the way of improvements for people who originally bought a ThinkPad because it was considered the best of breed, with excellent engineering and support.  Now we have a new issue, and once again, I don't see Lenovo's engineering department stepping up to the plate; rather, I see end-users having to point out (rather intelligently, I might add) good reasons why we need better support than we're being given.

 

As an IT administrator myself, I understand a lot about not implementing something "because it's cool", or for logistical reasons.  However, Lenovo's failure to keep up with graphics drivers, from both a features and a bug-fix perspective has been extremely frustrating for the entire ThinkPad T400-T500 community.  It's things like these that only let me recommend Lenovo to my techie-friends; I recommend other solutions to novice users who need better vendor support, because my reputation is at stake, and I'm not willing to rest that reputation on Lenovo as a company.  This issue (among others, though those are not your responsibility), at this very moment, is losing Lenovo sales.  I was part of a decision-making process to buy thirty laptops late last year for my organization.  Lenovo was on the list, but the sale didn't go there.

 

I am not blaming you --you have done an excellent job in working with us.  However, I'm putting this message into print because I'm hoping that it is something you can forward on to your business and your engineering divisions.  If someone doesn't get the support they expect from buying a reputed product like a ThinkPad, they will go somewhere else.  I'd like to see you get the support you need  from wherever needs be in the company so that your Engineering department can recognize the scope of this issue.

 

There's an already documented Microsoft KB article others have pointed out.  IE9 hit release-candidate stage at the end of this week, meaning full release is not far behind; FireFox 4 is close to release candidate as well.  Windows 7 Service Pack 1 hits Technet and MSDN subscribers on the 16th, forcing the issue by implementing a fix that was previously optional that will expose the issue.  I am hopeful that someone can respond in a timely fashion to deliver the fixes we need, but considering the time-frame of ThinkPad video driver releases --I really don't know.

TP T420, i5-2520M, 8GB, 80GB mSATA+500GB HDD
HD+ with webcam and Optimus, Intel 6300 wifi, BT 3.0
Windows 7 x64 Enterprise SP1

Previous owner, T61, T400
What's DOS?
plexman
Posts: 1
Registered: ‎02-13-2011
Location: UK
0

Re: R400/T400/T500/W500: Switchable graphics - NEW issues with 8.752.4 video drivers - crashes on In

Just to add I'm also having th same problem but with windows live mail 2011 which is not beta software.

Ctrl-Alt-Del
Edbert
Posts: 67
Registered: ‎03-12-2009
Location: Ecuador
0

Re: R400/T400/T500/W500: Switchable graphics - NEW issues with 8.752.4 video drivers - crashes on In

Bumping the thread up.

Guru
ColonelONeill
Posts: 6,293
Registered: ‎12-26-2009
Location: Toronto
0

Re: R400/T400/T500/W500: Switchable graphics - NEW issues with 8.752.4 video drivers - crashes on In

[ Edited ]

I tried dropping in the latest IGP drivers from Intel by doing a direct file replace, to no avail; Windows would think the new igdumd32.dll wasn't WDDM compatible.

 

Firefox 4 nightly also seems disable its Direct2D when the offending Windows update is installed.

W520: i7-2720QM, Q2000M at 1099/688/1377, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Blue Screen Again
Katastropoulos
Posts: 5
Registered: ‎05-27-2010
Location: Germany
0

Re: R400/T400/T500/W500: Switchable graphics - NEW issues with 8.752.4 video drivers - crashes on In

Same problem, here.

 

Windows Live Mail 2011 crashes when I am running on Intel drivers.

With ATI it runs fine. This is bad because I cannot check my mails
when I am outside my office because the I run the Intel card to save
energy when I am on battery mode!

 

Please fix the Intel drivers. Windows Live Mail 2011  is not a beta product!

Retired Employee
JameZ
Posts: 3,110
Registered: ‎07-11-2010
Location: Malaysia
0

Re: R400/T400/T500/W500: Switchable graphics - NEW issues with 8.752.4 video drivers - crashes on In

[ Edited ]

 

 

Initial issue was caused by installing IE9 causing crash. Currently SP1 is out for TechNet and MSDN members thus causing applications to crash when on Intel GPU. Therefore this thread has been moved to a new thread. Do refer to the new discussion.

 

Discussion Moved to R400/T400/T500/W500 - Issue with Intel GPU with SP1