Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Fanfold Paper
FriedDylan
Posts: 7
Registered: ‎05-21-2009
Location: USA
0

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

[ Edited ]

Lo and behold these drivers appear to have restored switchable graphics on my T400.

 

At first I did the dummy upgrade which entailed copying new drivers over bad ones.. No love.

 

Then I woke up a half inch smarter this morning and used the packaged to uninstall my previous drivers.. and rebooted- the system still had some ATI remnants in it so I uninstalled again and rebooted.  I then had a 1024x768 standard VGA view (a sign that MS drivers had taken over)..  I installed the fresh package from the previous link and although I was not at 1440x900 and system Manager saw the card correctly I rebooted anyway and changed my settings in BIOS back to Switchable and OS detection ON.

 

The resulting reboot with those settings has been fruitful.  I can now switch between graphic cards as expected.

 

The driver appears as:  ATI Technologies Inc  8/24/2009  v8.641.1.0  Microsoft Windows Hardware Compatibility Publisher

 

I see both the Intel graphics and the ATI and my power mamanger allows me to switch back and forth.  I dont dock my laptop so I can't test its functionality or confirm those glitches.

 

After being locked in discreet mode for so long I forgot why I wanted to be able to switch back and forth anyway..

 

Oh yeah, battery life.. I knew there was a reason for having that huge thing sticking out the back of my beautiful laptop.  :smileywink:

 

I hope everyone else has positive experiences.

 

I'll try to load up a 3D game today and test for crashing.. Fallout 3 should bring it to its knees I think.  :smileywink:


__
Thinkpad T400 IC2D T9400 2.53Ghz (2765-T2U)4Gb RAM 320Gb Hard Drive
Discreet Graphics - 1400x900
Windows 7 Enterprise 32Bit
Paper Tape
lego89
Posts: 2
Registered: ‎10-02-2009
Location: Switzerland
0

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

Hi all

 

I'm from Switzerland and new to this forum.

I bought a brand new W500 and it arrived yesterday. (it is my first IBM/Lenovo I've ever had)

I downgraded to Windows XP right from the start. At first I was very happy about the notebook in general. But ever since I connect it to an external 24" Samsung monitor (1920x1200) with VGA, I have the exact same issue as mentioned in this here:

After 20min-2h out of nowhere the notebook freezes and after a few seconds the BSOD appears.

 

Since the start of this topic is quite old, I wanted to ask you if you guys or Lenovo themselves came up with a stable solution in the meantime?

I'm sorry I'm asking this, but I tried to read through most of the topic but couldn't really find anything usefull and it's difficult for me to read carefully through everything since my English isn't perfect and it takes so long. Also everything I found was only for Vista, but I'm using XP and have the same problem.

So could anyone tell me the post # or so, where I can find a solution to my problem?

 

I already contacted Lenovo several times, downloaded the new video drivers from the site, but didn't help. After that I set up the whole XP again, but didn't help either.

 

I'm so angry & sad right now, because I was really looking forward to this notebook. One of the most important things for me is that I can connect 2 external 24" monitors to it. I got it from a special student's offer that we have in Switzerland twice a year. I could have also bought a HP 8530w instead, but chose the W500.

Now this "special offer window" is closed again, so I can't just sell the W500 and buy the HP instead :-(

 

Thanks for all your help.

 

 

 

 

 

Punch Card
bri0831
Posts: 71
Registered: ‎07-31-2008
Location: USA - MA
0

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

Here's my latest update...

 

Pretty much scrapped Vista (almost for good!)

 

Got Win 7 Pro volume license. Here are the steps to happiness (kinda like the little girl on the new Win 7 commercials on TV...)     :smileyvery-happy:

 

1) Take your T400 or 500/W500, etc

2) Backup all your data and install Vista x64 clean install (not an upgrade) over what's on your drive now

3) Run Setup.exe on the Win 7 x64 dvd after Vista boots up (or x32 if that's what you have)

4) Let the Win 7 upgrade do its thing

5) Reboot, and turn off switchable & os detection

6) Boot into 7 and let Windows Update get your ATI driver. Don't try the ones on the Lenovo Win 7 Beta Drivers page (they buffed my screen settings, kinda)

7) Once your Windows Updates are done, perfection emerges with no screen flashes, no BSOD, no video errors, no problems when switching between PC's

 

That's It! It looks like a lot of work but you can bang out all of these steps in like an hour. Like someone else mentioned, I am pretty much going to forget about Intel & the switchable video. If it's stable, then I get work done!!

 

Let me know if anyone else tries!!

 

-Brian G.

T430s (current), T420s, ThinkStation S20
Paper Tape
lego89
Posts: 2
Registered: ‎10-02-2009
Location: Switzerland
0

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

[ Edited ]

Thanks for your quick reply.

Your suggestion about the Windows 7 sounds very very interesting. Since I just bought the W500 I can get Windows 7 pretty much for free. But the release date is Oct 22nd. Are you currently running the beta version?

 

The main problem about your suggestion is that unfortunatelly I'm not a geek and don't know much about PC's. I actually pretty much only use firefox, word and excel, lol.

Therefor I would need a little help on almost every step:

 

2) How can I run a "clean install"

3) Where do I find setup.exe?

5) Where can I turn off switchable & os detection and what is that?

 

Thanks a lot for your help and sry for these noob-questions :-P

 

Another thing I would have to know:

What's the difference between Windows 7 32bit and 64bit version? And which one would you recommend for someone like me who uses the computer A LOT but isn't an expert?

 

Punch Card
shinigami7th
Posts: 15
Registered: ‎09-02-2008
Location: Singapore
0

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

@lego89:

 

Clean Install means reformatting the OS partition and reinstalling the windows from scratch... Whereas the other method is called in-place upgrade, which simply installs the new OS (Win7) over the old one (Vista). Clean install is always preferred since they are, as the name said, cleaner... No leftover junk from the previous OS. You can find the guide for it by simply googling it (there are some which were written specifically for thinkpads)

 

Setup.exe meant here is simply the one you can find when you download the driver... It is inside the .zip file.

 

Turning off switchable and its detection is in the BIOS configuration....

 

32-bit vs 64-bit... There shouldn't be much performance differences here. 64-bit allows the use of more than 4GB of RAM, so unless you have 4GB of RAM or more, stick to 32-bit as most applications integrate better to the system in 32-bit (I've had some minor incompatibilities in 64-bit). 64-bit OS will only show its 'teeth' when you run a 64-bit application (like my Photoshop CS4.... it is running like lightning under 64-bit).

 

Read up a bit before asking... Some of these questions can be simply answered by a 5-min googling....

 

In case you wanna know: I'm running my T400 on a Vista Ultimate 64-bit with switchable graphics on.

Punch Card
Andy_7575
Posts: 49
Registered: ‎02-03-2009
Location: California, USA
0

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

To add to that, if this is a computer you're using for school, make sure that all of the specialized software your school requires works for 64 bit.  Where I am, we still don't have a 64 bit compatible VPN client, and the computer security checker that they require us to run before okaying our computers for network use isn't compatible with 64 bit Windows.

Paper Tape
mikee99
Posts: 2
Registered: ‎08-20-2009
Location: United States
0

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

I just pre-ordered Windows 7 x64, and I'm wondering if there has been any progress on the Windows 7 switchable graphics driver. 

 

Like everyone else, when I ran the RC, I was unable to utilize the switchable graphics functionality.  Please tell me this will be available for launch.

Fanfold Paper
FriedDylan
Posts: 7
Registered: ‎05-21-2009
Location: USA
0

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

I don't know about anything specifically blessed by Lenovo but yesterday Windows 7 Update found an updated driver that works with my Windows 7 x64 Enterprise.  I can switch back and forth but I don't have a dock so I can't test that finctionality.

 

The driver version shows 8.641.1.1000


__
Thinkpad T400 IC2D T9400 2.53Ghz (2765-T2U)4Gb RAM 320Gb Hard Drive
Discreet Graphics - 1400x900
Windows 7 Enterprise 32Bit
Punch Card
Andy_7575
Posts: 49
Registered: ‎02-03-2009
Location: California, USA
0

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

By my count, the feature has never been fully functional, so I'm going to guess not likely.

Punch Card
bri0831
Posts: 71
Registered: ‎07-31-2008
Location: USA - MA
0

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

Hello again all,

 

I'm fully convinced that switchable was really only designed for running on battery only while undocked. If this is the case, then I guess my OEM Vista Biz image eventually lived up to its expectations. (Although it pains me to even say that)

 

I've been running 7 for a couple weeks (we ordered licenses @ my job) and I can at least leave it docked with the Windows drivers (and when I change on the KVM I get no screen flashes, which is nice) it works great.

 

I am recommending that you just go with the Windows drivers for ATI and forget about the rest!

 

Keep us all posted on your findings now that 7 is readily available.

T430s (current), T420s, ThinkStation S20