Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Ctrl-Alt-Del
afty
Posts: 15
Registered: ‎01-02-2009
Location: Somerville, MA
0
Accepted Solution

T400 and Advanced Mini Dock - doesn't detect DVI monitor

[ Edited ]

I have a T400 with integrated graphics and Windows 7 Professional 64-bit, and I recently bought an Advanced Mini Dock for it.  I have a Dell 1800FP monitor connected to the dock via the DVI output.  When I dock the T400, the system does not detect the external monitor.  If I go to Screen Resolution and click Detect, it does not show up.  The weird part is that if I reboot while in the dock, when the system comes back up it *does* detect and use the external monitor.

 

Any ideas what is going on?  The other devices attached through the dock (USB devices, Ethernet cable) all work fine.

Token Ring
mike5065
Posts: 124
Registered: ‎02-24-2010
Location: Toronto
0

Re: T400 and Advanced Mini Dock - doesn't detect DVI monitor

What happens when you are docked, and then power-off and power-on the monitor? Does it get detected?

 

Ctrl-Alt-Del
afty
Posts: 15
Registered: ‎01-02-2009
Location: Somerville, MA
0

Re: T400 and Advanced Mini Dock - doesn't detect DVI monitor

[ Edited ]

 


mike5065 wrote:

What happens when you are docked, and then power-off and power-on the monitor? Does it get detected?

 


 

No, it still is not detected.  This is very strange.  I swear the first time I plugged my laptop into the dock, it did detect the external DVI monitor.  But now it will only detect it if I boot while docked.

 

Edit: I just discovered that if I put the machine to sleep while docked, then wake it up, it detects the external monitor.

 

lead_org
Posts: 20,899
Topics: 128
Kudos: 1,252
Solutions: 1,342
Registered: ‎12-19-2008
Location: Australia, Melbourne
0

Re: T400 and Advanced Mini Dock - doesn't detect DVI monitor

go into your bios menu, and switch the display output to dvi+internal. 

Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
Ctrl-Alt-Del
afty
Posts: 15
Registered: ‎01-02-2009
Location: Somerville, MA
0

Re: T400 and Advanced Mini Dock - doesn't detect DVI monitor


lead_org wrote:

go into your bios menu, and switch the display output to dvi+internal.


No change.  Still seeing the above behavior.
Ctrl-Alt-Del
afty
Posts: 15
Registered: ‎01-02-2009
Location: Somerville, MA
0

Re: T400 and Advanced Mini Dock - doesn't detect DVI monitor

I think I've solved this problem.  I uninstalled my video driver and installed the latest version from the Lenovo website (which was newer than the one found by Lenovo System Update).  Now my system properly detects the external monitor when I attach it to the dock.

Community SuperMod
bananaman
Posts: 3,651
Registered: ‎04-25-2008
Location: San Francisco
0

Re: T400 and Advanced Mini Dock - doesn't detect DVI monitor

Hi afty!

 

Thank you for coming back and noting this - it will help other members!

 

If you're happy with it, please click on "Accept as Solution" in your post describing the fix, so that it's easier to find!

I don't work for Lenovo. I'm a crazy volunteer!
sjb
Punch Card
sjb
Posts: 6
Registered: ‎07-31-2009
Location: Europe
0

Re: T400 and Advanced Mini Dock - doesn't detect DVI monitor

[ Edited ]

Hi,

hi lead_org,

 

So for this advanced mini-dock:

 

advanced mini dock EU

 

is it POSITIVE that the DVI output works for ThinkPad T400 with only integrated graphics? And not with switchable graphics?

Were you guys referring to a different dock? And that a DVI/HDMI adapter cable works for connection to a 1080 wide HDTV LCD?

 

Is this the solution () to handle the T400 design handicap of lacking a digital video connector in the presence of digital outputs on the graphic card? And not another usb-to-dvi trick?

 

Thanks.

 

PS:

 

T410 seems better, it:

- has audio jacks on the right; bun one can turn one's T400 90 degrees on a side, and have the jacks to the left.

- has the yellow power USB port, although T400 BIOS can enable USB ports to provide power when in standby.

 

I wonder whether T410 has the mechanically removable CD/DVD optical drive too.

 

there is no but files... no error just File Not Found
Paper Tape
PeteLSneak
Posts: 2
Registered: ‎01-31-2011
Location: London, UK
0

Re: T400 and Advanced Mini Dock - doesn't detect DVI monitor

I have the exact same issue with a T410 and advanced mini dock series 3.  

 

If I boot with the bios option for DVI as primary then DVI works until windows loads the display driver, then DVI is not detected, only VGA is available as well as the laptop screen.  I have tried drivers from the lenovo site, the system update utility and even uninstalling all and having windows update install (I think these are all the same version though).  

 

Also when connected by VGA the display is not as clear as I have seen on my previous T61 on a dock.  I know the DVI cable is ok as it works from BIOS mode, and also worked on the T61 dock with the same monitor also.

 

is anyone from Lenovo able to tell me what driver version I should be using? is this a known issue? 

 

I have a T410 2518-F5U and I'm using mini dock type 4337,

Broadband 3G
JDay
Posts: 999
Registered: ‎01-06-2011
Location: Sacramento, CA
0

Re: T400 and Advanced Mini Dock - doesn't detect DVI monitor

Try closing the laptop.