Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Serial Port
robodelfy
Posts: 107
Registered: ‎09-07-2010
Location: UK
0

Re: T410 Extremely Annoying Audio Issues

Hi

 

I have just got my thinkpad t510 and it all seems very nice apart from this audio issue.  I had read every piece of info i could find and didnt find anything too conclusive before i bought it.  I knew that Rain make audio optimised laptops from these called Livebooks so I assumed I could defintaly get it working fine.  I have been running DPC latency checker and getting spikes all over the place.  The only way i get really good DPC latency, all very low green is to uninstall the Nvidia drivers from device manager.  But as someone else said this only gives me a resolution of 1280 x 800, which isnt enough!  I am running Windows 7 32 bit. 

 

I dont have any settings for powermizer in my nvidia control panel and I read elsewhere that they have not written it into the newest drivers due to problems! 

 

So basically, we need drivers that dont create DPC spikes, there are enough people asking for it, so please Lenovo, and nvidia, can you sort this out!  It shouldnt be a problem with such an expensive piece of equipment. 

 

Does anyone have a work around in the meanwhile, I will have two system partitions, one for general use and one for Pro audio use, so on the audio partition i dont need good 3d graphics, so some generic driver could be fine if it stops the spikes.  I will love you forever if you can help with this problem

 

Thankyou :smileyhappy:

Retired Employee
JameZ
Posts: 3,110
Registered: ‎07-11-2010
Location: Malaysia
0

Re: T410 Extremely Annoying Audio Issues

Hi All,

Is everyone having the same issue? (sound is like switching from stereo to mono?)

If everyone could post back the info which I need in order to raise a case for engineering on my first post in the 1st page of this thread then we are able to cascade this to them for their assistance.

//JameZ

Check out the Community Knowledge Base for hints and tips.


Did someone help you today? Press the star on the left to thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!




W520 | 4176-38U | i7 - 2720QM | Quardo 1000M | 8GB RAM | 60GB OCZ Agility 3

Serial Port
robodelfy
Posts: 107
Registered: ‎09-07-2010
Location: UK
0

Re: T410 Extremely Annoying Audio Issues

Hi James

 

Most people are not having an issue with it switching between mono and stereo.  The problem, which has been talkd about in many forums now, and people have begged for help with is DPC latency! 

 

You can use a program called DPC latency checker to see if you get any spikes in latency.  These spikes cause audio glitches and dropouts when recording or playing back audio.  Sometimes these dropouts are neglible but if you are recrding music themn its not acceptable to have a glicth in the middle of a part! 

 

the problem has been quite obviously isolated to the Nvidia nvs3100m graphics casrds in the t510s and 410s...when the driver is disabled for this, the DPC latency is perfect, but the resolution obviously goes very low. 

 

What we are asking for is for Lenovo to sort out a new driver for thsi video card and to keep DPC latency at a minimum, as lots of people want to use these laptops for pro audio, and if this was sorted out then the4 Thinkpad could become a true rival of the macbook pro, but as it is people cant rely on it!

 

please anyone who is experiencing the same problem speak up and send in the details of your t510 and 410s so we can get this ball rolling

 

Cheers

 

 

Serial Port
robodelfy
Posts: 107
Registered: ‎09-07-2010
Location: UK
0

Re: T410 Extremely Annoying Audio Issues

 

  • Model    - Thinkpad t310
  • BIOS version    -   newest
  • OS loaded (ex. Win 7 Ulti x64)    Windows 7 32bit PRo
  • Lenovo default OS?    Windows 7 32bit pro
  • Issue happen on Battery / AC / Both?   Yes
  • Updates from TVSU completed?    yes
  • Updates from Windows Updates?    yes
  • Power Manager Version   -    newest
  • Power Management Driver     -     newest
  • RAM installed (brand and 1 x 4gb, 1 x 2gb, 2 x 2gb?)   4
  • Any error notification before issue occurred?      -  no
  • 3rd party application installed before issue happen?      - no
  • Any particular application which is running on the time this issue arises?    no
  • Docked on station? Any USB attached?             no
  • Additional comments which you think might help.      

This has nothing to do with any o f the above questions, the DPC latency is high because of the nvidia nvs3100m

  • Are you able to recreate the issue on demand?    yes
Retired Employee
JameZ
Posts: 3,110
Registered: ‎07-11-2010
Location: Malaysia
0

Re: T410 Extremely Annoying Audio Issues

[ Edited ]

Hi robotdelfy,

Thanks for your prompt feedback. Could we maybe get this more detailed? So far I understand there is a thread which is the T61 which is similar to the issue which you are facing but for theirs is the "audio stutter" ? is it the same like yours? Also the BIOS version, could you state the exact version of the BIOS? RAM 4GB is 1 x 4GB or 2 x 2GB ? any idea of the brand?

You could open the Lenovo Think Toolbox to check the versions of the drivers as well.

You mentioned you are able to recreate the issue on demand, can you provide the steps so I am able to cascade this information to engineering?

 

Also the Model of the laptop is available below your laptop xxxx-xxx (beside the serial number)

 

Appreciate your feedback.

//JameZ

Check out the Community Knowledge Base for hints and tips.


Did someone help you today? Press the star on the left to thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!




W520 | 4176-38U | i7 - 2720QM | Quardo 1000M | 8GB RAM | 60GB OCZ Agility 3

Serial Port
robodelfy
Posts: 107
Registered: ‎09-07-2010
Location: UK
0

Re: T410 Extremely Annoying Audio Issues

Hi jameZ

 

Ok, When using any laptop for recording purposes or even video, using programs such as logic, cubase, pro tools etc. you have to be able to record and playback without clicks, pops, glitches and stutters.  Amongst other things (mainly your audio interface) this is caused by spikes in DPC latency.  If you have spikes in your PDC latency then  it doesnt matter what else yuo do, you will have glicthes and drop outs in your audio.  Here is a tool for checking your DPC latency, it is a standalone program and  its free.

 

http://www.thesycon.de/deu/latency_check.shtml

 

I know that the sole cause of these spikes on the t510s and t410s is the nvida nvs3100m video card as people with intergrated graphics arent getting the same problem and if I disabel the drivers for the nvidia card I get very low DPC latency.  But....you can only get a lower resolution than the screens native resolution, which isnt really enough

 

So please use this tool to check t510s and 410s with discrete nvidia graphics.  Let the DPC latency checker run for a few minutes and open a few things while its running, windows media player, control panel etc.  then you should see red spikes.  then disable the nividia card in device manager and run Latency checker again, it should be all in the low green area.

 

I have bios version 1.27

 

1 x 4gb ram, I dont know the brand, you guys make the laptops dont you!

 

product ID - 4313CTO

 

 

i am so certain about what is causing this, and have found many other on other forums who are experiencing the same thing.  I know we are in the minority as far as people who buy Lenovo laptops are concerned, but its a very realy problem for pro audio.  Its not hardware related, so all we need is new drivers from you and nvidia. 

 

 

Please keep us updated

 

Thanks

 

 

Fanfold Paper
monty_mcmont
Posts: 3
Registered: ‎09-06-2010
Location: Leeds, UK
0

Re: T410 Extremely Annoying Audio Issues

Hey all,

 

I've been having the same DPC latency issue with my T510 (4313-CTO) under Windows 7 64-bit. If I uninstall the nVidia NVS 3100 driver and use the VGA driver the latency spikes disappear completely. The problem with this is that I can only run the display at 1280x800, and I can't use the external monitor output.

 

After a lot of reading around forums and web sites, I discovered that many other users are experiencing the same issue. The problem is undoubtedly caused by the nVidia driver on Windows 7 64-bit, and since Lenovo / nVidia don't seem to have fixed this issue after months of asking I've just ordered a set of Windows XP downgrade CDs. They cost me £40 which I'm not thrilled about, but it's not the end of the world. It's a real shame that the Windows 7 driver isn't up to scratch. When the problem is ironed out, maybe I'll switch back to Windows 7.

 

Peace,

Monty

 

p.s. Lenovo - your Indian call centre staff appear to be introducing themselves with obviously fake western names. Disregarding the fact that they were very helpful and efficient, telling a fib right from the word go doesn't give the impression of an honest and reputable company...

Serial Port
robodelfy
Posts: 107
Registered: ‎09-07-2010
Location: UK
0

Re: T410 Extremely Annoying Audio Issues

Hi Monty,

 

i didnt realise I couldnt use a second monitor, I was planning on just dealin with the lower resolution and using a second manitor until they fixed the problem!  can you not use the displayport out or the VGA out?

 

Also, is gouing back to XP going to make any difference for you, will it not be the same problem

 

 

Blue Screen Again
T410er
Posts: 8
Registered: ‎08-06-2010
Location: China
0

Re: T410 Extremely Annoying Audio Issues

Hi Jamez,

 

I updated the power manager driver and software, as well as the bios as you suggested.  Unfortunately, the issue remains.  I'm not sure if it is the same issue as what the guys have been talking about in the latter half of the thread.  The thread was originally about this loss of quality and switching between mono and stereo.  I'm not sure if it is connected to the latency issue or not (I tried the latency-related fix and it similarly was ineffective).  As I said before, it appears connected with the actual audio level of the sound file itself - as in louder parts the output will return to full stereo, while during quieter parts it will switch to mono and really low quality output.  Any other suggestions?

Serial Port
robodelfy
Posts: 107
Registered: ‎09-07-2010
Location: UK
0

Re: T410 Extremely Annoying Audio Issues

Hi t410er

 

Sorry the thread has changed slightltly, it seems t be the only place that the latency issue is getting even a tiny bit of attention!

 

When you say its switching between mono and stereo, do you mean that you suddenly hear there is no panning/stereo but out of both headphones.  So Mono summed together and coming out of left and right.  or do you mean  it just switched between coming out of one ear and then comes back to both, if so which does it switch to, left or right?

 

Sounds like it could be a hardware problem, a dodgy jack or something