Support in other languages: 
Reply
Serial Port
CustomerX
Posts: 22
Registered: ‎10-30-2009
Location: United States
0
Accepted Solution

T410 Text Selection Issue w/ Intel HD Graphics Driver for Windows 7 (32-bit)

[ Edited ]

After I upgraded to the latest Intel HD Graphics Driver for Windows 7 (32-bit) and Vista (32-bit) - ThinkPad T410, T410i, T410s, T410si, T510, T510i, X201, X201i, X201s and X201 Tablet

 

Version: 8.15.10.2025

Release Date: 2010/01/29

 

Which is located here.

 

I ran into weird issues while highlighting text. Essentially, my text highlights but might be different colors (some too light to even see). After getting this weird highlight, I can minimize, maximize, or move my window off and back onto the screen and the highlight will be all one color.

 

This issue goes away if I roll back to version 8.15.10.2008.

 

Example 1: IssueExample 1: Issue after maximize/restore window

 

Example 2: IssueExample 2: Issue after maximize/restore window

 

 

Serial Port
CustomerX
Posts: 22
Registered: ‎10-30-2009
Location: United States
0

Re: T410 Odd Issue w/ Intel HD Graphics Driver for Windows 7 (32-bit)

Can anyone else reproduce this phenomenon?

Punch Card
ayeaye
Posts: 9
Registered: ‎11-03-2008
Location: United Kingdom
0

Re: T410 Odd Issue w/ Intel HD Graphics Driver for Windows 7 (32-bit)

Yip - I have this too with the latest driver (8.15.10.2082) on my X301

Token Ring
warder
Posts: 121
Registered: ‎04-04-2008
Location: USA
0

Re: T410 Odd Issue w/ Intel HD Graphics Driver for Windows 7 (32-bit)

I've seen this... it's just a driver bug.  Lenovo are a few versions behind Intel's driver release so it may be fixed already.

Punch Card
aterphasma
Posts: 3
Registered: ‎04-02-2010
Location: Bellingham, WA
0

Re: T410 Odd Issue w/ Intel HD Graphics Driver for Windows 7 (32-bit)

Yeah, I've got that, too. I thought it was an Office 2010 issue since It doesn't seem to happen anywhere else.

 

Also, has anyone else noticed that sometimes the Z-order of 3D elements gets messed up sometimes? The primary example is the alt-tab window being hidden at the back of the current window once Aero Peek comes into play (you know, when you alt-tab and pause so the highlighted window becomes visible). I tracked it down to the On-Screen Display service, but you can't disable that without also losing a ton of functionality like all the Fn+ key combination windows.

 

On a related note, then, would anyone know of an easy way to install the official Intel Graphics drivers as opposed to the Lenovo version? Has Lenovo done anything to the drivers to make things run better? Are there "special features" I'd miss if I went with the Intel version?

Fanfold Paper
Faruk
Posts: 4
Registered: ‎06-13-2010
Location: Canada
0

Re: T410 Odd Issue w/ Intel HD Graphics Driver for Windows 7 (32-bit)

[ Edited ]

Wow I found this thread totally by coincidence, and boy am I glad to find out that I'm not the only one with this problem. I created an account just to reply to this thread :smileyhappy:

 

Months ago I had this problem on my Thinkpad X200 running Windows 7 Professional x64. I did not have the problem with Office 2007, but it appeared when I installed the Office 2010 beta.

 

Now I am using a Thinkpad X201 with Windows 7 Professional x64. And now I'm getting the same issue even in Office 2007. I posted about my problem here:

 

http://forum.notebookreview.com/lenovo-ibm/491527-weird-highlighting-problem-microsoft-word-anybody-...

 

I am also using the driver from Lenovo. I would love to get the driver directly from Intel, but my only gripe with that is having to give up the screen brightness indicator. I wish that Lenovo would just fix their Hotkey/OSD driver and let us get the graphics driver directly from Intel instead of making us wait ages for their version...

Serial Port
CustomerX
Posts: 22
Registered: ‎10-30-2009
Location: United States
0

Re: T410 Odd Issue w/ Intel HD Graphics Driver for Windows 7 (32-bit)

Faruk, please keep this thread updated if you find out the solution elsewhere. I have to deal with this issue (it really is very annoying and makes selecting hard to do) every day and it doesn't look like it will be getting fixed any time soon. I downloaded the drivers from Intel, but the installer doesn't allow them to be installed. I think it knows that I'm using a Lenovo and forces me to use the Lenovo branded drivers.

 

Do you know if Lenovo Support even looks at these threads and the issues posted here?

Fanfold Paper
Faruk
Posts: 4
Registered: ‎06-13-2010
Location: Canada
0

Re: T410 Odd Issue w/ Intel HD Graphics Driver for Windows 7 (32-bit)

Hey, actually the Intel drivers will work but you will have to completely uninstall the Lenovo drivers first. I used to use the Intel drivers for a long time, until I decided to switch to the Lenovo ones. However, I wouldn't recommend switching from one version to another without doing a clean install, because even after uninstalling one of the drivers there can be "traces" left behind. I actually learned this the "hard way", but thankfully still managed to get away without a clean install (by going and manually deleting certain files from the system folder).

Fanfold Paper
Faruk
Posts: 4
Registered: ‎06-13-2010
Location: Canada
0

Re: T410 Odd Issue w/ Intel HD Graphics Driver for Windows 7 (32-bit)

[ Edited ]

Update: I had a chat with an Intel technical support representative today.

 

He asked me if I tried using the drivers directly from Intel and I said no... And then he said that it is probably an issue with the OEM drivers and that he would notify some people.  But he suggested that I contact Lenovo if I want a faster response. I'm feeling a little lazy to pick up the phone and speak with Lenovo support though, to be honest...

 

Anybody feeling up to trying the Intel drivers or contacting Lenovo by phone? :smileytongue:

 

 

Edit: After reading your original post more carefully, I noticed that you said the issue goes away if you roll back to the previous driver... Then I think it's definitely worth contacting Lenovo and telling them that!

 

And by the way, I tried updating to this version:

http://www-307.ibm.com/pc/support/site.wss/MIGR-73678.html

 

And I still have the issue...

Fanfold Paper
Faruk
Posts: 4
Registered: ‎06-13-2010
Location: Canada
0

Re: T410 Odd Issue w/ Intel HD Graphics Driver for Windows 7 (32-bit)

Update #2:

 

I uninstalled the Lenovo driver and installed the one directly from Intel's web site.

 

Surprise surprise... the issue is gone. But also gone is the OSD for the brightness indicator.

 

Looks like Lenovo sucks at making drivers. We might even have better luck contacting Intel to make their driver stop breaking Lenovo's OSD. I think I will stick with the Intel driver for now.