Support in other languages: 
Reply
Serial Port
rednasy
Posts: 67
Registered: ‎04-21-2009
Location: Riga, Latvia
0
Accepted Solution

[T410] discrete gfx - Problem with Video Card and Windows Aero -anyone using 4Gb memory modules?

[ Edited ]

[3/3/2010 Update]

There's a issue of using 4Gb sticks on T410 currently that results in video output artifacts and aero interface problems when using Lenovo supplied drivers v8.16.11.8825. I think I can call it confirmed (Three people including me face this issue).

 

Possible workaround is to install modified EliteBook 8440p video driver (read along this thread) comes with a BIG drawback of not being able to change brightness level within Windows 7. To sweeten it a little bit - you can set luminance level at POST screen, when computer boots up.

 

[Original Message]

Encountered strange behavoir of my T410.

 

I have a T410 with 256Mb of Video Memory and 1440x900 display, a T61 with 128Mb of Video Memory and 1400x1050 dsplay and external monitor HP w2338h with 1920x1080 resolution.

 

If I connect external monitor to my T410 and launch Visual Studio 2010 Beta 2 - image blinks and comes back with Aero disabled. Looking through event logs reveals the lack of memory. Entry information can be found further.

 

Now If I do the same with my old Thinkpad T61, connect the same monitor using the same cable - I can open as many Visual Studio 2010 Beta 2 instances I like (tried 5) and nothing blinks and Aero stays enabled.

 

Actually I find ridiculous, a notebook with more VRAM cannot archive the same performance as notebooks with less.

 

Does anyone know what path should I pursue to solve this issue?

 

UPDATE: Simply running multiple instances of Visual Studio 2010 Beta 2 without external monitor causes Aero disabled as well.

 

Log Name:      Application
Source:        Desktop Window Manager
Date:          2/4/2010 7:32:21 PM
Event ID:      9020
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:     

Description:
The Desktop Window Manager has encountered a fatal error (0x8007000e)
Error 2/4/2010 7:32:21 PM Desktop Window Manager 9020 None

 

 

Punch Card
erik_h
Posts: 75
Registered: ‎01-15-2010
Location: Massachusetts
0

Re: [T410] Problem with Video Card and Windows Aero

have you ensured that you have the latest Intel AMT and NVIDIA drivers?

 

Guru
sys3175
Posts: 367
Registered: ‎02-12-2009
Location: Austin, TX
0

Re: [T410] Problem with Video Card and Windows Aero

I would say you are running Beta software, perhaps it would be best to raise this conern with MS since it is quite likely that this is a bug in their software which presents itself on your hardware, assuming that it is the only application which exhibits this behavior.

 

Thinkpad T500-2081 CTO | T9400 2.53GHz | 8 GB RAM | ATI HD3650 + Intel GM45 | 15.4" LED WXGA+ | Windows 8 | ATI Catalyst 13.1 (non-switchable)
Thinkpad 390x | PII 333 | 256mb ram | NeoMagic 256AV | SVGA LCD | OS/2 v4.52
Ctrl-Alt-Del
bradhs
Posts: 25
Registered: ‎05-17-2008
Location: San Diego, CA
0

Re: [T410] Problem with Video Card and Windows Aero

Download newer video drivers from www.laptopvideo2go.com or www.nvidia.com..  Your video card is aka Quadro NVS 140M.

Serial Port
rednasy
Posts: 67
Registered: ‎04-21-2009
Location: Riga, Latvia
0

Re: [T410] Problem with Video Card and Windows Aero

erik_h,

 

Yes I did reinstall all the drivers I could find off the Lenovo site, with no success. Then I tried Nvidia (WHQL and Beta) packages (modified .inf file that came along). That resulted in less natural colors of the video output, but didn't solve the problem.

 

sys3175,

That what I'm leaning toward too. Everything else is working as expected, it's only Visual Studio 2010 Beta 2 that gives me the troubles only on this particular computer.

 

bradhs,

NVS140M is a T61 video card I have no problems with.

NVS3100M is the card giving me troubles.

 

 

I'm still in process of collecting information to make my judgements of the my problem. So far I can only reproduce it with Visual Studio 2010 Beta 2.

 

Blue Screen Again
mat3y
Posts: 11
Registered: ‎02-08-2010
Location: Slovenia
0

Re: [T410] Problem with Video Card and Windows Aero

I have the same problem with T410 and aero disabled.  I am not using VS and I get this error anyway.

 

The Desktop Window Manager has encountered a fatal error (0x8007000e).

 

This must be buggy drivers, on Lenovo download site is just the one and the only initial driver for T410 graphics card.

Serial Port
rednasy
Posts: 67
Registered: ‎04-21-2009
Location: Riga, Latvia
0

Re: [T410] Problem with Video Card and Windows Aero

Welcome to the boat, I started to think that I'm the only one with this problem. But given you're having the same problem, I'm leaning toward contacting support service and open up a case.

Guru
sys3175
Posts: 367
Registered: ‎02-12-2009
Location: Austin, TX
0

Re: [T410] Problem with Video Card and Windows Aero

 


mat3y wrote:

I have the same problem with T410 and aero disabled.  I am not using VS and I get this error anyway.

 

The Desktop Window Manager has encountered a fatal error (0x8007000e).

 

This must be buggy drivers, on Lenovo download site is just the one and the only initial driver for T410 graphics card.


 

What software were you actively using when this error occured?

 

Thinkpad T500-2081 CTO | T9400 2.53GHz | 8 GB RAM | ATI HD3650 + Intel GM45 | 15.4" LED WXGA+ | Windows 8 | ATI Catalyst 13.1 (non-switchable)
Thinkpad 390x | PII 333 | 256mb ram | NeoMagic 256AV | SVGA LCD | OS/2 v4.52
Blue Screen Again
mat3y
Posts: 11
Registered: ‎02-08-2010
Location: Slovenia
0

Re: [T410] Problem with Video Card and Windows Aero

When I tried to switch between applications with Alt+Tab. Sometimes if I stop and then start Desktop Windows Manager, Aero start working again but in most times it does not.

Guru
sys3175
Posts: 367
Registered: ‎02-12-2009
Location: Austin, TX
0

Re: [T410] Problem with Video Card and Windows Aero

Are you using the latest drivers found here:

 

http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-74582

Thinkpad T500-2081 CTO | T9400 2.53GHz | 8 GB RAM | ATI HD3650 + Intel GM45 | 15.4" LED WXGA+ | Windows 8 | ATI Catalyst 13.1 (non-switchable)
Thinkpad 390x | PII 333 | 256mb ram | NeoMagic 256AV | SVGA LCD | OS/2 v4.52