Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
popsch
Posts: 4
Registered: ‎03-11-2012
Location: Canada
0
Accepted Solution

T420 BIOS 1.34 can't update BIOS

Hi,

 

  I'm currently running UEFI BIOS 1.34 (ECP 1.11). Lenovo ships 1.37. I burnt a CD with 1.37 to update my BIOS, but the utility tells me that an update is unncessary. I want to update the BIOS, because I have problems during booting when I have USB devices plugged in.

 

Does anyone know a good solution?

 

Thanks.

Bit Torrent
ThorsHammer
Posts: 2,400
Registered: ‎04-08-2011
Location: USA
0

Re: T420 BIOS 1.34 can't update BIOS

I would download the BIOS and burn another CD then try again.

Guru
ColonelONeill
Posts: 6,641
Registered: ‎12-26-2009
Location: Toronto
0

Re: T420 BIOS 1.34 can't update BIOS

You may want to avoid BIOS/UEFI updates if system stability may be an issue to avoid bricking it.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Bit Torrent
ThorsHammer
Posts: 2,400
Registered: ‎04-08-2011
Location: USA
0

Re: T420 BIOS 1.34 can't update BIOS

It's likely under warranty still.  I don't think the T420 started shipping until aorund now last year.

Paper Tape
popsch
Posts: 4
Registered: ‎03-11-2012
Location: Canada
0

Re: T420 BIOS 1.34 can't update BIOS

It's the right version of the CD. I double checked. It didn't help. Any other ideas?
Paper Tape
popsch
Posts: 4
Registered: ‎03-11-2012
Location: Canada
0

Re: T420 BIOS 1.34 can't update BIOS

It's still under warranty, however, I just want to updated the BIOS, not return it.
Bit Torrent
ThorsHammer
Posts: 2,400
Registered: ‎04-08-2011
Location: USA
0

Re: T420 BIOS 1.34 can't update BIOS

Have you tried updating via the .EXE instead?

Paper Tape
popsch
Posts: 4
Registered: ‎03-11-2012
Location: Canada
0

Re: T420 BIOS 1.34 can't update BIOS

[ Edited ]

Somehow downloading it again and reburning the CD helped. I have no clue. It was the same file.

 

Thanks for the repies and help!