Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
What's DOS?
Miba
Posts: 1
Registered: ‎06-22-2011
Location: Denmark
0

T420 - Slow wireless connection

[ Edited ]

Hi

 

I just got my new Thinkpad T420 a couple of days ago now, but the wireless network / internet connection is bugging me.

 

I am unable to obtain anything higher than ~60kb/s, just occasionally it will land on 800kb/s for a brief second and then return to 60kb/s. Our internet connection should allow the T420 to download with 1MB/s, but settles at those 60kb/s.

 

I have already tried to download every update through Lenovo's System Update 4 and Microsoft Update. I have also tried to download the drivers for the T420's wireless network card:

 

Intel(R) Centrino(R) Advanced-N 6205

 

Connecting the T420 to a wired connection makes it go at the 1MB/s that it should do with wireless connection too.

 

I am really clueless about what to do with this situation.

Paper Tape
kevmitch
Posts: 4
Registered: ‎02-10-2011
Location: Vancovuer, BC
0

Re: T420 - Slow wireless connection

What kind of router do you have? Have you tested other machines/wireless cards with the same router? Are they also 11n cards? What about trying the machine with different routers (i.e., take the t420 to a coffee shop and see if the same thing happens there). Take a look in your router settings. In particular see if enabling/disabling 11n functionality (if it has it) helps at all.
Paper Tape
kevmitch
Posts: 4
Registered: ‎02-10-2011
Location: Vancovuer, BC
0

Re: T420 - Slow wireless connection

Oh, and you might want to check if there are any wireless powersaving options on the machine itself.
What's DOS?
rfurtado
Posts: 1
Registered: ‎08-09-2014
Location: North York
0

Re: T420 - Slow wireless connection

Similar problem...

Internet should be up to 45Mbps download, Other computers are getting close to that ranging from 42-44Mbps, but the Lenovo T420 never gets over 28Mbps.

- Wirelss Adapter setting already in "Maximum Performance". 

- Since it's my company's computer, I cannot remove Access Connections

- Device Manager: driver is up to date. 802.11 for band 2.4 and 5.2 are "Auto". I enabled the Ad Hoc QoS Mode, but it made no difference.

 

Any other ideas?