Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Punch Card
spudgun79
Posts: 15
Registered: ‎03-08-2011
Location: uk
0

T420 losing mouse and keyboard when docking

Hi All,

 

I have seen quite a few cases now upon docking a T20, you will lose your mouse and keyboard.(screen is ok)

 

In most cases they come back to life within 30 seconds, sometimes requires a re-dock. In worst cases a full reboot. (only seen this once)

 

Any ideas on what would cause this or is this a common fault?

 

Cheers!

 

Punch Card
spudgun79
Posts: 15
Registered: ‎03-08-2011
Location: uk
0

Re: T420 losing mouse and keyboard when docking

This issue is occurring on both wired and wireless usb mouse and keyboard.

 

is this a docking station issue or maybe out dated bios? Our laptops all have bit locker configured so I'd like to find out if its a common issue before I de-crypt and update bios, it can take up quite a bit of time..

 

any thoughts greatly appreciated!

 

 

Bit Torrent
tripplec
Posts: 1,472
Registered: ‎03-08-2012
Location: Toronto, Ontario Canada
0

Re: T420 losing mouse and keyboard when docking

Image another drive from the Recovery media and drop it in. Test with that. The image process should not take long at SATA speeds.

BE CAREFUL THOUGH - IF UPDATING THE BIOS AFFECTS THE ENCRYPTION. If shouldn't and I don't see why but Triple Check that point.
T520 Model 4239 Intel(R) Core(TM) i7-2860QM CPU @ 2.50GHz
Intel Sandy Bridge & Nvidia NVS 4200M graphics Intel N 6300 Wi-Fi adapter
Windows 7 Home Prem - 64bit w/8GB DDR3
Punch Card
spudgun79
Posts: 15
Registered: ‎03-08-2011
Location: uk
0

Re: T420 losing mouse and keyboard when docking

any other ideas?

Punch Card
spudgun79
Posts: 15
Registered: ‎03-08-2011
Location: uk
0

Re: T420 losing mouse and keyboard when docking

update:

Now upon leaving workstation for period over 30 mins and returning, the laptop docks and usb devices are not recognised. You can refresh services and usb devices in device manager, re-dock, re-seat usb devices, but no joy.

 

If you unplug the power supply to the dock, this can get them back however. 

 

Have tried replacing dock, usb mouse, usb keyboard. Although without succuss, behaviour remains the same.

 

Has anyone else seen this issue with a T420? OR anything else for that matter, we're running out of ideas!

 

Many thanks.,.

Hiro
Posts: 444
Kudos: 88
Solutions: 22
Registered: ‎05-26-2012
Location: Raleigh, North carolina
0

Re: T420 losing mouse and keyboard when docking

Hey Spudgun79,

 

Can you tell me what version of BIOS you have? Also what docking station your using?

 

Best Regards,

 

Hiro

Did you find a post Awesome? A response just Outstanding? Kudo them!
Did the post you read answer your question? Did someone help you figure out your problem? Hit Solution Provided and give that person a pat on the back for helping you out!
Paper Tape
anopie
Posts: 2
Registered: ‎07-26-2012
Location: USA
0

Re: T420 losing mouse and keyboard when docking

I have seen this issue or very similar if you do not have the 90w 20v power supply connected to the dock.

Punch Card
spudgun79
Posts: 15
Registered: ‎03-08-2011
Location: uk
0

Re: T420 losing mouse and keyboard when docking

Hi,

 

Dock is a ThinkPad Mini Dock Series 3, using 90w power supply. We have tried swapping the dock, but this hasn't resolved.

 

Using system update, we have updated the BIOS to the latest version

 

thanks

Punch Card
spudgun79
Posts: 15
Registered: ‎03-08-2011
Location: uk
0

Re: T420 losing mouse and keyboard when docking

shameless BUMP

 

we've had engineer swap out the system board to try and resovle this problem but no joy. any other suggestions?

Punch Card
spudgun79
Posts: 15
Registered: ‎03-08-2011
Location: uk
0

Re: T420 losing mouse and keyboard when docking

This is now becoming a common issue with T420s, is anyone else experiencing this issue?